summaryrefslogtreecommitdiff
path: root/python-insightconnect-integrations-plugin-spec-tooling.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-insightconnect-integrations-plugin-spec-tooling.spec')
-rw-r--r--python-insightconnect-integrations-plugin-spec-tooling.spec208
1 files changed, 208 insertions, 0 deletions
diff --git a/python-insightconnect-integrations-plugin-spec-tooling.spec b/python-insightconnect-integrations-plugin-spec-tooling.spec
new file mode 100644
index 0000000..318f927
--- /dev/null
+++ b/python-insightconnect-integrations-plugin-spec-tooling.spec
@@ -0,0 +1,208 @@
+%global _empty_manifest_terminate_build 0
+Name: python-insightconnect-integrations-plugin-spec-tooling
+Version: 1.3.1
+Release: 1
+Summary: Plugin spec parser tooling for InsightConnect integrations
+License: MIT
+URL: https://github.com/rapid7/icon-integrations-plugin-spec
+Source0: https://mirrors.aliyun.com/pypi/web/packages/5b/d9/f089c45931a6fc272c14a7cbb5543ed800572b80e97f3f53e426bc4ba7c6/insightconnect_integrations_plugin_spec_tooling-1.3.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-PyYAML
+
+%description
+
+# InsightConnect Integrations Plugin Spec
+
+## What this is
+
+A tool for parsing a
+[Rapid7 InsightConnect](https://www.rapid7.com/products/insightconnect/) integration
+plugin spec file _(plugin.spec.yaml)_ and interacting with it programmatically.
+
+## Installation
+
+### Install the module via `pip`
+
+```
+$ pip install insightconnect-integrations-plugin-spec-tooling
+```
+
+## Okay great, but how do I use it
+
+Simple!
+
+```
+from typing import Any
+from icon_plugin_spec.plugin_spec import KomandPluginSpec, PluginComponent
+
+spec: KomandPluginSpec = KomandPluginSpec(directory="path_to_my_plugin")
+raw_connection: {str: Any} = spec.connection() # Dictionary of connection properties
+
+print(raw_connection) # Prints out list of inputs on the connection
+
+# or, do the following
+connection: PluginComponent = PluginComponent.new_connection(raw=raw_connection)
+print(connection.inputs)
+```
+
+## Changelog
+
+* 1.3.1 - Update ruamel.yaml to work with Python 3.9
+* 1.3.0 - Add functionality to support plugin tasks
+* 1.2.0 - Add functionality to check if a plugin is cloud ready
+* 1.1.0 - Add functionality to check if a plugin is obsolete
+* 1.0.0 - Initial
+
+
+
+
+
+%package -n python3-insightconnect-integrations-plugin-spec-tooling
+Summary: Plugin spec parser tooling for InsightConnect integrations
+Provides: python-insightconnect-integrations-plugin-spec-tooling
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-insightconnect-integrations-plugin-spec-tooling
+
+# InsightConnect Integrations Plugin Spec
+
+## What this is
+
+A tool for parsing a
+[Rapid7 InsightConnect](https://www.rapid7.com/products/insightconnect/) integration
+plugin spec file _(plugin.spec.yaml)_ and interacting with it programmatically.
+
+## Installation
+
+### Install the module via `pip`
+
+```
+$ pip install insightconnect-integrations-plugin-spec-tooling
+```
+
+## Okay great, but how do I use it
+
+Simple!
+
+```
+from typing import Any
+from icon_plugin_spec.plugin_spec import KomandPluginSpec, PluginComponent
+
+spec: KomandPluginSpec = KomandPluginSpec(directory="path_to_my_plugin")
+raw_connection: {str: Any} = spec.connection() # Dictionary of connection properties
+
+print(raw_connection) # Prints out list of inputs on the connection
+
+# or, do the following
+connection: PluginComponent = PluginComponent.new_connection(raw=raw_connection)
+print(connection.inputs)
+```
+
+## Changelog
+
+* 1.3.1 - Update ruamel.yaml to work with Python 3.9
+* 1.3.0 - Add functionality to support plugin tasks
+* 1.2.0 - Add functionality to check if a plugin is cloud ready
+* 1.1.0 - Add functionality to check if a plugin is obsolete
+* 1.0.0 - Initial
+
+
+
+
+
+%package help
+Summary: Development documents and examples for insightconnect-integrations-plugin-spec-tooling
+Provides: python3-insightconnect-integrations-plugin-spec-tooling-doc
+%description help
+
+# InsightConnect Integrations Plugin Spec
+
+## What this is
+
+A tool for parsing a
+[Rapid7 InsightConnect](https://www.rapid7.com/products/insightconnect/) integration
+plugin spec file _(plugin.spec.yaml)_ and interacting with it programmatically.
+
+## Installation
+
+### Install the module via `pip`
+
+```
+$ pip install insightconnect-integrations-plugin-spec-tooling
+```
+
+## Okay great, but how do I use it
+
+Simple!
+
+```
+from typing import Any
+from icon_plugin_spec.plugin_spec import KomandPluginSpec, PluginComponent
+
+spec: KomandPluginSpec = KomandPluginSpec(directory="path_to_my_plugin")
+raw_connection: {str: Any} = spec.connection() # Dictionary of connection properties
+
+print(raw_connection) # Prints out list of inputs on the connection
+
+# or, do the following
+connection: PluginComponent = PluginComponent.new_connection(raw=raw_connection)
+print(connection.inputs)
+```
+
+## Changelog
+
+* 1.3.1 - Update ruamel.yaml to work with Python 3.9
+* 1.3.0 - Add functionality to support plugin tasks
+* 1.2.0 - Add functionality to check if a plugin is cloud ready
+* 1.1.0 - Add functionality to check if a plugin is obsolete
+* 1.0.0 - Initial
+
+
+
+
+
+%prep
+%autosetup -n insightconnect_integrations_plugin_spec_tooling-1.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-insightconnect-integrations-plugin-spec-tooling -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.1-1
+- Package Spec generated