summaryrefslogtreecommitdiff
path: root/python-intents.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 11:55:15 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 11:55:15 +0000
commit1de82b80d1b3b7f8bc5fe4499dcf23249af12bd7 (patch)
tree30e4ec17d84dc36c1fb795f5f5eb21967c2b0ff8 /python-intents.spec
parent8273c4393e858225486f54e666fc1e0632a2d24b (diff)
automatic import of python-intents
Diffstat (limited to 'python-intents.spec')
-rw-r--r--python-intents.spec304
1 files changed, 304 insertions, 0 deletions
diff --git a/python-intents.spec b/python-intents.spec
new file mode 100644
index 0000000..88b8ac1
--- /dev/null
+++ b/python-intents.spec
@@ -0,0 +1,304 @@
+%global _empty_manifest_terminate_build 0
+Name: python-intents
+Version: 0.3.0
+Release: 1
+Summary: Define and operate Dialogflow Agents with a simple, code-first, approach
+License: Apache-2.0
+URL: https://github.com/dariowho/intents
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d1/cf/c50e584f1cd753a67c07d4bf523f8d45f8477ec71e8b95ce787974fe55f0/intents-0.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyyaml
+Requires: python3-google-cloud-dialogflow
+Requires: python3-dacite
+Requires: python3-snips-nlu[snips]
+
+%description
+# Intents ⛺
+
+[![Documentation Status](https://readthedocs.org/projects/intents/badge/?version=latest)](https://intents.readthedocs.io/en/latest/?badge=latest)
+[![codecov](https://codecov.io/gh/dariowho/intents/branch/master/graph/badge.svg?token=XAVLW70J8S)](https://codecov.io/gh/dariowho/intents)
+[![HEAD version](https://img.shields.io/badge/head-v0.3.0-blue.svg)](https://img.shields.io/badge/head-v0.3.0-blue.svg)
+[![PyPI version](https://badge.fury.io/py/intents.svg)](https://badge.fury.io/py/intents)
+
+**Intents** is a Python framework to define and operate
+Conversational Agents with a simple, code-first approach. *Intents* comes with
+built-in support for Dialogflow ES and experimental Alexa and Snips connectors. Its main benefits are:
+
+* **Agents are Python projects**. You will develop with autocomplete, static type checking
+ and everything you are already used to.
+* **Versioning and CI**. Agents can be versioned on Git, and programmatically
+ deployed just like software.
+* **Human-friendly Connectors**. Intents are classes, predictions are their
+ instances. Support can be extended beyond Dialogflow by implementing custom connectors.
+
+A detailed view of the available features can be found in
+[STATUS.md](STATUS.md). Also, check out the
+[Projects](https://github.com/dariowho/intents/projects) page to keep track of
+recent developments.
+
+## Install
+
+```sh
+pip install intents
+```
+
+## Usage
+
+Intents are defined like standard Python **dataclasses**:
+
+```python
+@dataclass
+class HelloIntent(Intent):
+ """A little docstring for my Intent class"""
+ user_name: Sys.Person = "Guido"
+MyAgent.register(HelloIntent)
+```
+
+Their **language** resources are stored in separate YAML files:
+
+```yaml
+utterances:
+ - Hi! My name is $user_name{Guido}
+ - Hello there, I'm $user_name{Mario}
+
+responses:
+ default:
+ - text:
+ - Hi $user_name
+ - Hello $user_name, this is Bot!
+```
+
+Agents can be **uploaded** as Dialogflow ES projects directly from code:
+
+```python
+df = DialogflowEsConnector('/path/to/service-account.json', MyAgent)
+df.upload() # You will find it in your Dialogflow Console
+```
+
+*Intents* will act transparently as a **prediction** client:
+
+```python
+predicted = df.predict("Hi there, my name is Mario")
+predicted.intent # HelloIntent(user_name="Mario")
+predicted.intent.user_name # "Mario"
+predicted.fulfillment_text # "Hello Mario, this is Bot!"
+```
+
+For a complete working example, check out the included [Example Agent](example_agent/). Also, *Intents* **documentation** is published at https://intents.readthedocs.io/ 📚
+
+## Disclaimer
+
+*This project is not affiliated, associated, authorized, endorsed by, or in any way officially connected with Dialogflow. The names Dialogflow, Google, as well as related names, marks, emblems and images are registered trademarks of their respective owners.*
+
+
+%package -n python3-intents
+Summary: Define and operate Dialogflow Agents with a simple, code-first, approach
+Provides: python-intents
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-intents
+# Intents ⛺
+
+[![Documentation Status](https://readthedocs.org/projects/intents/badge/?version=latest)](https://intents.readthedocs.io/en/latest/?badge=latest)
+[![codecov](https://codecov.io/gh/dariowho/intents/branch/master/graph/badge.svg?token=XAVLW70J8S)](https://codecov.io/gh/dariowho/intents)
+[![HEAD version](https://img.shields.io/badge/head-v0.3.0-blue.svg)](https://img.shields.io/badge/head-v0.3.0-blue.svg)
+[![PyPI version](https://badge.fury.io/py/intents.svg)](https://badge.fury.io/py/intents)
+
+**Intents** is a Python framework to define and operate
+Conversational Agents with a simple, code-first approach. *Intents* comes with
+built-in support for Dialogflow ES and experimental Alexa and Snips connectors. Its main benefits are:
+
+* **Agents are Python projects**. You will develop with autocomplete, static type checking
+ and everything you are already used to.
+* **Versioning and CI**. Agents can be versioned on Git, and programmatically
+ deployed just like software.
+* **Human-friendly Connectors**. Intents are classes, predictions are their
+ instances. Support can be extended beyond Dialogflow by implementing custom connectors.
+
+A detailed view of the available features can be found in
+[STATUS.md](STATUS.md). Also, check out the
+[Projects](https://github.com/dariowho/intents/projects) page to keep track of
+recent developments.
+
+## Install
+
+```sh
+pip install intents
+```
+
+## Usage
+
+Intents are defined like standard Python **dataclasses**:
+
+```python
+@dataclass
+class HelloIntent(Intent):
+ """A little docstring for my Intent class"""
+ user_name: Sys.Person = "Guido"
+MyAgent.register(HelloIntent)
+```
+
+Their **language** resources are stored in separate YAML files:
+
+```yaml
+utterances:
+ - Hi! My name is $user_name{Guido}
+ - Hello there, I'm $user_name{Mario}
+
+responses:
+ default:
+ - text:
+ - Hi $user_name
+ - Hello $user_name, this is Bot!
+```
+
+Agents can be **uploaded** as Dialogflow ES projects directly from code:
+
+```python
+df = DialogflowEsConnector('/path/to/service-account.json', MyAgent)
+df.upload() # You will find it in your Dialogflow Console
+```
+
+*Intents* will act transparently as a **prediction** client:
+
+```python
+predicted = df.predict("Hi there, my name is Mario")
+predicted.intent # HelloIntent(user_name="Mario")
+predicted.intent.user_name # "Mario"
+predicted.fulfillment_text # "Hello Mario, this is Bot!"
+```
+
+For a complete working example, check out the included [Example Agent](example_agent/). Also, *Intents* **documentation** is published at https://intents.readthedocs.io/ 📚
+
+## Disclaimer
+
+*This project is not affiliated, associated, authorized, endorsed by, or in any way officially connected with Dialogflow. The names Dialogflow, Google, as well as related names, marks, emblems and images are registered trademarks of their respective owners.*
+
+
+%package help
+Summary: Development documents and examples for intents
+Provides: python3-intents-doc
+%description help
+# Intents ⛺
+
+[![Documentation Status](https://readthedocs.org/projects/intents/badge/?version=latest)](https://intents.readthedocs.io/en/latest/?badge=latest)
+[![codecov](https://codecov.io/gh/dariowho/intents/branch/master/graph/badge.svg?token=XAVLW70J8S)](https://codecov.io/gh/dariowho/intents)
+[![HEAD version](https://img.shields.io/badge/head-v0.3.0-blue.svg)](https://img.shields.io/badge/head-v0.3.0-blue.svg)
+[![PyPI version](https://badge.fury.io/py/intents.svg)](https://badge.fury.io/py/intents)
+
+**Intents** is a Python framework to define and operate
+Conversational Agents with a simple, code-first approach. *Intents* comes with
+built-in support for Dialogflow ES and experimental Alexa and Snips connectors. Its main benefits are:
+
+* **Agents are Python projects**. You will develop with autocomplete, static type checking
+ and everything you are already used to.
+* **Versioning and CI**. Agents can be versioned on Git, and programmatically
+ deployed just like software.
+* **Human-friendly Connectors**. Intents are classes, predictions are their
+ instances. Support can be extended beyond Dialogflow by implementing custom connectors.
+
+A detailed view of the available features can be found in
+[STATUS.md](STATUS.md). Also, check out the
+[Projects](https://github.com/dariowho/intents/projects) page to keep track of
+recent developments.
+
+## Install
+
+```sh
+pip install intents
+```
+
+## Usage
+
+Intents are defined like standard Python **dataclasses**:
+
+```python
+@dataclass
+class HelloIntent(Intent):
+ """A little docstring for my Intent class"""
+ user_name: Sys.Person = "Guido"
+MyAgent.register(HelloIntent)
+```
+
+Their **language** resources are stored in separate YAML files:
+
+```yaml
+utterances:
+ - Hi! My name is $user_name{Guido}
+ - Hello there, I'm $user_name{Mario}
+
+responses:
+ default:
+ - text:
+ - Hi $user_name
+ - Hello $user_name, this is Bot!
+```
+
+Agents can be **uploaded** as Dialogflow ES projects directly from code:
+
+```python
+df = DialogflowEsConnector('/path/to/service-account.json', MyAgent)
+df.upload() # You will find it in your Dialogflow Console
+```
+
+*Intents* will act transparently as a **prediction** client:
+
+```python
+predicted = df.predict("Hi there, my name is Mario")
+predicted.intent # HelloIntent(user_name="Mario")
+predicted.intent.user_name # "Mario"
+predicted.fulfillment_text # "Hello Mario, this is Bot!"
+```
+
+For a complete working example, check out the included [Example Agent](example_agent/). Also, *Intents* **documentation** is published at https://intents.readthedocs.io/ 📚
+
+## Disclaimer
+
+*This project is not affiliated, associated, authorized, endorsed by, or in any way officially connected with Dialogflow. The names Dialogflow, Google, as well as related names, marks, emblems and images are registered trademarks of their respective owners.*
+
+
+%prep
+%autosetup -n intents-0.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-intents -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.0-1
+- Package Spec generated