summaryrefslogtreecommitdiff
path: root/python-japanera.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-japanera.spec')
-rw-r--r--python-japanera.spec112
1 files changed, 112 insertions, 0 deletions
diff --git a/python-japanera.spec b/python-japanera.spec
new file mode 100644
index 0000000..2f8001d
--- /dev/null
+++ b/python-japanera.spec
@@ -0,0 +1,112 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Japanera
+Version: 2.0.0
+Release: 1
+Summary: Easy japanese era tool
+License: MIT
+URL: https://github.com/nagataaaas/Japanera
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/75/cd/0fec0857dca597e2cb56548d88f2db31278944c8651ef54b52a359f1d2d8/Japanera-2.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-kanjize
+
+%description
+Powered by [Yamato Nagata](https://twitter.com/514YJ)
+[GitHub](https://github.com/delta114514/Japanera)
+[ReadTheDocs](https://japanera.readthedocs.io/en/latest/)
+```python
+>>> from datetime import date
+>>> from japanera import EraDate
+>>> today = EraDate.from_date(date.today())
+>>> date(2020, 4, 16) in today.era
+True
+>>> "Current Japanese Era is <{}>: <{}>".format(today.era.kanji, today.era.english)
+Current Japanese Era is <令和>: <Reiwa>
+>>> "Current Date is <{}>".format(today.strftime("%-K%-y年%m月%d日"))
+Current Date is <令和05年03月07日>
+```
+
+%package -n python3-Japanera
+Summary: Easy japanese era tool
+Provides: python-Japanera
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Japanera
+Powered by [Yamato Nagata](https://twitter.com/514YJ)
+[GitHub](https://github.com/delta114514/Japanera)
+[ReadTheDocs](https://japanera.readthedocs.io/en/latest/)
+```python
+>>> from datetime import date
+>>> from japanera import EraDate
+>>> today = EraDate.from_date(date.today())
+>>> date(2020, 4, 16) in today.era
+True
+>>> "Current Japanese Era is <{}>: <{}>".format(today.era.kanji, today.era.english)
+Current Japanese Era is <令和>: <Reiwa>
+>>> "Current Date is <{}>".format(today.strftime("%-K%-y年%m月%d日"))
+Current Date is <令和05年03月07日>
+```
+
+%package help
+Summary: Development documents and examples for Japanera
+Provides: python3-Japanera-doc
+%description help
+Powered by [Yamato Nagata](https://twitter.com/514YJ)
+[GitHub](https://github.com/delta114514/Japanera)
+[ReadTheDocs](https://japanera.readthedocs.io/en/latest/)
+```python
+>>> from datetime import date
+>>> from japanera import EraDate
+>>> today = EraDate.from_date(date.today())
+>>> date(2020, 4, 16) in today.era
+True
+>>> "Current Japanese Era is <{}>: <{}>".format(today.era.kanji, today.era.english)
+Current Japanese Era is <令和>: <Reiwa>
+>>> "Current Date is <{}>".format(today.strftime("%-K%-y年%m月%d日"))
+Current Date is <令和05年03月07日>
+```
+
+%prep
+%autosetup -n Japanera-2.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Japanera -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.0-1
+- Package Spec generated