summaryrefslogtreecommitdiff
path: root/python-jenkins-epo.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 05:57:14 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 05:57:14 +0000
commit9c4a91bafc92339b1acc875a5c6b2e49057b78e0 (patch)
treebc85ce71bf84e528d26b4a7656eab335aa3e5f1d /python-jenkins-epo.spec
parent22221e7710340547c6fcc57649476a31ee1d3f28 (diff)
automatic import of python-jenkins-epo
Diffstat (limited to 'python-jenkins-epo.spec')
-rw-r--r--python-jenkins-epo.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-jenkins-epo.spec b/python-jenkins-epo.spec
new file mode 100644
index 0000000..1b04532
--- /dev/null
+++ b/python-jenkins-epo.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jenkins-epo
+Version: 1.160
+Release: 1
+Summary: Leverage Jenkins features for GitHub repositories.
+License: GPL v3 or later
+URL: http://jenkins-epo.rtfd.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/1b/ee7066c81b83137d85e9343f9be6ef8b2aa49582fbe7fc4ec957261e61c6/jenkins-epo-1.160.tar.gz
+BuildArch: noarch
+
+
+%description
+- Define jobs from repository in `jenkins.yml
+ <https://github.com/novafloss/jenkins-yml>`_.
+- Jobs pipeline façon GitLab CI.
+- Query GitHub API to poll open PR instead of polling git repository.
+- Read instructions from PR comments.
+- Cancel running jobs when pushing new commits.
+- Report issue on broken protected branches.
+- Auto-merge PR.
+- Works with webhook and/or behind firewall.
+- Extensible through entry-point.
+
+%package -n python3-jenkins-epo
+Summary: Leverage Jenkins features for GitHub repositories.
+Provides: python-jenkins-epo
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jenkins-epo
+- Define jobs from repository in `jenkins.yml
+ <https://github.com/novafloss/jenkins-yml>`_.
+- Jobs pipeline façon GitLab CI.
+- Query GitHub API to poll open PR instead of polling git repository.
+- Read instructions from PR comments.
+- Cancel running jobs when pushing new commits.
+- Report issue on broken protected branches.
+- Auto-merge PR.
+- Works with webhook and/or behind firewall.
+- Extensible through entry-point.
+
+%package help
+Summary: Development documents and examples for jenkins-epo
+Provides: python3-jenkins-epo-doc
+%description help
+- Define jobs from repository in `jenkins.yml
+ <https://github.com/novafloss/jenkins-yml>`_.
+- Jobs pipeline façon GitLab CI.
+- Query GitHub API to poll open PR instead of polling git repository.
+- Read instructions from PR comments.
+- Cancel running jobs when pushing new commits.
+- Report issue on broken protected branches.
+- Auto-merge PR.
+- Works with webhook and/or behind firewall.
+- Extensible through entry-point.
+
+%prep
+%autosetup -n jenkins-epo-1.160
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jenkins-epo -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.160-1
+- Package Spec generated