summaryrefslogtreecommitdiff
path: root/python-jetson-stats.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 22:31:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 22:31:50 +0000
commit8313b615dd7a2ecaaa41841a959edc5ff939fb63 (patch)
treec261c1a790a80c18fe3b54d0762023508bfd65ce /python-jetson-stats.spec
parent9452675f9cca75bafb5c9f98b10b8e2d17cd6824 (diff)
automatic import of python-jetson-stats
Diffstat (limited to 'python-jetson-stats.spec')
-rw-r--r--python-jetson-stats.spec426
1 files changed, 426 insertions, 0 deletions
diff --git a/python-jetson-stats.spec b/python-jetson-stats.spec
new file mode 100644
index 0000000..db88458
--- /dev/null
+++ b/python-jetson-stats.spec
@@ -0,0 +1,426 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jetson-stats
+Version: 4.2.1
+Release: 1
+Summary: Interactive system-monitor and process viewer for all NVIDIA Jetson [Orin, Xavier, Nano, TX] series
+License: AGPL-3.0
+URL: https://rnext.it/jetson_stats
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/aa/07/098bfb6f864b44c12957be8798c34af4faabac33ffde2eaf1ef861f901e5/jetson-stats-4.2.1.tar.gz
+BuildArch: noarch
+
+
+%description
+<h1 align="center">
+
+<b>jetson-stats</b>
+
+[![jetson-stats](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.png)](https://rnext.it/jetson_stats/)
+
+</h1>
+
+<p align="center">
+ <a href="https://pypistats.org/packages/jetson-stats"><img alt="PyPI - Downloads" src="https://img.shields.io/pypi/dw/jetson-stats.svg" /></a>
+ <a href="https://badge.fury.io/py/jetson-stats"><img alt="PyPI version" src="https://badge.fury.io/py/jetson-stats.svg" /></a>
+ <a href="https://www.python.org/"><img alt="PyPI - Python Version" src="https://img.shields.io/pypi/pyversions/jetson-stats.svg" /></a>
+ <a href="https://pypi.org/project/jetson-stats/"><img alt="PyPI - Format" src="https://img.shields.io/pypi/format/jetson-stats.svg" /></a>
+ <a href="/LICENSE"><img alt="GitHub" src="https://img.shields.io/github/license/rbonghi/jetson_stats" /></a>
+ <a href="https://snyk.io/advisor/python/jetson-stats"><img alt="jetson-stats" src="https://snyk.io/advisor/python/jetson-stats/badge.svg" /></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Image Size (tag)" src="https://img.shields.io/docker/image-size/rbonghi/jetson_stats/latest"></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Pulls" src="https://img.shields.io/docker/pulls/rbonghi/jetson_stats" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions?query=workflow%3A%22CI+%26+CD%22"><img alt="CI & CD" src="https://github.com/rbonghi/jetson_stats/workflows/CI%20&%20CD/badge.svg" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql"><img alt="CodeQL" src="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql/badge.svg?branch=master" /></a>
+</p>
+<p align="center">
+ <a href="https://twitter.com/raffaello86"><img alt="Twitter Follow" src="https://img.shields.io/badge/Follow-%40raffaello86-1DA1F2?logo=twitter&style=social" /></a>
+ <a href="https://www.instagram.com/robo.panther/"><img alt="robo.panther" src="https://img.shields.io/badge/Follow-robo.panther-E4405F?style=social&logo=instagram" /></a>
+ <a href="https://discord.gg/BFbuJNhYzS"><img alt="Join our Discord" src="https://img.shields.io/discord/1060563771048861817?color=%237289da&label=discord" /></a>
+</p>
+
+**jetson-stats** is a package for **monitoring** and **control** your [NVIDIA Jetson](https://developer.nvidia.com/buy-jetson) [Orin, Xavier, Nano, TX] series.
+
+jetson-stats is a powerful tool to analyze your board, you can use with a stand alone application with `jtop` or import in your python script, the main features are:
+
+- Decode hardware, architecture, L4T and NVIDIA Jetpack
+- Monitoring, CPU, GPU, Memory, Engines, fan
+- Control NVP model, fan speed, jetson_clocks
+- Importable in a python script
+- Dockerizable in a container
+- Do not need super user
+- Tested on many different hardware configurations
+- Works with all NVIDIA Jetpack
+
+## Install
+
+jetson-stats can be installed with [pip](https://pip.pypa.io), but need **superuser**:
+
+```console
+sudo pip3 install -U jetson-stats
+```
+
+_Don't forget to **logout/login** or **reboot** your board_
+
+<div align="center">
+
+**🚀 That's it! 🚀**
+
+</div>
+
+## Run
+
+Start jtop it's pretty simple just write `jtop`!
+
+```console
+jtop
+```
+
+A simple interface will appear on your terminal, more capabilities are documented at [_jtop_](https://rnext.it/jetson_stats/jtop.html) page.
+
+<div align="center">
+
+[![jtop](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.gif)](https://github.com/rbonghi/jetson_stats)
+
+</div>
+
+## Library
+
+You can use jtop such a python library to integrate in your software
+
+```python
+from jtop import jtop
+
+with jtop() as jetson:
+ # jetson.ok() will provide the proper update frequency
+ while jetson.ok():
+ # Read tegra stats
+ print(jetson.stats)
+```
+
+You can also use jtop with your _virualenv_!
+
+More information available at [_advanced usage_](https://rnext.it/jetson_stats/advanced-usage.html) page.
+
+## Docker
+
+You can run directly in Docker jtop, you need only to:
+
+1. Install jetson-stats on your **host**
+2. Install jetson-stats on your container as well
+3. Pass to your container `/run/jtop.sock:/run/jtop.sock`
+
+You can try running this command
+
+```console
+docker run --rm -it -v /run/jtop.sock:/run/jtop.sock rbonghi/jetson_stats:latest
+```
+
+More information available at [_docker_](https://rnext.it/jetson_stats/docker.html) documentation page.
+
+## Sponsorship
+
+If your company benefits from this library, please consider [💖 sponsoring its development](https://github.com/sponsors/rbonghi).
+
+## Documentation
+
+jetson-stats has usage and reference documentation at <https://rnext.it/jetson_stats>, there is also a [🆘 troubleshooting](https://rnext.it/jetson_stats/troubleshooting.html) page.
+
+## Community
+
+jetson-stats has a [community Discord channel](https://discord.gg/BFbuJNhYzS) for asking questions and collaborating with other contributors. Drop by and say hello 👋
+
+
+
+
+%package -n python3-jetson-stats
+Summary: Interactive system-monitor and process viewer for all NVIDIA Jetson [Orin, Xavier, Nano, TX] series
+Provides: python-jetson-stats
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jetson-stats
+<h1 align="center">
+
+<b>jetson-stats</b>
+
+[![jetson-stats](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.png)](https://rnext.it/jetson_stats/)
+
+</h1>
+
+<p align="center">
+ <a href="https://pypistats.org/packages/jetson-stats"><img alt="PyPI - Downloads" src="https://img.shields.io/pypi/dw/jetson-stats.svg" /></a>
+ <a href="https://badge.fury.io/py/jetson-stats"><img alt="PyPI version" src="https://badge.fury.io/py/jetson-stats.svg" /></a>
+ <a href="https://www.python.org/"><img alt="PyPI - Python Version" src="https://img.shields.io/pypi/pyversions/jetson-stats.svg" /></a>
+ <a href="https://pypi.org/project/jetson-stats/"><img alt="PyPI - Format" src="https://img.shields.io/pypi/format/jetson-stats.svg" /></a>
+ <a href="/LICENSE"><img alt="GitHub" src="https://img.shields.io/github/license/rbonghi/jetson_stats" /></a>
+ <a href="https://snyk.io/advisor/python/jetson-stats"><img alt="jetson-stats" src="https://snyk.io/advisor/python/jetson-stats/badge.svg" /></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Image Size (tag)" src="https://img.shields.io/docker/image-size/rbonghi/jetson_stats/latest"></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Pulls" src="https://img.shields.io/docker/pulls/rbonghi/jetson_stats" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions?query=workflow%3A%22CI+%26+CD%22"><img alt="CI & CD" src="https://github.com/rbonghi/jetson_stats/workflows/CI%20&%20CD/badge.svg" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql"><img alt="CodeQL" src="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql/badge.svg?branch=master" /></a>
+</p>
+<p align="center">
+ <a href="https://twitter.com/raffaello86"><img alt="Twitter Follow" src="https://img.shields.io/badge/Follow-%40raffaello86-1DA1F2?logo=twitter&style=social" /></a>
+ <a href="https://www.instagram.com/robo.panther/"><img alt="robo.panther" src="https://img.shields.io/badge/Follow-robo.panther-E4405F?style=social&logo=instagram" /></a>
+ <a href="https://discord.gg/BFbuJNhYzS"><img alt="Join our Discord" src="https://img.shields.io/discord/1060563771048861817?color=%237289da&label=discord" /></a>
+</p>
+
+**jetson-stats** is a package for **monitoring** and **control** your [NVIDIA Jetson](https://developer.nvidia.com/buy-jetson) [Orin, Xavier, Nano, TX] series.
+
+jetson-stats is a powerful tool to analyze your board, you can use with a stand alone application with `jtop` or import in your python script, the main features are:
+
+- Decode hardware, architecture, L4T and NVIDIA Jetpack
+- Monitoring, CPU, GPU, Memory, Engines, fan
+- Control NVP model, fan speed, jetson_clocks
+- Importable in a python script
+- Dockerizable in a container
+- Do not need super user
+- Tested on many different hardware configurations
+- Works with all NVIDIA Jetpack
+
+## Install
+
+jetson-stats can be installed with [pip](https://pip.pypa.io), but need **superuser**:
+
+```console
+sudo pip3 install -U jetson-stats
+```
+
+_Don't forget to **logout/login** or **reboot** your board_
+
+<div align="center">
+
+**🚀 That's it! 🚀**
+
+</div>
+
+## Run
+
+Start jtop it's pretty simple just write `jtop`!
+
+```console
+jtop
+```
+
+A simple interface will appear on your terminal, more capabilities are documented at [_jtop_](https://rnext.it/jetson_stats/jtop.html) page.
+
+<div align="center">
+
+[![jtop](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.gif)](https://github.com/rbonghi/jetson_stats)
+
+</div>
+
+## Library
+
+You can use jtop such a python library to integrate in your software
+
+```python
+from jtop import jtop
+
+with jtop() as jetson:
+ # jetson.ok() will provide the proper update frequency
+ while jetson.ok():
+ # Read tegra stats
+ print(jetson.stats)
+```
+
+You can also use jtop with your _virualenv_!
+
+More information available at [_advanced usage_](https://rnext.it/jetson_stats/advanced-usage.html) page.
+
+## Docker
+
+You can run directly in Docker jtop, you need only to:
+
+1. Install jetson-stats on your **host**
+2. Install jetson-stats on your container as well
+3. Pass to your container `/run/jtop.sock:/run/jtop.sock`
+
+You can try running this command
+
+```console
+docker run --rm -it -v /run/jtop.sock:/run/jtop.sock rbonghi/jetson_stats:latest
+```
+
+More information available at [_docker_](https://rnext.it/jetson_stats/docker.html) documentation page.
+
+## Sponsorship
+
+If your company benefits from this library, please consider [💖 sponsoring its development](https://github.com/sponsors/rbonghi).
+
+## Documentation
+
+jetson-stats has usage and reference documentation at <https://rnext.it/jetson_stats>, there is also a [🆘 troubleshooting](https://rnext.it/jetson_stats/troubleshooting.html) page.
+
+## Community
+
+jetson-stats has a [community Discord channel](https://discord.gg/BFbuJNhYzS) for asking questions and collaborating with other contributors. Drop by and say hello 👋
+
+
+
+
+%package help
+Summary: Development documents and examples for jetson-stats
+Provides: python3-jetson-stats-doc
+%description help
+<h1 align="center">
+
+<b>jetson-stats</b>
+
+[![jetson-stats](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.png)](https://rnext.it/jetson_stats/)
+
+</h1>
+
+<p align="center">
+ <a href="https://pypistats.org/packages/jetson-stats"><img alt="PyPI - Downloads" src="https://img.shields.io/pypi/dw/jetson-stats.svg" /></a>
+ <a href="https://badge.fury.io/py/jetson-stats"><img alt="PyPI version" src="https://badge.fury.io/py/jetson-stats.svg" /></a>
+ <a href="https://www.python.org/"><img alt="PyPI - Python Version" src="https://img.shields.io/pypi/pyversions/jetson-stats.svg" /></a>
+ <a href="https://pypi.org/project/jetson-stats/"><img alt="PyPI - Format" src="https://img.shields.io/pypi/format/jetson-stats.svg" /></a>
+ <a href="/LICENSE"><img alt="GitHub" src="https://img.shields.io/github/license/rbonghi/jetson_stats" /></a>
+ <a href="https://snyk.io/advisor/python/jetson-stats"><img alt="jetson-stats" src="https://snyk.io/advisor/python/jetson-stats/badge.svg" /></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Image Size (tag)" src="https://img.shields.io/docker/image-size/rbonghi/jetson_stats/latest"></a>
+ <a href="https://hub.docker.com/r/rbonghi/jetson_stats"><img alt="Docker Pulls" src="https://img.shields.io/docker/pulls/rbonghi/jetson_stats" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions?query=workflow%3A%22CI+%26+CD%22"><img alt="CI & CD" src="https://github.com/rbonghi/jetson_stats/workflows/CI%20&%20CD/badge.svg" /></a>
+ <a href="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql"><img alt="CodeQL" src="https://github.com/rbonghi/jetson_stats/actions/workflows/github-code-scanning/codeql/badge.svg?branch=master" /></a>
+</p>
+<p align="center">
+ <a href="https://twitter.com/raffaello86"><img alt="Twitter Follow" src="https://img.shields.io/badge/Follow-%40raffaello86-1DA1F2?logo=twitter&style=social" /></a>
+ <a href="https://www.instagram.com/robo.panther/"><img alt="robo.panther" src="https://img.shields.io/badge/Follow-robo.panther-E4405F?style=social&logo=instagram" /></a>
+ <a href="https://discord.gg/BFbuJNhYzS"><img alt="Join our Discord" src="https://img.shields.io/discord/1060563771048861817?color=%237289da&label=discord" /></a>
+</p>
+
+**jetson-stats** is a package for **monitoring** and **control** your [NVIDIA Jetson](https://developer.nvidia.com/buy-jetson) [Orin, Xavier, Nano, TX] series.
+
+jetson-stats is a powerful tool to analyze your board, you can use with a stand alone application with `jtop` or import in your python script, the main features are:
+
+- Decode hardware, architecture, L4T and NVIDIA Jetpack
+- Monitoring, CPU, GPU, Memory, Engines, fan
+- Control NVP model, fan speed, jetson_clocks
+- Importable in a python script
+- Dockerizable in a container
+- Do not need super user
+- Tested on many different hardware configurations
+- Works with all NVIDIA Jetpack
+
+## Install
+
+jetson-stats can be installed with [pip](https://pip.pypa.io), but need **superuser**:
+
+```console
+sudo pip3 install -U jetson-stats
+```
+
+_Don't forget to **logout/login** or **reboot** your board_
+
+<div align="center">
+
+**🚀 That's it! 🚀**
+
+</div>
+
+## Run
+
+Start jtop it's pretty simple just write `jtop`!
+
+```console
+jtop
+```
+
+A simple interface will appear on your terminal, more capabilities are documented at [_jtop_](https://rnext.it/jetson_stats/jtop.html) page.
+
+<div align="center">
+
+[![jtop](https://github.com/rbonghi/jetson_stats/raw/master/docs/images/jtop.gif)](https://github.com/rbonghi/jetson_stats)
+
+</div>
+
+## Library
+
+You can use jtop such a python library to integrate in your software
+
+```python
+from jtop import jtop
+
+with jtop() as jetson:
+ # jetson.ok() will provide the proper update frequency
+ while jetson.ok():
+ # Read tegra stats
+ print(jetson.stats)
+```
+
+You can also use jtop with your _virualenv_!
+
+More information available at [_advanced usage_](https://rnext.it/jetson_stats/advanced-usage.html) page.
+
+## Docker
+
+You can run directly in Docker jtop, you need only to:
+
+1. Install jetson-stats on your **host**
+2. Install jetson-stats on your container as well
+3. Pass to your container `/run/jtop.sock:/run/jtop.sock`
+
+You can try running this command
+
+```console
+docker run --rm -it -v /run/jtop.sock:/run/jtop.sock rbonghi/jetson_stats:latest
+```
+
+More information available at [_docker_](https://rnext.it/jetson_stats/docker.html) documentation page.
+
+## Sponsorship
+
+If your company benefits from this library, please consider [💖 sponsoring its development](https://github.com/sponsors/rbonghi).
+
+## Documentation
+
+jetson-stats has usage and reference documentation at <https://rnext.it/jetson_stats>, there is also a [🆘 troubleshooting](https://rnext.it/jetson_stats/troubleshooting.html) page.
+
+## Community
+
+jetson-stats has a [community Discord channel](https://discord.gg/BFbuJNhYzS) for asking questions and collaborating with other contributors. Drop by and say hello 👋
+
+
+
+
+%prep
+%autosetup -n jetson-stats-4.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jetson-stats -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 4.2.1-1
+- Package Spec generated