summaryrefslogtreecommitdiff
path: root/python-jsonfield.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-jsonfield.spec')
-rw-r--r--python-jsonfield.spec91
1 files changed, 91 insertions, 0 deletions
diff --git a/python-jsonfield.spec b/python-jsonfield.spec
new file mode 100644
index 0000000..5a320b4
--- /dev/null
+++ b/python-jsonfield.spec
@@ -0,0 +1,91 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jsonfield
+Version: 3.1.0
+Release: 1
+Summary: A reusable Django field that allows you to store validated JSON in your model.
+License: MIT
+URL: https://github.com/rpkilby/jsonfield/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/10/3b/4542fd9465908380ba4321329d3cdfeb959769ec48d878dead978286b48d/jsonfield-3.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Django
+
+%description
+**jsonfield** is a reusable model field that allows you to store validated JSON, automatically handling
+serialization to and from the database. To use, add ``jsonfield.JSONField`` to one of your models.
+**Note:** `django.contrib.postgres`_ now supports PostgreSQL's jsonb type, which includes extended querying
+capabilities. If you're an end user of PostgreSQL and want full-featured JSON support, then it is
+recommended that you use the built-in JSONField. However, jsonfield is still useful when your app
+needs to be database-agnostic, or when the built-in JSONField's extended querying is not being leveraged.
+e.g., a configuration field.
+
+%package -n python3-jsonfield
+Summary: A reusable Django field that allows you to store validated JSON in your model.
+Provides: python-jsonfield
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jsonfield
+**jsonfield** is a reusable model field that allows you to store validated JSON, automatically handling
+serialization to and from the database. To use, add ``jsonfield.JSONField`` to one of your models.
+**Note:** `django.contrib.postgres`_ now supports PostgreSQL's jsonb type, which includes extended querying
+capabilities. If you're an end user of PostgreSQL and want full-featured JSON support, then it is
+recommended that you use the built-in JSONField. However, jsonfield is still useful when your app
+needs to be database-agnostic, or when the built-in JSONField's extended querying is not being leveraged.
+e.g., a configuration field.
+
+%package help
+Summary: Development documents and examples for jsonfield
+Provides: python3-jsonfield-doc
+%description help
+**jsonfield** is a reusable model field that allows you to store validated JSON, automatically handling
+serialization to and from the database. To use, add ``jsonfield.JSONField`` to one of your models.
+**Note:** `django.contrib.postgres`_ now supports PostgreSQL's jsonb type, which includes extended querying
+capabilities. If you're an end user of PostgreSQL and want full-featured JSON support, then it is
+recommended that you use the built-in JSONField. However, jsonfield is still useful when your app
+needs to be database-agnostic, or when the built-in JSONField's extended querying is not being leveraged.
+e.g., a configuration field.
+
+%prep
+%autosetup -n jsonfield-3.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jsonfield -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.1.0-1
+- Package Spec generated