summaryrefslogtreecommitdiff
path: root/python-jsonmask.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 03:19:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 03:19:42 +0000
commita7eb0f6a8c3debe958b029546ff0eb377bb1e09c (patch)
treef43bb5c941865075000bdaee6e1ea806afacb116 /python-jsonmask.spec
parentab848ec34a03951cc0292a8a5d576dc618e6de99 (diff)
automatic import of python-jsonmask
Diffstat (limited to 'python-jsonmask.spec')
-rw-r--r--python-jsonmask.spec273
1 files changed, 273 insertions, 0 deletions
diff --git a/python-jsonmask.spec b/python-jsonmask.spec
new file mode 100644
index 0000000..1ec3869
--- /dev/null
+++ b/python-jsonmask.spec
@@ -0,0 +1,273 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jsonmask
+Version: 0.1.1
+Release: 1
+Summary: Implements the Google Partial Response protocol in Python
+License: MIT
+URL: https://github.com/zapier/jsonmask
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/23/d8a16e6c8e6cbbd78a428aa904563ca5441ae2659f669ad9345037798749/jsonmask-0.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Build Status](https://img.shields.io/travis/zapier/jsonmask/master.svg)](https://travis-ci.org/zapier/jsonmask) [![Coverage Status](https://img.shields.io/coveralls/zapier/jsonmask/master.svg)](https://coveralls.io/r/zapier/jsonmask) [![PyPI Version](https://img.shields.io/pypi/v/jsonmask.svg)](https://pypi.org/project/jsonmask)
+
+# Overview
+
+Implements [Google Partial Response](https://developers.google.com/discovery/v1/performance#partial-response) / [`json-mask`](https://github.com/nemtsov/json-mask) in Python.
+
+## Requirements
+
+* Python 2.7
+* Python 3.6+
+
+## Installation
+
+Install jsonmask with pip:
+
+```sh
+$ pip install jsonmask
+```
+
+or directly from the source code:
+
+```sh
+$ git clone https://github.com/zapier/jsonmask.git
+$ cd jsonmask
+$ python setup.py install
+```
+
+# Usage
+
+After installation, the package can imported:
+
+```sh
+$ python
+>>> import jsonmask
+>>> jsonmask.__version__
+```
+
+To prune dictionaries:
+
+```py
+>>> import jsonmask
+>>> mask = jsonmask.parse_fields('a,b(c,d)')
+>>> jsonmask.apply_json_mask(
+ {
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ 'e': 'Tough luck here',
+ },
+ 'c': 'Definitely hopeless',
+ },
+ mask,
+)
+
+{
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ },
+}
+```
+
+
+%package -n python3-jsonmask
+Summary: Implements the Google Partial Response protocol in Python
+Provides: python-jsonmask
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jsonmask
+[![Build Status](https://img.shields.io/travis/zapier/jsonmask/master.svg)](https://travis-ci.org/zapier/jsonmask) [![Coverage Status](https://img.shields.io/coveralls/zapier/jsonmask/master.svg)](https://coveralls.io/r/zapier/jsonmask) [![PyPI Version](https://img.shields.io/pypi/v/jsonmask.svg)](https://pypi.org/project/jsonmask)
+
+# Overview
+
+Implements [Google Partial Response](https://developers.google.com/discovery/v1/performance#partial-response) / [`json-mask`](https://github.com/nemtsov/json-mask) in Python.
+
+## Requirements
+
+* Python 2.7
+* Python 3.6+
+
+## Installation
+
+Install jsonmask with pip:
+
+```sh
+$ pip install jsonmask
+```
+
+or directly from the source code:
+
+```sh
+$ git clone https://github.com/zapier/jsonmask.git
+$ cd jsonmask
+$ python setup.py install
+```
+
+# Usage
+
+After installation, the package can imported:
+
+```sh
+$ python
+>>> import jsonmask
+>>> jsonmask.__version__
+```
+
+To prune dictionaries:
+
+```py
+>>> import jsonmask
+>>> mask = jsonmask.parse_fields('a,b(c,d)')
+>>> jsonmask.apply_json_mask(
+ {
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ 'e': 'Tough luck here',
+ },
+ 'c': 'Definitely hopeless',
+ },
+ mask,
+)
+
+{
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ },
+}
+```
+
+
+%package help
+Summary: Development documents and examples for jsonmask
+Provides: python3-jsonmask-doc
+%description help
+[![Build Status](https://img.shields.io/travis/zapier/jsonmask/master.svg)](https://travis-ci.org/zapier/jsonmask) [![Coverage Status](https://img.shields.io/coveralls/zapier/jsonmask/master.svg)](https://coveralls.io/r/zapier/jsonmask) [![PyPI Version](https://img.shields.io/pypi/v/jsonmask.svg)](https://pypi.org/project/jsonmask)
+
+# Overview
+
+Implements [Google Partial Response](https://developers.google.com/discovery/v1/performance#partial-response) / [`json-mask`](https://github.com/nemtsov/json-mask) in Python.
+
+## Requirements
+
+* Python 2.7
+* Python 3.6+
+
+## Installation
+
+Install jsonmask with pip:
+
+```sh
+$ pip install jsonmask
+```
+
+or directly from the source code:
+
+```sh
+$ git clone https://github.com/zapier/jsonmask.git
+$ cd jsonmask
+$ python setup.py install
+```
+
+# Usage
+
+After installation, the package can imported:
+
+```sh
+$ python
+>>> import jsonmask
+>>> jsonmask.__version__
+```
+
+To prune dictionaries:
+
+```py
+>>> import jsonmask
+>>> mask = jsonmask.parse_fields('a,b(c,d)')
+>>> jsonmask.apply_json_mask(
+ {
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ 'e': 'Tough luck here',
+ },
+ 'c': 'Definitely hopeless',
+ },
+ mask,
+)
+
+{
+ 'a': {
+ 'nested_within_a': True,
+ },
+ 'b' {
+ 'c': True,
+ 'd': {'Will get included?': 'Yes'},
+ },
+}
+```
+
+
+%prep
+%autosetup -n jsonmask-0.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jsonmask -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.1-1
+- Package Spec generated