summaryrefslogtreecommitdiff
path: root/python-jsonpath2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-jsonpath2.spec')
-rw-r--r--python-jsonpath2.spec151
1 files changed, 151 insertions, 0 deletions
diff --git a/python-jsonpath2.spec b/python-jsonpath2.spec
new file mode 100644
index 0000000..bd9bcb1
--- /dev/null
+++ b/python-jsonpath2.spec
@@ -0,0 +1,151 @@
+%global _empty_manifest_terminate_build 0
+Name: python-jsonpath2
+Version: 0.4.5
+Release: 1
+Summary: JSONPath implementation for Python
+License: LGPLv3
+URL: https://github.com/pacifica/python-jsonpath2/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/5d/0202fe5f4ce814fe7d026dc0c462358fb1bd4d14f5ab84f32a2657ce43c7/jsonpath2-0.4.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-antlr4-python3-runtime
+
+%description
+# jsonpath2
+[![Build Status](https://travis-ci.org/pacifica/python-jsonpath2.svg?branch=master)](https://travis-ci.org/pacifica/python-jsonpath2)
+
+This repository contains an implementation of
+[JSONPath](http://goessner.net/articles/JsonPath/)
+([XPath](https://www.w3.org/TR/xpath/all/) for
+[JSON](https://www.json.org/)) for the Python programming
+language.
+
+## Documentation
+
+For installation, configuration and usage documentation please
+refer to the [Read the Docs](https://jsonpath2.readthedocs.io)
+documentation.
+
+* [Installation](docs/installation.md) documentation.
+* [Examples](docs/exampleusage.md) documentation.
+
+
+## Contributions
+
+Contributions are accepted on GitHub via the fork and pull request workflow.
+GitHub has a good [help article](https://help.github.com/articles/using-pull-requests/)
+if you are unfamiliar with this method of contributing.
+
+
+
+
+%package -n python3-jsonpath2
+Summary: JSONPath implementation for Python
+Provides: python-jsonpath2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-jsonpath2
+# jsonpath2
+[![Build Status](https://travis-ci.org/pacifica/python-jsonpath2.svg?branch=master)](https://travis-ci.org/pacifica/python-jsonpath2)
+
+This repository contains an implementation of
+[JSONPath](http://goessner.net/articles/JsonPath/)
+([XPath](https://www.w3.org/TR/xpath/all/) for
+[JSON](https://www.json.org/)) for the Python programming
+language.
+
+## Documentation
+
+For installation, configuration and usage documentation please
+refer to the [Read the Docs](https://jsonpath2.readthedocs.io)
+documentation.
+
+* [Installation](docs/installation.md) documentation.
+* [Examples](docs/exampleusage.md) documentation.
+
+
+## Contributions
+
+Contributions are accepted on GitHub via the fork and pull request workflow.
+GitHub has a good [help article](https://help.github.com/articles/using-pull-requests/)
+if you are unfamiliar with this method of contributing.
+
+
+
+
+%package help
+Summary: Development documents and examples for jsonpath2
+Provides: python3-jsonpath2-doc
+%description help
+# jsonpath2
+[![Build Status](https://travis-ci.org/pacifica/python-jsonpath2.svg?branch=master)](https://travis-ci.org/pacifica/python-jsonpath2)
+
+This repository contains an implementation of
+[JSONPath](http://goessner.net/articles/JsonPath/)
+([XPath](https://www.w3.org/TR/xpath/all/) for
+[JSON](https://www.json.org/)) for the Python programming
+language.
+
+## Documentation
+
+For installation, configuration and usage documentation please
+refer to the [Read the Docs](https://jsonpath2.readthedocs.io)
+documentation.
+
+* [Installation](docs/installation.md) documentation.
+* [Examples](docs/exampleusage.md) documentation.
+
+
+## Contributions
+
+Contributions are accepted on GitHub via the fork and pull request workflow.
+GitHub has a good [help article](https://help.github.com/articles/using-pull-requests/)
+if you are unfamiliar with this method of contributing.
+
+
+
+
+%prep
+%autosetup -n jsonpath2-0.4.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-jsonpath2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.4.5-1
+- Package Spec generated