summaryrefslogtreecommitdiff
path: root/python-katversion.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-katversion.spec')
-rw-r--r--python-katversion.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-katversion.spec b/python-katversion.spec
new file mode 100644
index 0000000..09f70a0
--- /dev/null
+++ b/python-katversion.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-katversion
+Version: 1.2
+Release: 1
+Summary: Reliable git-based versioning for Python packages
+License: BSD
+URL: https://github.com/ska-sa/katversion
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8a/ca/0b7afb0ec27ac1e554fff9fa3fa9ce584b1a7df3f8001a07dcc247973f53/katversion-1.2.tar.gz
+BuildArch: noarch
+
+
+%description
+The *katversion* package provides proper versioning for Python packages as
+dictated by their (git) source repositories. The resulting version string is
+baked into the installed package's ``__init__.py`` file for guaranteed
+traceability when imported (no dependency on what pkg_resources thinks!).
+
+%package -n python3-katversion
+Summary: Reliable git-based versioning for Python packages
+Provides: python-katversion
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-katversion
+The *katversion* package provides proper versioning for Python packages as
+dictated by their (git) source repositories. The resulting version string is
+baked into the installed package's ``__init__.py`` file for guaranteed
+traceability when imported (no dependency on what pkg_resources thinks!).
+
+%package help
+Summary: Development documents and examples for katversion
+Provides: python3-katversion-doc
+%description help
+The *katversion* package provides proper versioning for Python packages as
+dictated by their (git) source repositories. The resulting version string is
+baked into the installed package's ``__init__.py`` file for guaranteed
+traceability when imported (no dependency on what pkg_resources thinks!).
+
+%prep
+%autosetup -n katversion-1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-katversion -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2-1
+- Package Spec generated