summaryrefslogtreecommitdiff
path: root/python-kwonly-args.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 17:57:13 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 17:57:13 +0000
commit4ca73d572d57a8ead085b747491a91779937b2b4 (patch)
tree07b69e7ebdb876d990427db61adee26782c27654 /python-kwonly-args.spec
parenta955cee7d17c3c948d843b2dfcc9c5067f08dfa5 (diff)
automatic import of python-kwonly-args
Diffstat (limited to 'python-kwonly-args.spec')
-rw-r--r--python-kwonly-args.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-kwonly-args.spec b/python-kwonly-args.spec
new file mode 100644
index 0000000..439c385
--- /dev/null
+++ b/python-kwonly-args.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-kwonly-args
+Version: 1.0.10
+Release: 1
+Summary: Python2 keyword-only argument emulation as a decorator. Python 3 compatible.
+License: MIT
+URL: https://github.com/pasztorpisti/kwonly-args
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ee/da/a7ba4f2153a536a895a9d29a222ee0f138d617862f9b982bd4ae33714308/kwonly-args-1.0.10.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-kwonly-args
+Summary: Python2 keyword-only argument emulation as a decorator. Python 3 compatible.
+Provides: python-kwonly-args
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-kwonly-args
+
+
+%package help
+Summary: Development documents and examples for kwonly-args
+Provides: python3-kwonly-args-doc
+%description help
+
+
+%prep
+%autosetup -n kwonly-args-1.0.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-kwonly-args -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.10-1
+- Package Spec generated