summaryrefslogtreecommitdiff
path: root/python-lambda-toolkit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-lambda-toolkit.spec')
-rw-r--r--python-lambda-toolkit.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-lambda-toolkit.spec b/python-lambda-toolkit.spec
new file mode 100644
index 0000000..88c14d8
--- /dev/null
+++ b/python-lambda-toolkit.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-lambda-toolkit
+Version: 0.3.7
+Release: 1
+Summary: An AWS Lambda command line interface (CLI). It helps you in creating, building, testing and deploying your lambda functions.
+License: Apache Software License
+URL: https://github.com/lucioveloso/lambda-toolkit
+Source0: https://mirrors.aliyun.com/pypi/web/packages/0c/1c/264912340f924e286838e8f3337d3db150dfb32a204f48adc74d4ac76951/lambda-toolkit-0.3.7.tar.gz
+BuildArch: noarch
+
+Requires: python3-boto3
+Requires: python3-botocore
+Requires: python3-click
+Requires: python3-tail-toolkit
+
+%description
+
+
+%package -n python3-lambda-toolkit
+Summary: An AWS Lambda command line interface (CLI). It helps you in creating, building, testing and deploying your lambda functions.
+Provides: python-lambda-toolkit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-lambda-toolkit
+
+
+%package help
+Summary: Development documents and examples for lambda-toolkit
+Provides: python3-lambda-toolkit-doc
+%description help
+
+
+%prep
+%autosetup -n lambda-toolkit-0.3.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-lambda-toolkit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.7-1
+- Package Spec generated