summaryrefslogtreecommitdiff
path: root/python-lbnightlytools.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 22:21:08 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 22:21:08 +0000
commite24115ec72059848621141cb142955e6e2c7f392 (patch)
treed21203bdb1eab49f8e1b924f0428c7772d8d0485 /python-lbnightlytools.spec
parent57cff697922ca805929c7ccacb8b21eb790178af (diff)
automatic import of python-lbnightlytools
Diffstat (limited to 'python-lbnightlytools.spec')
-rw-r--r--python-lbnightlytools.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-lbnightlytools.spec b/python-lbnightlytools.spec
new file mode 100644
index 0000000..bdbdb97
--- /dev/null
+++ b/python-lbnightlytools.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-LbNightlyTools
+Version: 3.0.49
+Release: 1
+Summary: LHCb Nightly tools
+License: GNU General Public License v3 or later (GPLv3+)
+URL: https://gitlab.cern.ch/lhcb-core/LbNightlyTools
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/5c/161e50db3d6070b919959fd7cae7d2f255e14ed6100830b3cc93d2230124/LbNightlyTools-3.0.49.tar.gz
+BuildArch: noarch
+
+Requires: python3-LbEnv
+Requires: python3-LbCommon
+Requires: python3-LbSoftConfDb2Clients
+Requires: python3-LbDevTools
+Requires: python3-lbinstall
+Requires: python3-gitlab
+Requires: python3-pika
+Requires: python3-CouchDB
+Requires: python3-tabulate
+Requires: python3-joblib
+Requires: python3-GitPython
+Requires: python3-networkx
+Requires: python3-gitdb2
+Requires: python3-pyyaml
+Requires: python3-decorator
+
+%description
+Scripts to perform LHCb Nightly builds.
+
+%package -n python3-LbNightlyTools
+Summary: LHCb Nightly tools
+Provides: python-LbNightlyTools
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-LbNightlyTools
+Scripts to perform LHCb Nightly builds.
+
+%package help
+Summary: Development documents and examples for LbNightlyTools
+Provides: python3-LbNightlyTools-doc
+%description help
+Scripts to perform LHCb Nightly builds.
+
+%prep
+%autosetup -n LbNightlyTools-3.0.49
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-LbNightlyTools -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.49-1
+- Package Spec generated