summaryrefslogtreecommitdiff
path: root/python-ldif3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ldif3.spec')
-rw-r--r--python-ldif3.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-ldif3.spec b/python-ldif3.spec
new file mode 100644
index 0000000..5439bce
--- /dev/null
+++ b/python-ldif3.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ldif3
+Version: 3.2.2
+Release: 1
+Summary: generate and parse LDIF data (see RFC 2849).
+License: BSD
+URL: https://github.com/xi/ldif3
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/50/ff/2686e25a7abdb273b5b85b752f4fcbd14d3aca52bac9cf6ddda17845ede2/ldif3-3.2.2.tar.gz
+BuildArch: noarch
+
+
+%description
+Parse LDIF from a file (or ``BytesIO``)::
+ from ldif3 import LDIFParser
+ from pprint import pprint
+ parser = LDIFParser(open('data.ldif', 'rb'))
+ for dn, entry in parser.parse():
+ print('got entry record: %s' % dn)
+ pprint(record)
+Write LDIF to a file (or ``BytesIO``)::
+ from ldif3 import LDIFWriter
+ writer = LDIFWriter(open('data.ldif', 'wb'))
+ writer.unparse('mail=alice@example.com', {
+ 'cn': ['Alice Alison'],
+ 'mail': ['alice@example.com'],
+ 'objectclass': ['top', 'person'],
+ })
+
+%package -n python3-ldif3
+Summary: generate and parse LDIF data (see RFC 2849).
+Provides: python-ldif3
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ldif3
+Parse LDIF from a file (or ``BytesIO``)::
+ from ldif3 import LDIFParser
+ from pprint import pprint
+ parser = LDIFParser(open('data.ldif', 'rb'))
+ for dn, entry in parser.parse():
+ print('got entry record: %s' % dn)
+ pprint(record)
+Write LDIF to a file (or ``BytesIO``)::
+ from ldif3 import LDIFWriter
+ writer = LDIFWriter(open('data.ldif', 'wb'))
+ writer.unparse('mail=alice@example.com', {
+ 'cn': ['Alice Alison'],
+ 'mail': ['alice@example.com'],
+ 'objectclass': ['top', 'person'],
+ })
+
+%package help
+Summary: Development documents and examples for ldif3
+Provides: python3-ldif3-doc
+%description help
+Parse LDIF from a file (or ``BytesIO``)::
+ from ldif3 import LDIFParser
+ from pprint import pprint
+ parser = LDIFParser(open('data.ldif', 'rb'))
+ for dn, entry in parser.parse():
+ print('got entry record: %s' % dn)
+ pprint(record)
+Write LDIF to a file (or ``BytesIO``)::
+ from ldif3 import LDIFWriter
+ writer = LDIFWriter(open('data.ldif', 'wb'))
+ writer.unparse('mail=alice@example.com', {
+ 'cn': ['Alice Alison'],
+ 'mail': ['alice@example.com'],
+ 'objectclass': ['top', 'person'],
+ })
+
+%prep
+%autosetup -n ldif3-3.2.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ldif3 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.2-1
+- Package Spec generated