summaryrefslogtreecommitdiff
path: root/python-logutils.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-logutils.spec')
-rw-r--r--python-logutils.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-logutils.spec b/python-logutils.spec
new file mode 100644
index 0000000..03ae924
--- /dev/null
+++ b/python-logutils.spec
@@ -0,0 +1,120 @@
+%global _empty_manifest_terminate_build 0
+Name: python-logutils
+Version: 0.3.5
+Release: 1
+Summary: Logging utilities
+License: Copyright (C) 2010-2017 by Vinay Sajip. All Rights Reserved. See LICENSE.txt for license.
+URL: http://code.google.com/p/logutils/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/49/b2/b57450889bf73da26027f8b995fd5fbfab258ec24ef967e4c1892f7cb121/logutils-0.3.5.tar.gz
+BuildArch: noarch
+
+
+%description
+The logutils package provides a set of handlers for the Python standard
+library's logging package.
+
+Some of these handlers are out-of-scope for the standard library, and
+so they are packaged here. Others are updated versions which have
+appeared in recent Python releases, but are usable with older versions
+of Python and so are packaged here.
+
+The source code repository is at:
+
+https://bitbucket.org/vinay.sajip/logutils/
+
+Documentation is available at:
+
+https://logutils.readthedocs.io/
+
+https://pythonhosted.org/logutils/
+
+%package -n python3-logutils
+Summary: Logging utilities
+Provides: python-logutils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-logutils
+The logutils package provides a set of handlers for the Python standard
+library's logging package.
+
+Some of these handlers are out-of-scope for the standard library, and
+so they are packaged here. Others are updated versions which have
+appeared in recent Python releases, but are usable with older versions
+of Python and so are packaged here.
+
+The source code repository is at:
+
+https://bitbucket.org/vinay.sajip/logutils/
+
+Documentation is available at:
+
+https://logutils.readthedocs.io/
+
+https://pythonhosted.org/logutils/
+
+%package help
+Summary: Development documents and examples for logutils
+Provides: python3-logutils-doc
+%description help
+The logutils package provides a set of handlers for the Python standard
+library's logging package.
+
+Some of these handlers are out-of-scope for the standard library, and
+so they are packaged here. Others are updated versions which have
+appeared in recent Python releases, but are usable with older versions
+of Python and so are packaged here.
+
+The source code repository is at:
+
+https://bitbucket.org/vinay.sajip/logutils/
+
+Documentation is available at:
+
+https://logutils.readthedocs.io/
+
+https://pythonhosted.org/logutils/
+
+%prep
+%autosetup -n logutils-0.3.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-logutils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.5-1
+- Package Spec generated