summaryrefslogtreecommitdiff
path: root/python-loopstructural.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-loopstructural.spec')
-rw-r--r--python-loopstructural.spec182
1 files changed, 182 insertions, 0 deletions
diff --git a/python-loopstructural.spec b/python-loopstructural.spec
new file mode 100644
index 0000000..e1c6eb2
--- /dev/null
+++ b/python-loopstructural.spec
@@ -0,0 +1,182 @@
+%global _empty_manifest_terminate_build 0
+Name: python-LoopStructural
+Version: 1.5.10
+Release: 1
+Summary: Open source 3D structural geology modelling
+License: MIT
+URL: https://loop3d.github.io/LoopStructural/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/5d/15/e2fdb8fffb2527739d9a3ebb9b432e367ec92e78d1e55597259050b0845a/LoopStructural-1.5.10.tar.gz
+
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-scipy
+Requires: python3-scikit-image
+Requires: python3-scikit-learn
+Requires: python3-tqdm
+
+%description
+# LoopStructural: Loop3D Geological Forward Modeling Engine.
+![3D model of Hamersley created using loopstructural](docs/source/images/image823.png)
+![Continuous integration and deployment](https://github.com/Loop3D/LoopStructural/workflows/Continuous%20integration%20and%20deployment/badge.svg)
+![Publish Docker Hub](https://github.com/Loop3D/LoopStructural/workflows/Publish%20Docker%20Hub/badge.svg)
+[![PyPI version](https://badge.fury.io/py/LoopStructural.svg)](https://badge.fury.io/py/LoopStructural)
+[![GitHub license](https://img.shields.io/github/license/Naereen/StrapDown.js.svg)](https://github.com/Loop3D/LoopStructural/blob/master/LICENSE)
+[![Documentation loop3d.github.io/LoopStructural/](https://img.shields.io/badge/docs-githubio-brightgreen)](https://loop3d.github.io/LoopStructural)
+
+
+LoopStructural is the 3D geological modelling library for Loop ([Loop3d.org](https://loop3d.org/)). The development of LoopStructural is lead by **Lachlan Grose** as an ARC (LP170100985) post-doc at Monash University. **Laurent Ailleres** and **Gautier Laurent** have made significant contributions to the conceptual design and integration of geological concepts into the geological modelling workflow. **Roy Thomson** and **Yohan de Rose** have contributed to the implementation and integration of LoopStructural into the Loop workflow.
+
+Loop is led by Laurent Ailleres (Monash University) with a team of Work Package leaders from:
+* Monash University: Roy Thomson, Lachlan Grose and Robin Armit
+* University of Western Australia: Mark Jessell, Jeremie Giraud, Mark Lindsay and Guillaume Pirot
+* Geological Survey of Canada: Boyan Brodaric and Eric de Kemp
+
+The project benefits from in-kind contributions from the Geological Survey of Canada, the British Geological Survey, the French Bureau de Recherches Geologiques et Minieres, the RING group at the Universite de Lorraine, the RWTH in Aachen, Germany and AUSCOPE
+
+* Python/cython implementation of a Discrete interpolatiors
+* Fold interpolation using constraints outlined in Laurent 2016 with fold geostatistical tools shown in Grose et al., 2017
+* Fault interpolation
+
+If you want to use LoopStructural the easiest way to get started is to use a docker container and a jupyter notebook environment
+
+1. Pull the loopstructural docker image `docker pull lachlangrose/loopstructural`
+2. Start a docker container `docker run -it -p 8888:8888 lachlangrose/loopstructural`
+
+## Documentation
+The LoopStructural documentation can be found [here](https://loop3d.github.io/LoopStructural)
+## Problems
+Any bugs/feature requests/comments please create a new [issue](https://github.com/Loop3D/LoopStructural/issues).
+
+## Acknowledgements
+*The Loop platform is an open source 3D probabilistic geological and geophysical modelling platform, initiated by Geoscience Australia and the OneGeology consortium. The project is funded by Australian territory, State and Federal Geological Surveys, the Australian Research Council and the MinEx Collaborative Research Centre.*
+
+
+%package -n python3-LoopStructural
+Summary: Open source 3D structural geology modelling
+Provides: python-LoopStructural
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-LoopStructural
+# LoopStructural: Loop3D Geological Forward Modeling Engine.
+![3D model of Hamersley created using loopstructural](docs/source/images/image823.png)
+![Continuous integration and deployment](https://github.com/Loop3D/LoopStructural/workflows/Continuous%20integration%20and%20deployment/badge.svg)
+![Publish Docker Hub](https://github.com/Loop3D/LoopStructural/workflows/Publish%20Docker%20Hub/badge.svg)
+[![PyPI version](https://badge.fury.io/py/LoopStructural.svg)](https://badge.fury.io/py/LoopStructural)
+[![GitHub license](https://img.shields.io/github/license/Naereen/StrapDown.js.svg)](https://github.com/Loop3D/LoopStructural/blob/master/LICENSE)
+[![Documentation loop3d.github.io/LoopStructural/](https://img.shields.io/badge/docs-githubio-brightgreen)](https://loop3d.github.io/LoopStructural)
+
+
+LoopStructural is the 3D geological modelling library for Loop ([Loop3d.org](https://loop3d.org/)). The development of LoopStructural is lead by **Lachlan Grose** as an ARC (LP170100985) post-doc at Monash University. **Laurent Ailleres** and **Gautier Laurent** have made significant contributions to the conceptual design and integration of geological concepts into the geological modelling workflow. **Roy Thomson** and **Yohan de Rose** have contributed to the implementation and integration of LoopStructural into the Loop workflow.
+
+Loop is led by Laurent Ailleres (Monash University) with a team of Work Package leaders from:
+* Monash University: Roy Thomson, Lachlan Grose and Robin Armit
+* University of Western Australia: Mark Jessell, Jeremie Giraud, Mark Lindsay and Guillaume Pirot
+* Geological Survey of Canada: Boyan Brodaric and Eric de Kemp
+
+The project benefits from in-kind contributions from the Geological Survey of Canada, the British Geological Survey, the French Bureau de Recherches Geologiques et Minieres, the RING group at the Universite de Lorraine, the RWTH in Aachen, Germany and AUSCOPE
+
+* Python/cython implementation of a Discrete interpolatiors
+* Fold interpolation using constraints outlined in Laurent 2016 with fold geostatistical tools shown in Grose et al., 2017
+* Fault interpolation
+
+If you want to use LoopStructural the easiest way to get started is to use a docker container and a jupyter notebook environment
+
+1. Pull the loopstructural docker image `docker pull lachlangrose/loopstructural`
+2. Start a docker container `docker run -it -p 8888:8888 lachlangrose/loopstructural`
+
+## Documentation
+The LoopStructural documentation can be found [here](https://loop3d.github.io/LoopStructural)
+## Problems
+Any bugs/feature requests/comments please create a new [issue](https://github.com/Loop3D/LoopStructural/issues).
+
+## Acknowledgements
+*The Loop platform is an open source 3D probabilistic geological and geophysical modelling platform, initiated by Geoscience Australia and the OneGeology consortium. The project is funded by Australian territory, State and Federal Geological Surveys, the Australian Research Council and the MinEx Collaborative Research Centre.*
+
+
+%package help
+Summary: Development documents and examples for LoopStructural
+Provides: python3-LoopStructural-doc
+%description help
+# LoopStructural: Loop3D Geological Forward Modeling Engine.
+![3D model of Hamersley created using loopstructural](docs/source/images/image823.png)
+![Continuous integration and deployment](https://github.com/Loop3D/LoopStructural/workflows/Continuous%20integration%20and%20deployment/badge.svg)
+![Publish Docker Hub](https://github.com/Loop3D/LoopStructural/workflows/Publish%20Docker%20Hub/badge.svg)
+[![PyPI version](https://badge.fury.io/py/LoopStructural.svg)](https://badge.fury.io/py/LoopStructural)
+[![GitHub license](https://img.shields.io/github/license/Naereen/StrapDown.js.svg)](https://github.com/Loop3D/LoopStructural/blob/master/LICENSE)
+[![Documentation loop3d.github.io/LoopStructural/](https://img.shields.io/badge/docs-githubio-brightgreen)](https://loop3d.github.io/LoopStructural)
+
+
+LoopStructural is the 3D geological modelling library for Loop ([Loop3d.org](https://loop3d.org/)). The development of LoopStructural is lead by **Lachlan Grose** as an ARC (LP170100985) post-doc at Monash University. **Laurent Ailleres** and **Gautier Laurent** have made significant contributions to the conceptual design and integration of geological concepts into the geological modelling workflow. **Roy Thomson** and **Yohan de Rose** have contributed to the implementation and integration of LoopStructural into the Loop workflow.
+
+Loop is led by Laurent Ailleres (Monash University) with a team of Work Package leaders from:
+* Monash University: Roy Thomson, Lachlan Grose and Robin Armit
+* University of Western Australia: Mark Jessell, Jeremie Giraud, Mark Lindsay and Guillaume Pirot
+* Geological Survey of Canada: Boyan Brodaric and Eric de Kemp
+
+The project benefits from in-kind contributions from the Geological Survey of Canada, the British Geological Survey, the French Bureau de Recherches Geologiques et Minieres, the RING group at the Universite de Lorraine, the RWTH in Aachen, Germany and AUSCOPE
+
+* Python/cython implementation of a Discrete interpolatiors
+* Fold interpolation using constraints outlined in Laurent 2016 with fold geostatistical tools shown in Grose et al., 2017
+* Fault interpolation
+
+If you want to use LoopStructural the easiest way to get started is to use a docker container and a jupyter notebook environment
+
+1. Pull the loopstructural docker image `docker pull lachlangrose/loopstructural`
+2. Start a docker container `docker run -it -p 8888:8888 lachlangrose/loopstructural`
+
+## Documentation
+The LoopStructural documentation can be found [here](https://loop3d.github.io/LoopStructural)
+## Problems
+Any bugs/feature requests/comments please create a new [issue](https://github.com/Loop3D/LoopStructural/issues).
+
+## Acknowledgements
+*The Loop platform is an open source 3D probabilistic geological and geophysical modelling platform, initiated by Geoscience Australia and the OneGeology consortium. The project is funded by Australian territory, State and Federal Geological Surveys, the Australian Research Council and the MinEx Collaborative Research Centre.*
+
+
+%prep
+%autosetup -n LoopStructural-1.5.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-LoopStructural -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.10-1
+- Package Spec generated