summaryrefslogtreecommitdiff
path: root/python-louie.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-17 03:49:11 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-17 03:49:11 +0000
commit9f8bdad1412d3f6688a2121b1fab886f76e395e5 (patch)
treef1ac186ee03ef9d316385c7b01bd330c9d5fc071 /python-louie.spec
parent6bf8353e7def4e845241aa3186739d6b7f94e6cf (diff)
automatic import of python-louie
Diffstat (limited to 'python-louie.spec')
-rw-r--r--python-louie.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-louie.spec b/python-louie.spec
new file mode 100644
index 0000000..eb62717
--- /dev/null
+++ b/python-louie.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Louie
+Version: 2.0
+Release: 1
+Summary: Signal dispatching mechanism
+License: BSD
+URL: https://github.com/11craft/louie/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f2/f8/f9dfd97003f1c120dca1ed4dc9e3e16b74b583ce5bcb2d9b013142b6bee2/Louie-2.0.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-Louie
+Summary: Signal dispatching mechanism
+Provides: python-Louie
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Louie
+
+
+%package help
+Summary: Development documents and examples for Louie
+Provides: python3-Louie-doc
+%description help
+
+
+%prep
+%autosetup -n Louie-2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Louie -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0-1
+- Package Spec generated