summaryrefslogtreecommitdiff
path: root/python-mapboxgl.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 07:05:23 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 07:05:23 +0000
commitfb2ae7a6e799cc9fd0970da953a36fca3d11dc1c (patch)
tree7137d63b344b8e01526567164239118ce653680e /python-mapboxgl.spec
parentb99499222bc02913fc0e23cd24679a7ae03efd45 (diff)
automatic import of python-mapboxglopeneuler20.03
Diffstat (limited to 'python-mapboxgl.spec')
-rw-r--r--python-mapboxgl.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-mapboxgl.spec b/python-mapboxgl.spec
new file mode 100644
index 0000000..84d86f5
--- /dev/null
+++ b/python-mapboxgl.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mapboxgl
+Version: 0.10.2
+Release: 1
+Summary: MapboxGL plugin for Jupyter Notebooks
+License: MIT
+URL: https://github.com/mapbox/mapboxgl-jupyter
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/90/03/bb7d041edaa91968be45d87e44b883ba568da6e072ce16f9c7147265de82/mapboxgl-0.10.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-jinja2
+Requires: python3-geojson
+Requires: python3-chroma-py
+Requires: python3-colour
+Requires: python3-matplotlib
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-codecov
+Requires: python3-mock
+Requires: python3-jupyter
+Requires: python3-Sphinx
+Requires: python3-pandas
+
+%description
+Use Mapbox GL natively in your Jupyter Notebook workflows
+
+
+
+
+%package -n python3-mapboxgl
+Summary: MapboxGL plugin for Jupyter Notebooks
+Provides: python-mapboxgl
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mapboxgl
+Use Mapbox GL natively in your Jupyter Notebook workflows
+
+
+
+
+%package help
+Summary: Development documents and examples for mapboxgl
+Provides: python3-mapboxgl-doc
+%description help
+Use Mapbox GL natively in your Jupyter Notebook workflows
+
+
+
+
+%prep
+%autosetup -n mapboxgl-0.10.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mapboxgl -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.2-1
+- Package Spec generated