summaryrefslogtreecommitdiff
path: root/python-markdown-inline-graphviz-extension.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 23:06:19 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 23:06:19 +0000
commit4336a76e0c794dd8267b28806d4f0d5303451352 (patch)
treefd6d3100d368f870632c8967349ca3248787d5f3 /python-markdown-inline-graphviz-extension.spec
parent535ca437e7fa4881dc859026a8b409252f0e2670 (diff)
automatic import of python-markdown-inline-graphviz-extension
Diffstat (limited to 'python-markdown-inline-graphviz-extension.spec')
-rw-r--r--python-markdown-inline-graphviz-extension.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-markdown-inline-graphviz-extension.spec b/python-markdown-inline-graphviz-extension.spec
new file mode 100644
index 0000000..007b8a7
--- /dev/null
+++ b/python-markdown-inline-graphviz-extension.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-markdown-inline-graphviz-extension
+Version: 1.1.1
+Release: 1
+Summary: Render inline graphs with Markdown and Graphviz (python3 version)
+License: MIT
+URL: https://github.com/cesaremorel/markdown-inline-graphviz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/35/607ca124fb3818724f6ff53098a5d18d36f7ce1368d66b4151a9342cf9a3/markdown_inline_graphviz_extension-1.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Markdown
+
+%description
+This is just a continuation of the great job of Steffen Prince (sprin/markdown-inline-graphviz) in order to get it work with pip3. If you use python 2, please use the original extension instead.
+
+
+%package -n python3-markdown-inline-graphviz-extension
+Summary: Render inline graphs with Markdown and Graphviz (python3 version)
+Provides: python-markdown-inline-graphviz-extension
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-markdown-inline-graphviz-extension
+This is just a continuation of the great job of Steffen Prince (sprin/markdown-inline-graphviz) in order to get it work with pip3. If you use python 2, please use the original extension instead.
+
+
+%package help
+Summary: Development documents and examples for markdown-inline-graphviz-extension
+Provides: python3-markdown-inline-graphviz-extension-doc
+%description help
+This is just a continuation of the great job of Steffen Prince (sprin/markdown-inline-graphviz) in order to get it work with pip3. If you use python 2, please use the original extension instead.
+
+
+%prep
+%autosetup -n markdown-inline-graphviz-extension-1.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-markdown-inline-graphviz-extension -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
+- Package Spec generated