summaryrefslogtreecommitdiff
path: root/python-markdownbear.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-markdownbear.spec')
-rw-r--r--python-markdownbear.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-markdownbear.spec b/python-markdownbear.spec
new file mode 100644
index 0000000..55bebb7
--- /dev/null
+++ b/python-markdownbear.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-MarkdownBear
+Version: 0.10.0
+Release: 1
+Summary: 'MarkdownBear' bear for coala (http://coala.rtfd.org/)
+License: AGPL-3.0
+URL: https://pypi.org/project/MarkdownBear/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b7/a5/8b7a415d502932e14dedb1feb7a8952cfa147ba7420048a47ce9bb1f6952/MarkdownBear-0.10.0.tar.gz
+BuildArch: noarch
+
+
+%description
+Check and correct Markdown style violations automatically.
+
+ See <https://github.com/wooorm/remark-lint> for details about the tool
+ below.
+
+%package -n python3-MarkdownBear
+Summary: 'MarkdownBear' bear for coala (http://coala.rtfd.org/)
+Provides: python-MarkdownBear
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-MarkdownBear
+Check and correct Markdown style violations automatically.
+
+ See <https://github.com/wooorm/remark-lint> for details about the tool
+ below.
+
+%package help
+Summary: Development documents and examples for MarkdownBear
+Provides: python3-MarkdownBear-doc
+%description help
+Check and correct Markdown style violations automatically.
+
+ See <https://github.com/wooorm/remark-lint> for details about the tool
+ below.
+
+%prep
+%autosetup -n MarkdownBear-0.10.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-MarkdownBear -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.0-1
+- Package Spec generated