summaryrefslogtreecommitdiff
path: root/python-mega-py.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 06:22:35 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 06:22:35 +0000
commite2716a2da80a7a23b3792e981801d3b2c8cec271 (patch)
tree11605788f8f4f27e9946b12b27f01efdf2ad2a5d /python-mega-py.spec
parentae12bf88ad39b5f937c48385a213556cee5d8130 (diff)
automatic import of python-mega-py
Diffstat (limited to 'python-mega-py.spec')
-rw-r--r--python-mega-py.spec118
1 files changed, 118 insertions, 0 deletions
diff --git a/python-mega-py.spec b/python-mega-py.spec
new file mode 100644
index 0000000..ea06cd3
--- /dev/null
+++ b/python-mega-py.spec
@@ -0,0 +1,118 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mega.py
+Version: 1.0.8
+Release: 1
+Summary: Python lib for the Mega.co.nz API
+License: Creative Commons Attribution-Noncommercial-Share Alike license
+URL: https://github.com/odwyersoftware/mega.py
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/47/0d/211ed7689526f27bc6138f611267553ff27ad539bb4529095e80dd48f21b/mega.py-1.0.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-requests
+Requires: python3-pycryptodome
+Requires: python3-pathlib
+Requires: python3-tenacity
+
+%description
+[![Build
+Status](https://travis-ci.org/odwyersoftware/mega.py.png?branch=master)](https://travis-ci.org/odwyersoftware/mega.py)
+[![Downloads](https://pypip.in/d/mega.py/badge.png)](https://crate.io/packages/mega.py/) [![PyPI version](https://badge.fury.io/py/mega.py.svg)](https://pypi.org/project/mega.py/)
+Python library for the [Mega.co.nz](https://mega.nz/aff=Zo6IxNaHw14)
+API, currently supporting:
+- login
+- uploading
+- downloading
+- deleting
+- searching
+- sharing
+- renaming
+- moving files
+This is a work in progress, further functionality coming shortly.
+For more detailed information see API\_INFO.md
+
+%package -n python3-mega.py
+Summary: Python lib for the Mega.co.nz API
+Provides: python-mega.py
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mega.py
+[![Build
+Status](https://travis-ci.org/odwyersoftware/mega.py.png?branch=master)](https://travis-ci.org/odwyersoftware/mega.py)
+[![Downloads](https://pypip.in/d/mega.py/badge.png)](https://crate.io/packages/mega.py/) [![PyPI version](https://badge.fury.io/py/mega.py.svg)](https://pypi.org/project/mega.py/)
+Python library for the [Mega.co.nz](https://mega.nz/aff=Zo6IxNaHw14)
+API, currently supporting:
+- login
+- uploading
+- downloading
+- deleting
+- searching
+- sharing
+- renaming
+- moving files
+This is a work in progress, further functionality coming shortly.
+For more detailed information see API\_INFO.md
+
+%package help
+Summary: Development documents and examples for mega.py
+Provides: python3-mega.py-doc
+%description help
+[![Build
+Status](https://travis-ci.org/odwyersoftware/mega.py.png?branch=master)](https://travis-ci.org/odwyersoftware/mega.py)
+[![Downloads](https://pypip.in/d/mega.py/badge.png)](https://crate.io/packages/mega.py/) [![PyPI version](https://badge.fury.io/py/mega.py.svg)](https://pypi.org/project/mega.py/)
+Python library for the [Mega.co.nz](https://mega.nz/aff=Zo6IxNaHw14)
+API, currently supporting:
+- login
+- uploading
+- downloading
+- deleting
+- searching
+- sharing
+- renaming
+- moving files
+This is a work in progress, further functionality coming shortly.
+For more detailed information see API\_INFO.md
+
+%prep
+%autosetup -n mega.py-1.0.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mega.py -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.8-1
+- Package Spec generated