summaryrefslogtreecommitdiff
path: root/python-microversion-parse.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 11:18:59 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 11:18:59 +0000
commit1ae2b6a8f00c43214d4eb47b1066583ad61fdba7 (patch)
tree5edb6c71fea264ef35351522edd58ee955aadcb6 /python-microversion-parse.spec
parentc25c4517005dfcdc1d6980b3024eb9b6ff03133a (diff)
automatic import of python-microversion-parse
Diffstat (limited to 'python-microversion-parse.spec')
-rw-r--r--python-microversion-parse.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-microversion-parse.spec b/python-microversion-parse.spec
new file mode 100644
index 0000000..2672027
--- /dev/null
+++ b/python-microversion-parse.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-microversion-parse
+Version: 1.0.1
+Release: 1
+Summary: OpenStack microversion header parser
+License: Apache Software License
+URL: http://www.openstack.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1c/bb/ffeb8ac7acfe77425220352f1338e164ceb1177fdb69f7bcbc6750ca878d/microversion_parse-1.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-WebOb
+
+%description
+A small set of functions to manage OpenStack `microversion`_ headers that can
+be used in middleware, application handlers and decorators to effectively
+manage microversions.
+Also included, in the ``middleware`` module, is a ``MicroversionMiddleware``
+that will process incoming microversion headers.
+
+%package -n python3-microversion-parse
+Summary: OpenStack microversion header parser
+Provides: python-microversion-parse
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-microversion-parse
+A small set of functions to manage OpenStack `microversion`_ headers that can
+be used in middleware, application handlers and decorators to effectively
+manage microversions.
+Also included, in the ``middleware`` module, is a ``MicroversionMiddleware``
+that will process incoming microversion headers.
+
+%package help
+Summary: Development documents and examples for microversion-parse
+Provides: python3-microversion-parse-doc
+%description help
+A small set of functions to manage OpenStack `microversion`_ headers that can
+be used in middleware, application handlers and decorators to effectively
+manage microversions.
+Also included, in the ``middleware`` module, is a ``MicroversionMiddleware``
+that will process incoming microversion headers.
+
+%prep
+%autosetup -n microversion-parse-1.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-microversion-parse -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.1-1
+- Package Spec generated