summaryrefslogtreecommitdiff
path: root/python-minisom.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-minisom.spec')
-rw-r--r--python-minisom.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-minisom.spec b/python-minisom.spec
new file mode 100644
index 0000000..21e0fde
--- /dev/null
+++ b/python-minisom.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-MiniSom
+Version: 2.3.1
+Release: 1
+Summary: Minimalistic implementation of the Self Organizing Maps (SOM)
+License: MIT
+URL: https://github.com/JustGlowing/minisom
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b4/aa/22d31e9f3fbd462585099f8fd07a5373cff1c00ae3c9455e1de8f3b56c7b/MiniSom-2.3.1.tar.gz
+BuildArch: noarch
+
+
+%description
+See the github page https://github.com/JustGlowing/minisom
+
+
+
+%package -n python3-MiniSom
+Summary: Minimalistic implementation of the Self Organizing Maps (SOM)
+Provides: python-MiniSom
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-MiniSom
+See the github page https://github.com/JustGlowing/minisom
+
+
+
+%package help
+Summary: Development documents and examples for MiniSom
+Provides: python3-MiniSom-doc
+%description help
+See the github page https://github.com/JustGlowing/minisom
+
+
+
+%prep
+%autosetup -n MiniSom-2.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-MiniSom -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.3.1-1
+- Package Spec generated