summaryrefslogtreecommitdiff
path: root/python-mockaioredis.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mockaioredis.spec')
-rw-r--r--python-mockaioredis.spec103
1 files changed, 103 insertions, 0 deletions
diff --git a/python-mockaioredis.spec b/python-mockaioredis.spec
new file mode 100644
index 0000000..9c27c09
--- /dev/null
+++ b/python-mockaioredis.spec
@@ -0,0 +1,103 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mockaioredis
+Version: 0.0.16
+Release: 1
+Summary: Mock implementation of aioredis
+License: Apache Software License
+URL: https://github.com/kblin/mockaioredis
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/bb/29b47ffe1765adcb2e01b6a43f0153b5bf32d13fd307d32ab71f5745b0ad/mockaioredis-0.0.16.tar.gz
+BuildArch: noarch
+
+Requires: python3-aioredis
+Requires: python3-mockredispy-kblin
+Requires: python3-twine
+Requires: python3-coverage
+Requires: python3-pytest
+Requires: python3-pytest-asyncio
+Requires: python3-pytest-cov
+
+%description
+[![Build Status](https://travis-ci.com/kblin/mockaioredis.svg?branch=master)](https://travis-ci.com/kblin/mockaioredis)
+mockaioredis is to [aioredis] what the [mockredispy] library is to plain [redis-py].
+It uses the mockredispy library and wraps it in the asyncio magic required to work like
+aioredis.
+Uses the new `async` keyword for Python 3.5, so no 3.4 support.
+**Beware**: This is an early alpha that isn't even close to API-complete.
+In fact, so far it only supports the limited set of calls I needed for another project.
+Eventually, as I use more and more aioredis calls in my other projects, this mock layer
+will be fleshed out more.
+
+%package -n python3-mockaioredis
+Summary: Mock implementation of aioredis
+Provides: python-mockaioredis
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mockaioredis
+[![Build Status](https://travis-ci.com/kblin/mockaioredis.svg?branch=master)](https://travis-ci.com/kblin/mockaioredis)
+mockaioredis is to [aioredis] what the [mockredispy] library is to plain [redis-py].
+It uses the mockredispy library and wraps it in the asyncio magic required to work like
+aioredis.
+Uses the new `async` keyword for Python 3.5, so no 3.4 support.
+**Beware**: This is an early alpha that isn't even close to API-complete.
+In fact, so far it only supports the limited set of calls I needed for another project.
+Eventually, as I use more and more aioredis calls in my other projects, this mock layer
+will be fleshed out more.
+
+%package help
+Summary: Development documents and examples for mockaioredis
+Provides: python3-mockaioredis-doc
+%description help
+[![Build Status](https://travis-ci.com/kblin/mockaioredis.svg?branch=master)](https://travis-ci.com/kblin/mockaioredis)
+mockaioredis is to [aioredis] what the [mockredispy] library is to plain [redis-py].
+It uses the mockredispy library and wraps it in the asyncio magic required to work like
+aioredis.
+Uses the new `async` keyword for Python 3.5, so no 3.4 support.
+**Beware**: This is an early alpha that isn't even close to API-complete.
+In fact, so far it only supports the limited set of calls I needed for another project.
+Eventually, as I use more and more aioredis calls in my other projects, this mock layer
+will be fleshed out more.
+
+%prep
+%autosetup -n mockaioredis-0.0.16
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mockaioredis -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.16-1
+- Package Spec generated