summaryrefslogtreecommitdiff
path: root/python-modapy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 18:38:01 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 18:38:01 +0000
commit710ab6acbc45ab1aaa9fa813ec2801f15f31757d (patch)
tree3c98b2ed4a7d1b6bf1a3a2c4530e467acc2cbabb /python-modapy.spec
parent135b6a9cb025b9452346f31333b397c4f6ae9a5f (diff)
automatic import of python-modapy
Diffstat (limited to 'python-modapy.spec')
-rw-r--r--python-modapy.spec171
1 files changed, 171 insertions, 0 deletions
diff --git a/python-modapy.spec b/python-modapy.spec
new file mode 100644
index 0000000..3f36d7a
--- /dev/null
+++ b/python-modapy.spec
@@ -0,0 +1,171 @@
+%global _empty_manifest_terminate_build 0
+Name: python-MODApy
+Version: 0.7.8
+Release: 1
+Summary: Package to perform several analysis on Multi-Omics Data
+License: GNU General Public License (GPL)
+URL: https://github.com/juancgvazquez/MODApy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8c/19/befa942842a3bff717c5b5e356f0bd503c416fcb1d90caa4a6acc90eb63b/MODApy-0.7.8.tar.gz
+BuildArch: noarch
+
+Requires: python3-rq
+Requires: python3-uvicorn
+Requires: python3-pandas
+Requires: python3-numpy
+Requires: python3-configparser
+Requires: python3-argparse
+Requires: python3-Cython
+Requires: python3-cyvcf2
+Requires: python3-xlrd
+Requires: python3-openpyxl
+Requires: python3-XlsxWriter
+Requires: python3-matplotlib
+Requires: python3-matplotlib-venn
+Requires: python3-xmltodict
+Requires: python3-pyyaml
+Requires: python3-requests
+Requires: python3-tqdm
+Requires: python3-fastapi
+
+%description
+# MODA
+Multi-Omics Data Analysis (MODA) is an analitical platform for presicion medicine in Python and R, the MODApy and MODAr family. It allows easy and friendly analysis the Whole Exome Sequencing (WES) data or clinical applications such as SNP identification and priorization and SNP database generation from analyzed patients. In this sence it allows building a home made data base for local and private use.
+
+## Current facilities
+The platform can be deployed in a local or remote server acceced trhough a Shiny web interface trhough RStudio Server and Python. The platform allow retrieving raw sequencing data from sequencong providers such as Macrogen(r) and others, by providing approrpiate url to the data. The patients will be downloaded and orgnanized into a local data base.
+* SNP hunting: It apply GATK best practices for mutation detection and annotation trhough an optimized pipeline.
+* SNP population based database: It allows building a local data base of SNP, with Zigocity information, allele frequency and SNP population frequency. Such type of database is important when analyzing local variant frequencies that may allow filtering or population characterization.
+* Single, duos and trios WES analysis and comparison by means of User defined Gene sets implementing state of the art processing pipelines applying good practices protocols. A gene set is a list of genes pathological or pehnotipical associated by the user. It can be used for the study of mendelian/hereditary diseases. The results are saved in an Excel(r) file with clinvar, dbGap, dbSNP annotation plus local allee frequency and population based frequency. The files also hold url links to genecards, snpDB and Varsome web platforms for each detected variant to simplify acces to uptodate information.
+
+## Under development
+* Gene Fusion RNAseq-based detection: It is based on [Arriba](https://arriba.readthedocs.io/en/latest/) software, the winner of the [DREAM SMC-RNA Challenge](https://www.synapse.org/SMC_RNA) in addition with specific visualization capabilities exclusive for MODA family.
+* Gene expression analysis: Gene and exon quantification
+* Immune tumor microenvironment deconvolution of RNAseq samples trhough [MIXTURE]
+
+
+## Current services
+* Local and remote Instalation of the MODA family in your local or remote server for institutional use
+* We provided WES analysis and advice
+* We provide Gene-Fusion, gene expression and immune deconvolution analysis
+
+Please contact for further details efernandez at cidie . ucc . edu . ar
+
+Authors:
+
+Juan Carlos Vázquez, UTN FRC - UCC
+
+Elmer Andrés Fernández (PhD) - CIDIE - UCC - CONICET
+
+
+%package -n python3-MODApy
+Summary: Package to perform several analysis on Multi-Omics Data
+Provides: python-MODApy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-MODApy
+# MODA
+Multi-Omics Data Analysis (MODA) is an analitical platform for presicion medicine in Python and R, the MODApy and MODAr family. It allows easy and friendly analysis the Whole Exome Sequencing (WES) data or clinical applications such as SNP identification and priorization and SNP database generation from analyzed patients. In this sence it allows building a home made data base for local and private use.
+
+## Current facilities
+The platform can be deployed in a local or remote server acceced trhough a Shiny web interface trhough RStudio Server and Python. The platform allow retrieving raw sequencing data from sequencong providers such as Macrogen(r) and others, by providing approrpiate url to the data. The patients will be downloaded and orgnanized into a local data base.
+* SNP hunting: It apply GATK best practices for mutation detection and annotation trhough an optimized pipeline.
+* SNP population based database: It allows building a local data base of SNP, with Zigocity information, allele frequency and SNP population frequency. Such type of database is important when analyzing local variant frequencies that may allow filtering or population characterization.
+* Single, duos and trios WES analysis and comparison by means of User defined Gene sets implementing state of the art processing pipelines applying good practices protocols. A gene set is a list of genes pathological or pehnotipical associated by the user. It can be used for the study of mendelian/hereditary diseases. The results are saved in an Excel(r) file with clinvar, dbGap, dbSNP annotation plus local allee frequency and population based frequency. The files also hold url links to genecards, snpDB and Varsome web platforms for each detected variant to simplify acces to uptodate information.
+
+## Under development
+* Gene Fusion RNAseq-based detection: It is based on [Arriba](https://arriba.readthedocs.io/en/latest/) software, the winner of the [DREAM SMC-RNA Challenge](https://www.synapse.org/SMC_RNA) in addition with specific visualization capabilities exclusive for MODA family.
+* Gene expression analysis: Gene and exon quantification
+* Immune tumor microenvironment deconvolution of RNAseq samples trhough [MIXTURE]
+
+
+## Current services
+* Local and remote Instalation of the MODA family in your local or remote server for institutional use
+* We provided WES analysis and advice
+* We provide Gene-Fusion, gene expression and immune deconvolution analysis
+
+Please contact for further details efernandez at cidie . ucc . edu . ar
+
+Authors:
+
+Juan Carlos Vázquez, UTN FRC - UCC
+
+Elmer Andrés Fernández (PhD) - CIDIE - UCC - CONICET
+
+
+%package help
+Summary: Development documents and examples for MODApy
+Provides: python3-MODApy-doc
+%description help
+# MODA
+Multi-Omics Data Analysis (MODA) is an analitical platform for presicion medicine in Python and R, the MODApy and MODAr family. It allows easy and friendly analysis the Whole Exome Sequencing (WES) data or clinical applications such as SNP identification and priorization and SNP database generation from analyzed patients. In this sence it allows building a home made data base for local and private use.
+
+## Current facilities
+The platform can be deployed in a local or remote server acceced trhough a Shiny web interface trhough RStudio Server and Python. The platform allow retrieving raw sequencing data from sequencong providers such as Macrogen(r) and others, by providing approrpiate url to the data. The patients will be downloaded and orgnanized into a local data base.
+* SNP hunting: It apply GATK best practices for mutation detection and annotation trhough an optimized pipeline.
+* SNP population based database: It allows building a local data base of SNP, with Zigocity information, allele frequency and SNP population frequency. Such type of database is important when analyzing local variant frequencies that may allow filtering or population characterization.
+* Single, duos and trios WES analysis and comparison by means of User defined Gene sets implementing state of the art processing pipelines applying good practices protocols. A gene set is a list of genes pathological or pehnotipical associated by the user. It can be used for the study of mendelian/hereditary diseases. The results are saved in an Excel(r) file with clinvar, dbGap, dbSNP annotation plus local allee frequency and population based frequency. The files also hold url links to genecards, snpDB and Varsome web platforms for each detected variant to simplify acces to uptodate information.
+
+## Under development
+* Gene Fusion RNAseq-based detection: It is based on [Arriba](https://arriba.readthedocs.io/en/latest/) software, the winner of the [DREAM SMC-RNA Challenge](https://www.synapse.org/SMC_RNA) in addition with specific visualization capabilities exclusive for MODA family.
+* Gene expression analysis: Gene and exon quantification
+* Immune tumor microenvironment deconvolution of RNAseq samples trhough [MIXTURE]
+
+
+## Current services
+* Local and remote Instalation of the MODA family in your local or remote server for institutional use
+* We provided WES analysis and advice
+* We provide Gene-Fusion, gene expression and immune deconvolution analysis
+
+Please contact for further details efernandez at cidie . ucc . edu . ar
+
+Authors:
+
+Juan Carlos Vázquez, UTN FRC - UCC
+
+Elmer Andrés Fernández (PhD) - CIDIE - UCC - CONICET
+
+
+%prep
+%autosetup -n MODApy-0.7.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-MODApy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.7.8-1
+- Package Spec generated