summaryrefslogtreecommitdiff
path: root/python-modelldcatnotordf.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 04:43:20 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 04:43:20 +0000
commite3cebd07746ac299de71e919bc362e5b821adaa0 (patch)
tree6fa04c08aa8b3906ed9b0e744843a9c2d2baab23 /python-modelldcatnotordf.spec
parent42cfe16922bc47118e1229b12572ef0e5709fb1d (diff)
automatic import of python-modelldcatnotordf
Diffstat (limited to 'python-modelldcatnotordf.spec')
-rw-r--r--python-modelldcatnotordf.spec319
1 files changed, 319 insertions, 0 deletions
diff --git a/python-modelldcatnotordf.spec b/python-modelldcatnotordf.spec
new file mode 100644
index 0000000..8750bcd
--- /dev/null
+++ b/python-modelldcatnotordf.spec
@@ -0,0 +1,319 @@
+%global _empty_manifest_terminate_build 0
+Name: python-modelldcatnotordf
+Version: 1.1.1
+Release: 1
+Summary: A library for mapping a modelldcatno model to rdf
+License: Apache-2.0
+URL: https://github.com/Informasjonsforvaltning/modelldcatnotordf
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/03/65/52d33fe21866de3df9aa9579b69e808f30a509ca712512ec5f00aae59b6e/modelldcatnotordf-1.1.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-rdflib
+Requires: python3-importlib_metadata
+Requires: python3-concepttordf
+Requires: python3-datacatalogtordf
+Requires: python3-validators
+Requires: python3-pytest-mock
+Requires: python3-skolemizer
+
+%description
+# modelldcatnotordf
+
+![Tests](https://github.com/Informasjonsforvaltning/modelldcatnotordf/workflows/Tests/badge.svg)
+[![codecov](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf/branch/master/graph/badge.svg)](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf)
+[![PyPI](https://img.shields.io/pypi/v/modelldcatnotordf.svg)](https://pypi.org/project/modelldcatnotordf/)
+[![Read the Docs](https://readthedocs.org/projects/modelldcatnotordf/badge/)](https://modelldcatnotordf.readthedocs.io/)
+
+
+A small Python library for mapping a modell catalog to rdf
+
+The library contains helper classes for the following modelldcat-ap-no classes:
+ - [InformationModel](https://informasjonsforvaltning.github.io/modelldcat-ap-no/#klasse-informasjonsmodell)
+
+ The library will map to [the Norwegian Application Profile](https://informasjonsforvaltning.github.io/modelldcat-ap-no/).
+
+## Usage
+### Install
+```
+% pip install modelldcatnotordf
+```
+### Getting started
+```
+from datacatalogtordf import Catalog
+from modelldcatnotordf import InformationModel
+
+# Create catalog object
+catalog = Catalog()
+catalog.identifier = "http://example.com/catalogs/1"
+catalog.title = {"en": "A model catalog"}
+catalog.publisher = "https://example.com/publishers/1"
+
+# Create a model:
+model = InformationModel()
+model.identifier = "http://example.com/models/1"
+model.description = {"nb": "En adressemodell"}
+# ... and further attributes ...
+#
+# Add model to catalog:
+catalog.model.append(model)
+
+# get rdf representation in turtle (default)
+rdf = catalog.to_rdf()
+print(rdf.decode())
+```
+## Development
+### Requirements
+- python3
+- [pyenv](https://github.com/pyenv/pyenv)
+- [pipx] (https://github.com/pipxproject/pipx)
+- [poetry](https://python-poetry.org/)
+- [nox](https://nox.thea.codes/en/stable/)
+
+```
+% pipx install poetry==1.0.5
+% pipx install nox==2020.8.22
+% pipx inject nox nox-poetry
+```
+### Install
+```
+% git clone https://github.com/Informasjonsforvaltning/modelldcatnotordf.git
+% cd modelldcatnotordf
+% pyenv install 3.8.6
+% pyenv install 3.7.9
+% pyenv local 3.8.6 3.7.9
+% poetry install
+```
+### Run all sessions
+```
+% nox
+```
+### Run all tests with coverage reporting
+```
+% nox -rs tests
+```
+### Debugging
+You can enter into [Pdb](https://docs.python.org/3/library/pdb.html) by passing `--pdb` to pytest:
+```
+nox -rs tests -- --pdb
+```
+You can set breakpoints directly in code by using the function `breakpoint()`.
+
+
+%package -n python3-modelldcatnotordf
+Summary: A library for mapping a modelldcatno model to rdf
+Provides: python-modelldcatnotordf
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-modelldcatnotordf
+# modelldcatnotordf
+
+![Tests](https://github.com/Informasjonsforvaltning/modelldcatnotordf/workflows/Tests/badge.svg)
+[![codecov](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf/branch/master/graph/badge.svg)](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf)
+[![PyPI](https://img.shields.io/pypi/v/modelldcatnotordf.svg)](https://pypi.org/project/modelldcatnotordf/)
+[![Read the Docs](https://readthedocs.org/projects/modelldcatnotordf/badge/)](https://modelldcatnotordf.readthedocs.io/)
+
+
+A small Python library for mapping a modell catalog to rdf
+
+The library contains helper classes for the following modelldcat-ap-no classes:
+ - [InformationModel](https://informasjonsforvaltning.github.io/modelldcat-ap-no/#klasse-informasjonsmodell)
+
+ The library will map to [the Norwegian Application Profile](https://informasjonsforvaltning.github.io/modelldcat-ap-no/).
+
+## Usage
+### Install
+```
+% pip install modelldcatnotordf
+```
+### Getting started
+```
+from datacatalogtordf import Catalog
+from modelldcatnotordf import InformationModel
+
+# Create catalog object
+catalog = Catalog()
+catalog.identifier = "http://example.com/catalogs/1"
+catalog.title = {"en": "A model catalog"}
+catalog.publisher = "https://example.com/publishers/1"
+
+# Create a model:
+model = InformationModel()
+model.identifier = "http://example.com/models/1"
+model.description = {"nb": "En adressemodell"}
+# ... and further attributes ...
+#
+# Add model to catalog:
+catalog.model.append(model)
+
+# get rdf representation in turtle (default)
+rdf = catalog.to_rdf()
+print(rdf.decode())
+```
+## Development
+### Requirements
+- python3
+- [pyenv](https://github.com/pyenv/pyenv)
+- [pipx] (https://github.com/pipxproject/pipx)
+- [poetry](https://python-poetry.org/)
+- [nox](https://nox.thea.codes/en/stable/)
+
+```
+% pipx install poetry==1.0.5
+% pipx install nox==2020.8.22
+% pipx inject nox nox-poetry
+```
+### Install
+```
+% git clone https://github.com/Informasjonsforvaltning/modelldcatnotordf.git
+% cd modelldcatnotordf
+% pyenv install 3.8.6
+% pyenv install 3.7.9
+% pyenv local 3.8.6 3.7.9
+% poetry install
+```
+### Run all sessions
+```
+% nox
+```
+### Run all tests with coverage reporting
+```
+% nox -rs tests
+```
+### Debugging
+You can enter into [Pdb](https://docs.python.org/3/library/pdb.html) by passing `--pdb` to pytest:
+```
+nox -rs tests -- --pdb
+```
+You can set breakpoints directly in code by using the function `breakpoint()`.
+
+
+%package help
+Summary: Development documents and examples for modelldcatnotordf
+Provides: python3-modelldcatnotordf-doc
+%description help
+# modelldcatnotordf
+
+![Tests](https://github.com/Informasjonsforvaltning/modelldcatnotordf/workflows/Tests/badge.svg)
+[![codecov](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf/branch/master/graph/badge.svg)](https://codecov.io/gh/Informasjonsforvaltning/modelldcatnotordf)
+[![PyPI](https://img.shields.io/pypi/v/modelldcatnotordf.svg)](https://pypi.org/project/modelldcatnotordf/)
+[![Read the Docs](https://readthedocs.org/projects/modelldcatnotordf/badge/)](https://modelldcatnotordf.readthedocs.io/)
+
+
+A small Python library for mapping a modell catalog to rdf
+
+The library contains helper classes for the following modelldcat-ap-no classes:
+ - [InformationModel](https://informasjonsforvaltning.github.io/modelldcat-ap-no/#klasse-informasjonsmodell)
+
+ The library will map to [the Norwegian Application Profile](https://informasjonsforvaltning.github.io/modelldcat-ap-no/).
+
+## Usage
+### Install
+```
+% pip install modelldcatnotordf
+```
+### Getting started
+```
+from datacatalogtordf import Catalog
+from modelldcatnotordf import InformationModel
+
+# Create catalog object
+catalog = Catalog()
+catalog.identifier = "http://example.com/catalogs/1"
+catalog.title = {"en": "A model catalog"}
+catalog.publisher = "https://example.com/publishers/1"
+
+# Create a model:
+model = InformationModel()
+model.identifier = "http://example.com/models/1"
+model.description = {"nb": "En adressemodell"}
+# ... and further attributes ...
+#
+# Add model to catalog:
+catalog.model.append(model)
+
+# get rdf representation in turtle (default)
+rdf = catalog.to_rdf()
+print(rdf.decode())
+```
+## Development
+### Requirements
+- python3
+- [pyenv](https://github.com/pyenv/pyenv)
+- [pipx] (https://github.com/pipxproject/pipx)
+- [poetry](https://python-poetry.org/)
+- [nox](https://nox.thea.codes/en/stable/)
+
+```
+% pipx install poetry==1.0.5
+% pipx install nox==2020.8.22
+% pipx inject nox nox-poetry
+```
+### Install
+```
+% git clone https://github.com/Informasjonsforvaltning/modelldcatnotordf.git
+% cd modelldcatnotordf
+% pyenv install 3.8.6
+% pyenv install 3.7.9
+% pyenv local 3.8.6 3.7.9
+% poetry install
+```
+### Run all sessions
+```
+% nox
+```
+### Run all tests with coverage reporting
+```
+% nox -rs tests
+```
+### Debugging
+You can enter into [Pdb](https://docs.python.org/3/library/pdb.html) by passing `--pdb` to pytest:
+```
+nox -rs tests -- --pdb
+```
+You can set breakpoints directly in code by using the function `breakpoint()`.
+
+
+%prep
+%autosetup -n modelldcatnotordf-1.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-modelldcatnotordf -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.1-1
+- Package Spec generated