summaryrefslogtreecommitdiff
path: root/python-module-build-service.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-module-build-service.spec')
-rw-r--r--python-module-build-service.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-module-build-service.spec b/python-module-build-service.spec
new file mode 100644
index 0000000..eae886c
--- /dev/null
+++ b/python-module-build-service.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-module-build-service
+Version: 3.9.2
+Release: 1
+Summary: The Module Build Service for Modularity
+License: MIT
+URL: https://pagure.io/fm-orchestrator/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/54/155258a8d81f2d4eb6176bfcb86035ba3b6bfcbfd5b33dc784c5123b536d/module-build-service-3.9.2.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-module-build-service
+Summary: The Module Build Service for Modularity
+Provides: python-module-build-service
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-module-build-service
+
+
+%package help
+Summary: Development documents and examples for module-build-service
+Provides: python3-module-build-service-doc
+%description help
+
+
+%prep
+%autosetup -n module-build-service-3.9.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-module-build-service -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 3.9.2-1
+- Package Spec generated