summaryrefslogtreecommitdiff
path: root/python-mondrian.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mondrian.spec')
-rw-r--r--python-mondrian.spec103
1 files changed, 103 insertions, 0 deletions
diff --git a/python-mondrian.spec b/python-mondrian.spec
new file mode 100644
index 0000000..08f1b28
--- /dev/null
+++ b/python-mondrian.spec
@@ -0,0 +1,103 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mondrian
+Version: 0.8.1
+Release: 1
+Summary: Mondrian helps you to configure and use python's logging module once and for ever.
+License: Apache License, Version 2.0
+URL: https://python-mondrian.github.io/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b3/76/6fff3f72ad164a64684189fc5a8ec9c7bb5a407ae121bdb35195bc83298b/mondrian-0.8.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-colorama
+Requires: python3-coverage
+Requires: python3-isort
+Requires: python3-pre-commit
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-sphinx
+
+%description
+Mondrian helps you paint your standard python logger.
+Enabling mondrian is simple and straightforward:
+ import logging
+ import mondrian
+ logger = logging.getLogger()
+ if __name__ == '__main__':
+ mondrian.setup(excepthook=True)
+ logger.setLevel(logging.INFO)
+ logger.info('Hello, world.')
+
+%package -n python3-mondrian
+Summary: Mondrian helps you to configure and use python's logging module once and for ever.
+Provides: python-mondrian
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mondrian
+Mondrian helps you paint your standard python logger.
+Enabling mondrian is simple and straightforward:
+ import logging
+ import mondrian
+ logger = logging.getLogger()
+ if __name__ == '__main__':
+ mondrian.setup(excepthook=True)
+ logger.setLevel(logging.INFO)
+ logger.info('Hello, world.')
+
+%package help
+Summary: Development documents and examples for mondrian
+Provides: python3-mondrian-doc
+%description help
+Mondrian helps you paint your standard python logger.
+Enabling mondrian is simple and straightforward:
+ import logging
+ import mondrian
+ logger = logging.getLogger()
+ if __name__ == '__main__':
+ mondrian.setup(excepthook=True)
+ logger.setLevel(logging.INFO)
+ logger.info('Hello, world.')
+
+%prep
+%autosetup -n mondrian-0.8.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mondrian -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.8.1-1
+- Package Spec generated