summaryrefslogtreecommitdiff
path: root/python-mrkd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mrkd.spec')
-rw-r--r--python-mrkd.spec228
1 files changed, 228 insertions, 0 deletions
diff --git a/python-mrkd.spec b/python-mrkd.spec
new file mode 100644
index 0000000..e1327d0
--- /dev/null
+++ b/python-mrkd.spec
@@ -0,0 +1,228 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mrkd
+Version: 0.2.0
+Release: 1
+Summary: Write man pages using Markdown, and convert them to Roff or HTML
+License: BSD
+URL: https://github.com/refi64/mrkd
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3a/5b/8cacb9e6f5589c5465fb65f79af76122bc6d8970cd3a15c498ca6bc45a93/mrkd-0.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-Jinja2
+Requires: python3-mistune
+Requires: python3-pygments
+
+%description
+# mrkd
+
+Write man pages using Markdown, and convert them to Roff or HTML.
+
+## Installation
+
+```
+$ pip install mrkd
+```
+
+## Usage
+
+```
+$ mrkd my-file.1.md my-file.1
+```
+
+Syntax is `mrkd [options...] input-file output-file`. The name and section number will
+automatically be derived from the input file, though you can override them using
+`-name my-name` and `-section my-section`, respectively.
+
+Change the format to HTML using `-format html`:
+
+```
+$ mrkd my-file.1.md -format html my-file.1.html
+```
+
+You can override the HTML template (see `template.html` for an example) using `-template`.
+
+In order to setup HTML links, you can set up an index file like so:
+
+```ini
+[Index]
+my-page(1)=my-page.1.html
+```
+
+Then, when you do the following in your Markdown files:
+
+```
+something something (see my-page(1))
+```
+
+mrkd will automatically pick up the link and connect it via the index file. Pass it via
+the `-index` argument:
+
+```
+$ mrkd -f html -index index.ini my-file.1.md my-file.1.html
+```
+
+See the `test` directory for an example.
+
+
+
+
+%package -n python3-mrkd
+Summary: Write man pages using Markdown, and convert them to Roff or HTML
+Provides: python-mrkd
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mrkd
+# mrkd
+
+Write man pages using Markdown, and convert them to Roff or HTML.
+
+## Installation
+
+```
+$ pip install mrkd
+```
+
+## Usage
+
+```
+$ mrkd my-file.1.md my-file.1
+```
+
+Syntax is `mrkd [options...] input-file output-file`. The name and section number will
+automatically be derived from the input file, though you can override them using
+`-name my-name` and `-section my-section`, respectively.
+
+Change the format to HTML using `-format html`:
+
+```
+$ mrkd my-file.1.md -format html my-file.1.html
+```
+
+You can override the HTML template (see `template.html` for an example) using `-template`.
+
+In order to setup HTML links, you can set up an index file like so:
+
+```ini
+[Index]
+my-page(1)=my-page.1.html
+```
+
+Then, when you do the following in your Markdown files:
+
+```
+something something (see my-page(1))
+```
+
+mrkd will automatically pick up the link and connect it via the index file. Pass it via
+the `-index` argument:
+
+```
+$ mrkd -f html -index index.ini my-file.1.md my-file.1.html
+```
+
+See the `test` directory for an example.
+
+
+
+
+%package help
+Summary: Development documents and examples for mrkd
+Provides: python3-mrkd-doc
+%description help
+# mrkd
+
+Write man pages using Markdown, and convert them to Roff or HTML.
+
+## Installation
+
+```
+$ pip install mrkd
+```
+
+## Usage
+
+```
+$ mrkd my-file.1.md my-file.1
+```
+
+Syntax is `mrkd [options...] input-file output-file`. The name and section number will
+automatically be derived from the input file, though you can override them using
+`-name my-name` and `-section my-section`, respectively.
+
+Change the format to HTML using `-format html`:
+
+```
+$ mrkd my-file.1.md -format html my-file.1.html
+```
+
+You can override the HTML template (see `template.html` for an example) using `-template`.
+
+In order to setup HTML links, you can set up an index file like so:
+
+```ini
+[Index]
+my-page(1)=my-page.1.html
+```
+
+Then, when you do the following in your Markdown files:
+
+```
+something something (see my-page(1))
+```
+
+mrkd will automatically pick up the link and connect it via the index file. Pass it via
+the `-index` argument:
+
+```
+$ mrkd -f html -index index.ini my-file.1.md my-file.1.html
+```
+
+See the `test` directory for an example.
+
+
+
+
+%prep
+%autosetup -n mrkd-0.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mrkd -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.0-1
+- Package Spec generated