summaryrefslogtreecommitdiff
path: root/python-msm.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 08:38:29 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 08:38:29 +0000
commitfde4bbbf868eeb31815e9b68ae25a120674d3127 (patch)
tree87f535e231e2a4e49867edaf86fcdd3799b58727 /python-msm.spec
parent10cae9bbf16ee640676b9db62fb615f2402dfefd (diff)
automatic import of python-msm
Diffstat (limited to 'python-msm.spec')
-rw-r--r--python-msm.spec226
1 files changed, 226 insertions, 0 deletions
diff --git a/python-msm.spec b/python-msm.spec
new file mode 100644
index 0000000..a4578fd
--- /dev/null
+++ b/python-msm.spec
@@ -0,0 +1,226 @@
+%global _empty_manifest_terminate_build 0
+Name: python-msm
+Version: 0.9.0
+Release: 1
+Summary: Mycroft Skills Manager
+License: Apache-2.0
+URL: https://github.com/MycroftAI/mycroft-skills-manager
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a8/e5/408fb57926a1bc0e304d751e120ba6965f40100dd53516f65a5a0a8dd4bc/msm-0.9.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-GitPython
+Requires: python3-fasteners
+Requires: python3-lazy
+Requires: python3-pako
+Requires: python3-pyxdg
+Requires: python3-pyyaml
+Requires: python3-requests
+
+%description
+## Mycroft Skills Manager
+
+Mycroft Skills Manager is a command line tool and a python module for interacting with the mycroft-skills repository. It allows querying the repository for information (skill listings, skill meta data, etc) and of course installing and removing skills from the system.
+
+## Install
+
+ pip install msm
+
+## Usage
+
+```python
+from msm import MycroftSkillsManager, SkillRepo, MultipleSkillMatches
+
+msm = MycroftSkillsManager(repo=SkillRepo(branch='master'))
+
+# msm = MycroftSkillsManager(platform='picroft', skills_dir='/some/path', repo=SkillRepo(branch='master', url='https://github.com/me/my-repo.git'))
+
+print(msm.find_skill('bitcoin price'))
+msm.install('bitcoin', 'dmp1ce')
+print(msm.list())
+print(msm.find_skill("https://github.com/JarbasAl/skill-stephen-hawking"))
+msm.update()
+msm.install_defaults()
+
+try:
+ msm.install('google')
+except MultipleSkillMatches as e:
+ e.skills[0].install()
+```
+
+```bash
+msm -b master install bitcoin
+msm -b master -p kde default
+# ...
+```
+
+## TODO
+
+- Parse readme.md from skills
+
+## New Features
+
+- Checks for skill_requirements.txt, will install skills listed there
+
+## Credits
+
+[JarbasAI/py_msm](https://github.com/JarbasAl/ZZZ-py_msm) and Mycroft AI
+
+
+
+
+%package -n python3-msm
+Summary: Mycroft Skills Manager
+Provides: python-msm
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-msm
+## Mycroft Skills Manager
+
+Mycroft Skills Manager is a command line tool and a python module for interacting with the mycroft-skills repository. It allows querying the repository for information (skill listings, skill meta data, etc) and of course installing and removing skills from the system.
+
+## Install
+
+ pip install msm
+
+## Usage
+
+```python
+from msm import MycroftSkillsManager, SkillRepo, MultipleSkillMatches
+
+msm = MycroftSkillsManager(repo=SkillRepo(branch='master'))
+
+# msm = MycroftSkillsManager(platform='picroft', skills_dir='/some/path', repo=SkillRepo(branch='master', url='https://github.com/me/my-repo.git'))
+
+print(msm.find_skill('bitcoin price'))
+msm.install('bitcoin', 'dmp1ce')
+print(msm.list())
+print(msm.find_skill("https://github.com/JarbasAl/skill-stephen-hawking"))
+msm.update()
+msm.install_defaults()
+
+try:
+ msm.install('google')
+except MultipleSkillMatches as e:
+ e.skills[0].install()
+```
+
+```bash
+msm -b master install bitcoin
+msm -b master -p kde default
+# ...
+```
+
+## TODO
+
+- Parse readme.md from skills
+
+## New Features
+
+- Checks for skill_requirements.txt, will install skills listed there
+
+## Credits
+
+[JarbasAI/py_msm](https://github.com/JarbasAl/ZZZ-py_msm) and Mycroft AI
+
+
+
+
+%package help
+Summary: Development documents and examples for msm
+Provides: python3-msm-doc
+%description help
+## Mycroft Skills Manager
+
+Mycroft Skills Manager is a command line tool and a python module for interacting with the mycroft-skills repository. It allows querying the repository for information (skill listings, skill meta data, etc) and of course installing and removing skills from the system.
+
+## Install
+
+ pip install msm
+
+## Usage
+
+```python
+from msm import MycroftSkillsManager, SkillRepo, MultipleSkillMatches
+
+msm = MycroftSkillsManager(repo=SkillRepo(branch='master'))
+
+# msm = MycroftSkillsManager(platform='picroft', skills_dir='/some/path', repo=SkillRepo(branch='master', url='https://github.com/me/my-repo.git'))
+
+print(msm.find_skill('bitcoin price'))
+msm.install('bitcoin', 'dmp1ce')
+print(msm.list())
+print(msm.find_skill("https://github.com/JarbasAl/skill-stephen-hawking"))
+msm.update()
+msm.install_defaults()
+
+try:
+ msm.install('google')
+except MultipleSkillMatches as e:
+ e.skills[0].install()
+```
+
+```bash
+msm -b master install bitcoin
+msm -b master -p kde default
+# ...
+```
+
+## TODO
+
+- Parse readme.md from skills
+
+## New Features
+
+- Checks for skill_requirements.txt, will install skills listed there
+
+## Credits
+
+[JarbasAI/py_msm](https://github.com/JarbasAl/ZZZ-py_msm) and Mycroft AI
+
+
+
+
+%prep
+%autosetup -n msm-0.9.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-msm -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.0-1
+- Package Spec generated