summaryrefslogtreecommitdiff
path: root/python-multiprocessing-on-dill.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-multiprocessing-on-dill.spec')
-rw-r--r--python-multiprocessing-on-dill.spec129
1 files changed, 129 insertions, 0 deletions
diff --git a/python-multiprocessing-on-dill.spec b/python-multiprocessing-on-dill.spec
new file mode 100644
index 0000000..9d981cf
--- /dev/null
+++ b/python-multiprocessing-on-dill.spec
@@ -0,0 +1,129 @@
+%global _empty_manifest_terminate_build 0
+Name: python-multiprocessing_on_dill
+Version: 3.5.0a4
+Release: 1
+Summary: A friendly fork of multiprocessing which uses dill instead of pickle
+License: PSFL
+URL: https://github.com/sixty-north/multiprocessing_on_dill
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/86/4d/4b135e2e5cd0194eb29f2ed36e9a77a07596787a9a8ac2279bd4445398f2/multiprocessing_on_dill-3.5.0a4.tar.gz
+BuildArch: noarch
+
+
+%description
+This project is a friendly fork – for Python 3 – of the Python Standard Library `multiprocessing
+<https://docs.python.org/3/library/multiprocessing.html>`_ module, which uses the third-party
+`dill <https://pypi.python.org/pypi/dill>`_ serializer instead of the standard ``pickle`` serializer. This overcomes
+many shortcomings of ``pickle`` which prevent multiprocessing being used with lambdas, closures and other useful Python
+objects.
+The easiest way to use ``multiprocessing_on_dill`` in place of ``multiprocessing`` is simply to replace any import
+statements like this::
+ import multiprocessing
+with::
+ import multiprocessing_on_dill as multiprocessing
+and import statements like this::
+ from multiprocessing import Pool
+with::
+ from multiprocessing_on_dill import Pool
+With such import changes in place, it will now be possible to use functions like ``Pool.map()`` with lambdas::
+ pool = Pool(12)
+ result = pool.map(lambda x: x*x, range(10000))
+Everything else should be identical to the Python version.
+You can determine from which version of the Python Standard Library ``multiprocessing_on_dill`` has been forked, by
+examining the ``multiprocessing_on_dill.__version__`` attribute.
+
+%package -n python3-multiprocessing_on_dill
+Summary: A friendly fork of multiprocessing which uses dill instead of pickle
+Provides: python-multiprocessing_on_dill
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-multiprocessing_on_dill
+This project is a friendly fork – for Python 3 – of the Python Standard Library `multiprocessing
+<https://docs.python.org/3/library/multiprocessing.html>`_ module, which uses the third-party
+`dill <https://pypi.python.org/pypi/dill>`_ serializer instead of the standard ``pickle`` serializer. This overcomes
+many shortcomings of ``pickle`` which prevent multiprocessing being used with lambdas, closures and other useful Python
+objects.
+The easiest way to use ``multiprocessing_on_dill`` in place of ``multiprocessing`` is simply to replace any import
+statements like this::
+ import multiprocessing
+with::
+ import multiprocessing_on_dill as multiprocessing
+and import statements like this::
+ from multiprocessing import Pool
+with::
+ from multiprocessing_on_dill import Pool
+With such import changes in place, it will now be possible to use functions like ``Pool.map()`` with lambdas::
+ pool = Pool(12)
+ result = pool.map(lambda x: x*x, range(10000))
+Everything else should be identical to the Python version.
+You can determine from which version of the Python Standard Library ``multiprocessing_on_dill`` has been forked, by
+examining the ``multiprocessing_on_dill.__version__`` attribute.
+
+%package help
+Summary: Development documents and examples for multiprocessing_on_dill
+Provides: python3-multiprocessing_on_dill-doc
+%description help
+This project is a friendly fork – for Python 3 – of the Python Standard Library `multiprocessing
+<https://docs.python.org/3/library/multiprocessing.html>`_ module, which uses the third-party
+`dill <https://pypi.python.org/pypi/dill>`_ serializer instead of the standard ``pickle`` serializer. This overcomes
+many shortcomings of ``pickle`` which prevent multiprocessing being used with lambdas, closures and other useful Python
+objects.
+The easiest way to use ``multiprocessing_on_dill`` in place of ``multiprocessing`` is simply to replace any import
+statements like this::
+ import multiprocessing
+with::
+ import multiprocessing_on_dill as multiprocessing
+and import statements like this::
+ from multiprocessing import Pool
+with::
+ from multiprocessing_on_dill import Pool
+With such import changes in place, it will now be possible to use functions like ``Pool.map()`` with lambdas::
+ pool = Pool(12)
+ result = pool.map(lambda x: x*x, range(10000))
+Everything else should be identical to the Python version.
+You can determine from which version of the Python Standard Library ``multiprocessing_on_dill`` has been forked, by
+examining the ``multiprocessing_on_dill.__version__`` attribute.
+
+%prep
+%autosetup -n multiprocessing_on_dill-3.5.0a4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-multiprocessing_on_dill -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 3.5.0a4-1
+- Package Spec generated