summaryrefslogtreecommitdiff
path: root/python-munch.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 09:12:49 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 09:12:49 +0000
commit00f12539a8398c6d8d9818848f678825e2dd5eaf (patch)
treeeeae1e4c7f1781f03ad92e22c98e9dc3b1011a87 /python-munch.spec
parent14bab512b1c1fde3b100c18202bc524b69730f73 (diff)
automatic import of python-munch
Diffstat (limited to 'python-munch.spec')
-rw-r--r--python-munch.spec125
1 files changed, 125 insertions, 0 deletions
diff --git a/python-munch.spec b/python-munch.spec
new file mode 100644
index 0000000..b1bb60d
--- /dev/null
+++ b/python-munch.spec
@@ -0,0 +1,125 @@
+%global _empty_manifest_terminate_build 0
+Name: python-munch
+Version: 2.5.0
+Release: 1
+Summary: A dot-accessible dictionary (a la JavaScript objects)
+License: MIT
+URL: https://github.com/Infinidat/munch
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/43/a1/ec48010724eedfe2add68eb7592a0d238590e14e08b95a4ffb3c7b2f0808/munch-2.5.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-pytest
+Requires: python3-coverage
+Requires: python3-astroid
+Requires: python3-pylint
+Requires: python3-astroid
+Requires: python3-pylint
+Requires: python3-PyYAML
+
+%description
+munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
+Munch is a dictionary that supports attribute-style access, a la JavaScript:
+```python
+>>> b = Munch()
+>>> b.hello = 'world'
+>>> b.hello
+'world'
+>>> b['hello'] += "!"
+>>> b.hello
+'world!'
+>>> b.foo = Munch(lol=True)
+>>> b.foo.lol
+True
+>>> b.foo is b['foo']
+True
+```
+
+%package -n python3-munch
+Summary: A dot-accessible dictionary (a la JavaScript objects)
+Provides: python-munch
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-munch
+munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
+Munch is a dictionary that supports attribute-style access, a la JavaScript:
+```python
+>>> b = Munch()
+>>> b.hello = 'world'
+>>> b.hello
+'world'
+>>> b['hello'] += "!"
+>>> b.hello
+'world!'
+>>> b.foo = Munch(lol=True)
+>>> b.foo.lol
+True
+>>> b.foo is b['foo']
+True
+```
+
+%package help
+Summary: Development documents and examples for munch
+Provides: python3-munch-doc
+%description help
+munch is a fork of David Schoonover's **Bunch** package, providing similar functionality. 99% of the work was done by him, and the fork was made mainly for lack of responsiveness for fixes and maintenance on the original code.
+Munch is a dictionary that supports attribute-style access, a la JavaScript:
+```python
+>>> b = Munch()
+>>> b.hello = 'world'
+>>> b.hello
+'world'
+>>> b['hello'] += "!"
+>>> b.hello
+'world!'
+>>> b.foo = Munch(lol=True)
+>>> b.foo.lol
+True
+>>> b.foo is b['foo']
+True
+```
+
+%prep
+%autosetup -n munch-2.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-munch -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5.0-1
+- Package Spec generated