summaryrefslogtreecommitdiff
path: root/python-mypy-boto3-events.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-mypy-boto3-events.spec')
-rw-r--r--python-mypy-boto3-events.spec66
1 files changed, 33 insertions, 33 deletions
diff --git a/python-mypy-boto3-events.spec b/python-mypy-boto3-events.spec
index 7fb3616..585e1ef 100644
--- a/python-mypy-boto3-events.spec
+++ b/python-mypy-boto3-events.spec
@@ -1,11 +1,11 @@
%global _empty_manifest_terminate_build 0
Name: python-mypy-boto3-events
-Version: 1.26.58
+Version: 1.26.111
Release: 1
-Summary: Type annotations for boto3.EventBridge 1.26.58 service generated with mypy-boto3-builder 7.12.3
+Summary: Type annotations for boto3.EventBridge 1.26.111 service generated with mypy-boto3-builder 7.14.5
License: MIT License
URL: https://github.com/youtype/mypy_boto3_builder
-Source0: https://mirrors.nju.edu.cn/pypi/web/packages/de/5d/379ddfe5a55a6ef597a73e1ce0ef87884d6c25a5866dc0eb97d0b2160c28/mypy-boto3-events-1.26.58.tar.gz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/15/2f/136b9afc42a51fd12e364e7250d735410661773b5287cfdc0cc0004c1adf/mypy-boto3-events-1.26.111.tar.gz
BuildArch: noarch
Requires: python3-typing-extensions
@@ -17,13 +17,13 @@ Requires: python3-typing-extensions
[![PyPI - mypy-boto3-events](https://img.shields.io/pypi/v/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
-[![Docs](https://img.shields.io/readthedocs/mypy-boto3-builder.svg?color=blue)](https://mypy-boto3-builder.readthedocs.io/)
+[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/mypy_boto3_events/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3-events?color=blue)](https://pypistats.org/packages/mypy-boto3-events)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Type annotations for
-[boto3.EventBridge 1.26.58](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
+[boto3.EventBridge 1.26.111](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
service compatible with [VSCode](https://code.visualstudio.com/),
[PyCharm](https://www.jetbrains.com/pycharm/),
[Emacs](https://www.gnu.org/software/emacs/),
@@ -32,7 +32,7 @@ service compatible with [VSCode](https://code.visualstudio.com/),
[pyright](https://github.com/microsoft/pyright) and other tools.
Generated by
-[mypy-boto3-builder 7.12.3](https://github.com/youtype/mypy_boto3_builder).
+[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page and in
@@ -514,12 +514,11 @@ def get_structure() -> ActivateEventSourceRequestRequestTypeDef:
Fully automated
[mypy-boto3-builder](https://github.com/youtype/mypy_boto3_builder) carefully
generates type annotations for each service, patiently waiting for `boto3`
-updates. It delivers a drop-in type annotations for you and makes sure that:
+updates. It delivers drop-in type annotations for you and makes sure that:
- All available `boto3` services are covered.
- Each public class and method of every `boto3` service gets valid type
- annotations extracted from the documentation (blame `botocore` docs if types
- are incorrect).
+ annotations extracted from `botocore` schemas.
- Type annotations include up-to-date documentation.
- Link to documentation is provided for every method.
- Code is processed by [black](https://github.com/psf/black) and
@@ -533,15 +532,16 @@ updates. It delivers a drop-in type annotations for you and makes sure that:
### Implemented features
-- Fully type annotated `boto3`, `botocore` and `aiobotocore` libraries
+- Fully type annotated `boto3`, `botocore`, `aiobotocore` and `aioboto3`
+ libraries
- `mypy`, `pyright`, `VSCode`, `PyCharm`, `Sublime Text` and `Emacs`
compatibility
- `Client`, `ServiceResource`, `Resource`, `Waiter` `Paginator` type
annotations for each service
- Generated `TypeDefs` for each service
- Generated `Literals` for each service
-- Auto discovery of types for `boto3.client` and `boto3.session` calls
-- Auto discovery of types for `session.client` and `session.session` calls
+- Auto discovery of types for `boto3.client` and `boto3.resource` calls
+- Auto discovery of types for `session.client` and `session.resource` calls
- Auto discovery of types for `client.get_waiter` and `client.get_paginator`
calls
- Auto discovery of types for `ServiceResource` and `Resource` collections
@@ -594,7 +594,7 @@ repository.
%package -n python3-mypy-boto3-events
-Summary: Type annotations for boto3.EventBridge 1.26.58 service generated with mypy-boto3-builder 7.12.3
+Summary: Type annotations for boto3.EventBridge 1.26.111 service generated with mypy-boto3-builder 7.14.5
Provides: python-mypy-boto3-events
BuildRequires: python3-devel
BuildRequires: python3-setuptools
@@ -606,13 +606,13 @@ BuildRequires: python3-pip
[![PyPI - mypy-boto3-events](https://img.shields.io/pypi/v/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
-[![Docs](https://img.shields.io/readthedocs/mypy-boto3-builder.svg?color=blue)](https://mypy-boto3-builder.readthedocs.io/)
+[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/mypy_boto3_events/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3-events?color=blue)](https://pypistats.org/packages/mypy-boto3-events)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Type annotations for
-[boto3.EventBridge 1.26.58](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
+[boto3.EventBridge 1.26.111](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
service compatible with [VSCode](https://code.visualstudio.com/),
[PyCharm](https://www.jetbrains.com/pycharm/),
[Emacs](https://www.gnu.org/software/emacs/),
@@ -621,7 +621,7 @@ service compatible with [VSCode](https://code.visualstudio.com/),
[pyright](https://github.com/microsoft/pyright) and other tools.
Generated by
-[mypy-boto3-builder 7.12.3](https://github.com/youtype/mypy_boto3_builder).
+[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page and in
@@ -1103,12 +1103,11 @@ def get_structure() -> ActivateEventSourceRequestRequestTypeDef:
Fully automated
[mypy-boto3-builder](https://github.com/youtype/mypy_boto3_builder) carefully
generates type annotations for each service, patiently waiting for `boto3`
-updates. It delivers a drop-in type annotations for you and makes sure that:
+updates. It delivers drop-in type annotations for you and makes sure that:
- All available `boto3` services are covered.
- Each public class and method of every `boto3` service gets valid type
- annotations extracted from the documentation (blame `botocore` docs if types
- are incorrect).
+ annotations extracted from `botocore` schemas.
- Type annotations include up-to-date documentation.
- Link to documentation is provided for every method.
- Code is processed by [black](https://github.com/psf/black) and
@@ -1122,15 +1121,16 @@ updates. It delivers a drop-in type annotations for you and makes sure that:
### Implemented features
-- Fully type annotated `boto3`, `botocore` and `aiobotocore` libraries
+- Fully type annotated `boto3`, `botocore`, `aiobotocore` and `aioboto3`
+ libraries
- `mypy`, `pyright`, `VSCode`, `PyCharm`, `Sublime Text` and `Emacs`
compatibility
- `Client`, `ServiceResource`, `Resource`, `Waiter` `Paginator` type
annotations for each service
- Generated `TypeDefs` for each service
- Generated `Literals` for each service
-- Auto discovery of types for `boto3.client` and `boto3.session` calls
-- Auto discovery of types for `session.client` and `session.session` calls
+- Auto discovery of types for `boto3.client` and `boto3.resource` calls
+- Auto discovery of types for `session.client` and `session.resource` calls
- Auto discovery of types for `client.get_waiter` and `client.get_paginator`
calls
- Auto discovery of types for `ServiceResource` and `Resource` collections
@@ -1192,13 +1192,13 @@ Provides: python3-mypy-boto3-events-doc
[![PyPI - mypy-boto3-events](https://img.shields.io/pypi/v/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
[![PyPI - Python Version](https://img.shields.io/pypi/pyversions/mypy-boto3-events.svg?color=blue)](https://pypi.org/project/mypy-boto3-events)
-[![Docs](https://img.shields.io/readthedocs/mypy-boto3-builder.svg?color=blue)](https://mypy-boto3-builder.readthedocs.io/)
+[![Docs](https://img.shields.io/readthedocs/boto3-stubs.svg?color=blue)](https://youtype.github.io/boto3_stubs_docs/mypy_boto3_events/)
[![PyPI - Downloads](https://img.shields.io/pypi/dm/mypy-boto3-events?color=blue)](https://pypistats.org/packages/mypy-boto3-events)
![boto3.typed](https://github.com/youtype/mypy_boto3_builder/raw/main/logo.png)
Type annotations for
-[boto3.EventBridge 1.26.58](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
+[boto3.EventBridge 1.26.111](https://boto3.amazonaws.com/v1/documentation/api/latest/reference/services/events.html#EventBridge)
service compatible with [VSCode](https://code.visualstudio.com/),
[PyCharm](https://www.jetbrains.com/pycharm/),
[Emacs](https://www.gnu.org/software/emacs/),
@@ -1207,7 +1207,7 @@ service compatible with [VSCode](https://code.visualstudio.com/),
[pyright](https://github.com/microsoft/pyright) and other tools.
Generated by
-[mypy-boto3-builder 7.12.3](https://github.com/youtype/mypy_boto3_builder).
+[mypy-boto3-builder 7.14.5](https://github.com/youtype/mypy_boto3_builder).
More information can be found on
[boto3-stubs](https://pypi.org/project/boto3-stubs/) page and in
@@ -1689,12 +1689,11 @@ def get_structure() -> ActivateEventSourceRequestRequestTypeDef:
Fully automated
[mypy-boto3-builder](https://github.com/youtype/mypy_boto3_builder) carefully
generates type annotations for each service, patiently waiting for `boto3`
-updates. It delivers a drop-in type annotations for you and makes sure that:
+updates. It delivers drop-in type annotations for you and makes sure that:
- All available `boto3` services are covered.
- Each public class and method of every `boto3` service gets valid type
- annotations extracted from the documentation (blame `botocore` docs if types
- are incorrect).
+ annotations extracted from `botocore` schemas.
- Type annotations include up-to-date documentation.
- Link to documentation is provided for every method.
- Code is processed by [black](https://github.com/psf/black) and
@@ -1708,15 +1707,16 @@ updates. It delivers a drop-in type annotations for you and makes sure that:
### Implemented features
-- Fully type annotated `boto3`, `botocore` and `aiobotocore` libraries
+- Fully type annotated `boto3`, `botocore`, `aiobotocore` and `aioboto3`
+ libraries
- `mypy`, `pyright`, `VSCode`, `PyCharm`, `Sublime Text` and `Emacs`
compatibility
- `Client`, `ServiceResource`, `Resource`, `Waiter` `Paginator` type
annotations for each service
- Generated `TypeDefs` for each service
- Generated `Literals` for each service
-- Auto discovery of types for `boto3.client` and `boto3.session` calls
-- Auto discovery of types for `session.client` and `session.session` calls
+- Auto discovery of types for `boto3.client` and `boto3.resource` calls
+- Auto discovery of types for `session.client` and `session.resource` calls
- Auto discovery of types for `client.get_waiter` and `client.get_paginator`
calls
- Auto discovery of types for `ServiceResource` and `Resource` collections
@@ -1769,7 +1769,7 @@ repository.
%prep
-%autosetup -n mypy-boto3-events-1.26.58
+%autosetup -n mypy-boto3-events-1.26.111
%build
%py3_build
@@ -1809,5 +1809,5 @@ mv %{buildroot}/doclist.lst .
%{_docdir}/*
%changelog
-* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.26.58-1
+* Sun Apr 23 2023 Python_Bot <Python_Bot@openeuler.org> - 1.26.111-1
- Package Spec generated