summaryrefslogtreecommitdiff
path: root/python-mysqlpy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 03:03:53 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 03:03:53 +0000
commit93ecefc3abea254fa952ac969ab74ba3431b0ca7 (patch)
tree73df75a1b6b9bb99b9a5e7a53d1e6f49cc4891de /python-mysqlpy.spec
parent299a3defdd301c52c4ec0e8c69cb5c3fb27ba8a3 (diff)
automatic import of python-mysqlpy
Diffstat (limited to 'python-mysqlpy.spec')
-rw-r--r--python-mysqlpy.spec88
1 files changed, 88 insertions, 0 deletions
diff --git a/python-mysqlpy.spec b/python-mysqlpy.spec
new file mode 100644
index 0000000..5fea4f6
--- /dev/null
+++ b/python-mysqlpy.spec
@@ -0,0 +1,88 @@
+%global _empty_manifest_terminate_build 0
+Name: python-mysqlpy
+Version: 8.0.12
+Release: 1
+Summary: MySQL driver written in Python
+License: GNU GPLv2 (with FOSS License Exception)
+URL: http://dev.mysql.com/doc/connector-python/en/index.html
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f2/ec/87a23fce3b8a080902cff7edd0005267de9d94f2469f97fe9df34be9e6c4/mysqlpy-8.0.12.tar.gz
+BuildArch: noarch
+
+Requires: python3-protobuf
+
+%description
+
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+
+
+
+%package -n python3-mysqlpy
+Summary: MySQL driver written in Python
+Provides: python-mysqlpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-mysqlpy
+
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+
+
+
+%package help
+Summary: Development documents and examples for mysqlpy
+Provides: python3-mysqlpy-doc
+%description help
+
+MySQL driver written in Python which does not depend on MySQL C client
+libraries and implements the DB API v2.0 specification (PEP-249).
+
+
+
+
+%prep
+%autosetup -n mysqlpy-8.0.12
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-mysqlpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 8.0.12-1
+- Package Spec generated