summaryrefslogtreecommitdiff
path: root/python-n0struct.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 05:20:58 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 05:20:58 +0000
commit9b0a8e610bb9c48f7d7452dbe0be348688d6d094 (patch)
treeec01d93993572b93e695595ea2d00d1d904f8926 /python-n0struct.spec
parent6882c672e062df2ab4d036a249d10dd8fd3db079 (diff)
automatic import of python-n0struct
Diffstat (limited to 'python-n0struct.spec')
-rw-r--r--python-n0struct.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-n0struct.spec b/python-n0struct.spec
new file mode 100644
index 0000000..3200ef8
--- /dev/null
+++ b/python-n0struct.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-n0struct
+Version: 0.2.97
+Release: 1
+Summary: list/dict extensions allow to load/save/serialize/deserialize xml/json/csv/dsv/fwf files into python/from structures, compare them and work with them using xpath approach
+License: ASL
+URL: https://github.com/pythonist552/n0struct/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7b/b0/fe255c971034ac8b120a70ec288904f63b441c1661e4d018a75025b74d5c/n0struct-0.2.97.tar.gz
+BuildArch: noarch
+
+Requires: python3-xmltodict
+Requires: python3-mypy-extensions
+Requires: python3-loguru
+
+%description
+list/dict extensions allow to load/save/serialize/deserialize xml/json/csv/dsv/fwf files into/from python structures, compare them and work with them using xpath approach
+
+
+%package -n python3-n0struct
+Summary: list/dict extensions allow to load/save/serialize/deserialize xml/json/csv/dsv/fwf files into python/from structures, compare them and work with them using xpath approach
+Provides: python-n0struct
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-n0struct
+list/dict extensions allow to load/save/serialize/deserialize xml/json/csv/dsv/fwf files into/from python structures, compare them and work with them using xpath approach
+
+
+%package help
+Summary: Development documents and examples for n0struct
+Provides: python3-n0struct-doc
+%description help
+list/dict extensions allow to load/save/serialize/deserialize xml/json/csv/dsv/fwf files into/from python structures, compare them and work with them using xpath approach
+
+
+%prep
+%autosetup -n n0struct-0.2.97
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-n0struct -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.97-1
+- Package Spec generated