summaryrefslogtreecommitdiff
path: root/python-nagisa.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-nagisa.spec')
-rw-r--r--python-nagisa.spec128
1 files changed, 128 insertions, 0 deletions
diff --git a/python-nagisa.spec b/python-nagisa.spec
new file mode 100644
index 0000000..30327c3
--- /dev/null
+++ b/python-nagisa.spec
@@ -0,0 +1,128 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nagisa
+Version: 0.2.8
+Release: 1
+Summary: A Japanese tokenizer based on recurrent neural networks
+License: MIT License
+URL: https://github.com/taishi-i/nagisa
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/af/81/2c61ffc4c532efc41e9fdd95109c3d844ff0627d212d95adee3744faa6dc/nagisa-0.2.8.tar.gz
+
+Requires: python3-six
+Requires: python3-numpy
+Requires: python3-DyNet
+
+%description
+[![Python package](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml/badge.svg)](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml)
+[![Build Status](https://app.travis-ci.com/taishi-i/nagisa.svg?branch=master)](https://app.travis-ci.com/taishi-i/nagisa)
+[![Build status](https://ci.appveyor.com/api/projects/status/6k35hmxl1juf1hqf?svg=true)](https://ci.appveyor.com/project/taishi-i/nagisa)
+[![Coverage Status](https://coveralls.io/repos/github/taishi-i/nagisa/badge.svg?branch=master)](https://coveralls.io/github/taishi-i/nagisa?branch=master)
+[![Documentation Status](https://readthedocs.org/projects/nagisa/badge/?version=latest)](https://nagisa.readthedocs.io/en/latest/?badge=latest)
+[![PyPI](https://img.shields.io/pypi/v/nagisa.svg)](https://pypi.python.org/pypi/nagisa)
+[![Downloads](https://pepy.tech/badge/nagisa)](https://pepy.tech/project/nagisa)
+Nagisa is a python module for Japanese word segmentation/POS-tagging.
+It is designed to be a simple and easy-to-use tool.
+This tool has the following features.
+- Based on recurrent neural networks.
+- The word segmentation model uses character- and word-level features [[池田+]](http://www.anlp.jp/proceedings/annual_meeting/2017/pdf_dir/B6-2.pdf).
+- The POS-tagging model uses tag dictionary information [[Inoue+]](http://www.aclweb.org/anthology/K17-1042).
+For more details refer to the following links.
+- The presentation slide at PyCon JP (2019) is available [here](https://speakerdeck.com/taishii/pycon-jp-2019).
+- The article in Japanese is available [here](https://qiita.com/taishi-i/items/5b9275a606b392f7f58e).
+- The documentation is available [here](https://nagisa.readthedocs.io/en/latest/?badge=latest).
+- The presentation slide at NLP Hacks (2022) is available [here](https://speakerdeck.com/taishii/nlphacks).
+
+%package -n python3-nagisa
+Summary: A Japanese tokenizer based on recurrent neural networks
+Provides: python-nagisa
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-nagisa
+[![Python package](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml/badge.svg)](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml)
+[![Build Status](https://app.travis-ci.com/taishi-i/nagisa.svg?branch=master)](https://app.travis-ci.com/taishi-i/nagisa)
+[![Build status](https://ci.appveyor.com/api/projects/status/6k35hmxl1juf1hqf?svg=true)](https://ci.appveyor.com/project/taishi-i/nagisa)
+[![Coverage Status](https://coveralls.io/repos/github/taishi-i/nagisa/badge.svg?branch=master)](https://coveralls.io/github/taishi-i/nagisa?branch=master)
+[![Documentation Status](https://readthedocs.org/projects/nagisa/badge/?version=latest)](https://nagisa.readthedocs.io/en/latest/?badge=latest)
+[![PyPI](https://img.shields.io/pypi/v/nagisa.svg)](https://pypi.python.org/pypi/nagisa)
+[![Downloads](https://pepy.tech/badge/nagisa)](https://pepy.tech/project/nagisa)
+Nagisa is a python module for Japanese word segmentation/POS-tagging.
+It is designed to be a simple and easy-to-use tool.
+This tool has the following features.
+- Based on recurrent neural networks.
+- The word segmentation model uses character- and word-level features [[池田+]](http://www.anlp.jp/proceedings/annual_meeting/2017/pdf_dir/B6-2.pdf).
+- The POS-tagging model uses tag dictionary information [[Inoue+]](http://www.aclweb.org/anthology/K17-1042).
+For more details refer to the following links.
+- The presentation slide at PyCon JP (2019) is available [here](https://speakerdeck.com/taishii/pycon-jp-2019).
+- The article in Japanese is available [here](https://qiita.com/taishi-i/items/5b9275a606b392f7f58e).
+- The documentation is available [here](https://nagisa.readthedocs.io/en/latest/?badge=latest).
+- The presentation slide at NLP Hacks (2022) is available [here](https://speakerdeck.com/taishii/nlphacks).
+
+%package help
+Summary: Development documents and examples for nagisa
+Provides: python3-nagisa-doc
+%description help
+[![Python package](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml/badge.svg)](https://github.com/taishi-i/nagisa/actions/workflows/python-package.yml)
+[![Build Status](https://app.travis-ci.com/taishi-i/nagisa.svg?branch=master)](https://app.travis-ci.com/taishi-i/nagisa)
+[![Build status](https://ci.appveyor.com/api/projects/status/6k35hmxl1juf1hqf?svg=true)](https://ci.appveyor.com/project/taishi-i/nagisa)
+[![Coverage Status](https://coveralls.io/repos/github/taishi-i/nagisa/badge.svg?branch=master)](https://coveralls.io/github/taishi-i/nagisa?branch=master)
+[![Documentation Status](https://readthedocs.org/projects/nagisa/badge/?version=latest)](https://nagisa.readthedocs.io/en/latest/?badge=latest)
+[![PyPI](https://img.shields.io/pypi/v/nagisa.svg)](https://pypi.python.org/pypi/nagisa)
+[![Downloads](https://pepy.tech/badge/nagisa)](https://pepy.tech/project/nagisa)
+Nagisa is a python module for Japanese word segmentation/POS-tagging.
+It is designed to be a simple and easy-to-use tool.
+This tool has the following features.
+- Based on recurrent neural networks.
+- The word segmentation model uses character- and word-level features [[池田+]](http://www.anlp.jp/proceedings/annual_meeting/2017/pdf_dir/B6-2.pdf).
+- The POS-tagging model uses tag dictionary information [[Inoue+]](http://www.aclweb.org/anthology/K17-1042).
+For more details refer to the following links.
+- The presentation slide at PyCon JP (2019) is available [here](https://speakerdeck.com/taishii/pycon-jp-2019).
+- The article in Japanese is available [here](https://qiita.com/taishi-i/items/5b9275a606b392f7f58e).
+- The documentation is available [here](https://nagisa.readthedocs.io/en/latest/?badge=latest).
+- The presentation slide at NLP Hacks (2022) is available [here](https://speakerdeck.com/taishii/nlphacks).
+
+%prep
+%autosetup -n nagisa-0.2.8
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nagisa -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.8-1
+- Package Spec generated