summaryrefslogtreecommitdiff
path: root/python-nakametpy.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 05:59:56 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 05:59:56 +0000
commit3f248c15ee58585e80d106f9b4ea4aabb300e6b3 (patch)
tree3ccac80fc7b46727129292e5a8012fa4a332c689 /python-nakametpy.spec
parent1153cf52a3553177eba2fd10e00b2566e3105f19 (diff)
automatic import of python-nakametpy
Diffstat (limited to 'python-nakametpy.spec')
-rw-r--r--python-nakametpy.spec300
1 files changed, 300 insertions, 0 deletions
diff --git a/python-nakametpy.spec b/python-nakametpy.spec
new file mode 100644
index 0000000..ea8f647
--- /dev/null
+++ b/python-nakametpy.spec
@@ -0,0 +1,300 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nakametpy
+Version: 2023.3.1
+Release: 1
+Summary: Meteorological modules for calculation and colormap.
+License: BSD 3-clause
+URL: https://github.com/muchojp/NakaMetPy
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b0/9e/89dec7b3f8bf3f605a2e84f6231b07a933de57ac564292d69ed305e03b9e/nakametpy-2023.3.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-matplotlib
+Requires: python3-nose
+
+%description
+# NakaMetPy
+
+[![PyPI version][pypi-image]][pypi-link]
+[![Anaconda version][anaconda-v-image]][anaconda-v-link]
+[![pytest](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg)](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml)
+<!-- [![Travis][travis-image]][travis-link] -->
+
+[pypi-image]: https://badge.fury.io/py/nakametpy.svg
+[pypi-link]: https://pypi.org/project/nakametpy
+[anaconda-v-image]: https://anaconda.org/muchiwo/nakametpy/badges/version.svg
+[anaconda-v-link]: https://anaconda.org/muchiwo/nakametpy
+<!-- [travis-image]: https://travis-ci.org/muchojp/NakaMetPy.svg?branch=main
+[travis-link]: https://travis-ci.org/github/muchojp/NakaMetPy -->
+[github-actions-image]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg
+[github-actions-link]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml
+
+## 概要
+このモジュールはMetPyの関数をNumPyで動作するように書き換えた関数のほか、
+観測データを扱う上で便利な関数が含まれています。
+気象データをNumPyでベクトル(配列)として扱うことを想定しています。
+
+そのため変数単位はMetPyとは異なり自分で気をつけて関数に与えなければなりません。
+また、関数の鉛直層数および時間のサイズは適当に与えています。利用される際にデータに合わせて引数を関数に渡してください。
+さらに、WRFの計算結果を入力する場合は`wrfon`のオプションを1にする必要があります。
+(`wrfon`オプションは使い勝手が悪いため、今後廃止される予定です。現在はそのための方策を考えているところです。)
+
+NakaMetPyは少なくとも2023年1月あたりまでは開発が継続される予定です。
+皆さんのContributionもお待ちしています。
+
+## Abstract
+`nakametpy` is a rewrited package of `MetPy` based on `NumPy`.
+I appreciate your contribution.
+
+## Documentation
+ドキュメンテーションは[こちら](https://muchojp.github.io/NakaMetPy/ "Docs")のページにあります。
+Documentation is [HERE](https://muchojp.github.io/NakaMetPy/).
+
+## How to Install
+### via Anaconda
+
+```
+conda install -c muchiwo nakametpy
+```
+
+### via PyPI
+
+```
+pip install nakametpy
+```
+
+## Licence
+`BSD-3-Clause`
+
+## Citation
+```
+Nakamura, Y. (2021). NakaMety (Version xxxx.x.x) [Software]. Fukuoka, Japan. https://github.com/muchojp/NakaMetPy
+```
+Note: The version number xxxx.x.x should be set to the version of NakaMetPy that you are using.
+
+## Update plans
+Next(`2022.4.0b0` or `2022.5.0` later):
+ - Refine reading GrADS binary function
+
+To Do:
+ - `wrfon`オプションの廃止
+ - MetPyの関数の移植 \[Further addition of MetPy function\]
+ - NCLに実装されている関数の移植 \[adding the NCL's function\]
+ - 方位角平均を取る関数の作成 \[Add function of Azimuthal Mean\]
+
+ - ~GPU(cupy)対応 \[GPU(cupy) compatible\]~
+ -> 軽い負荷の作業では GPU を利用するとかえって CPU only より遅くなることが多いため、ひとまず保留する。
+
+
+
+
+
+
+%package -n python3-nakametpy
+Summary: Meteorological modules for calculation and colormap.
+Provides: python-nakametpy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nakametpy
+# NakaMetPy
+
+[![PyPI version][pypi-image]][pypi-link]
+[![Anaconda version][anaconda-v-image]][anaconda-v-link]
+[![pytest](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg)](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml)
+<!-- [![Travis][travis-image]][travis-link] -->
+
+[pypi-image]: https://badge.fury.io/py/nakametpy.svg
+[pypi-link]: https://pypi.org/project/nakametpy
+[anaconda-v-image]: https://anaconda.org/muchiwo/nakametpy/badges/version.svg
+[anaconda-v-link]: https://anaconda.org/muchiwo/nakametpy
+<!-- [travis-image]: https://travis-ci.org/muchojp/NakaMetPy.svg?branch=main
+[travis-link]: https://travis-ci.org/github/muchojp/NakaMetPy -->
+[github-actions-image]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg
+[github-actions-link]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml
+
+## 概要
+このモジュールはMetPyの関数をNumPyで動作するように書き換えた関数のほか、
+観測データを扱う上で便利な関数が含まれています。
+気象データをNumPyでベクトル(配列)として扱うことを想定しています。
+
+そのため変数単位はMetPyとは異なり自分で気をつけて関数に与えなければなりません。
+また、関数の鉛直層数および時間のサイズは適当に与えています。利用される際にデータに合わせて引数を関数に渡してください。
+さらに、WRFの計算結果を入力する場合は`wrfon`のオプションを1にする必要があります。
+(`wrfon`オプションは使い勝手が悪いため、今後廃止される予定です。現在はそのための方策を考えているところです。)
+
+NakaMetPyは少なくとも2023年1月あたりまでは開発が継続される予定です。
+皆さんのContributionもお待ちしています。
+
+## Abstract
+`nakametpy` is a rewrited package of `MetPy` based on `NumPy`.
+I appreciate your contribution.
+
+## Documentation
+ドキュメンテーションは[こちら](https://muchojp.github.io/NakaMetPy/ "Docs")のページにあります。
+Documentation is [HERE](https://muchojp.github.io/NakaMetPy/).
+
+## How to Install
+### via Anaconda
+
+```
+conda install -c muchiwo nakametpy
+```
+
+### via PyPI
+
+```
+pip install nakametpy
+```
+
+## Licence
+`BSD-3-Clause`
+
+## Citation
+```
+Nakamura, Y. (2021). NakaMety (Version xxxx.x.x) [Software]. Fukuoka, Japan. https://github.com/muchojp/NakaMetPy
+```
+Note: The version number xxxx.x.x should be set to the version of NakaMetPy that you are using.
+
+## Update plans
+Next(`2022.4.0b0` or `2022.5.0` later):
+ - Refine reading GrADS binary function
+
+To Do:
+ - `wrfon`オプションの廃止
+ - MetPyの関数の移植 \[Further addition of MetPy function\]
+ - NCLに実装されている関数の移植 \[adding the NCL's function\]
+ - 方位角平均を取る関数の作成 \[Add function of Azimuthal Mean\]
+
+ - ~GPU(cupy)対応 \[GPU(cupy) compatible\]~
+ -> 軽い負荷の作業では GPU を利用するとかえって CPU only より遅くなることが多いため、ひとまず保留する。
+
+
+
+
+
+
+%package help
+Summary: Development documents and examples for nakametpy
+Provides: python3-nakametpy-doc
+%description help
+# NakaMetPy
+
+[![PyPI version][pypi-image]][pypi-link]
+[![Anaconda version][anaconda-v-image]][anaconda-v-link]
+[![pytest](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg)](https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml)
+<!-- [![Travis][travis-image]][travis-link] -->
+
+[pypi-image]: https://badge.fury.io/py/nakametpy.svg
+[pypi-link]: https://pypi.org/project/nakametpy
+[anaconda-v-image]: https://anaconda.org/muchiwo/nakametpy/badges/version.svg
+[anaconda-v-link]: https://anaconda.org/muchiwo/nakametpy
+<!-- [travis-image]: https://travis-ci.org/muchojp/NakaMetPy.svg?branch=main
+[travis-link]: https://travis-ci.org/github/muchojp/NakaMetPy -->
+[github-actions-image]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml/badge.svg
+[github-actions-link]: https://github.com/muchojp/NakaMetPy/actions/workflows/ci.yml
+
+## 概要
+このモジュールはMetPyの関数をNumPyで動作するように書き換えた関数のほか、
+観測データを扱う上で便利な関数が含まれています。
+気象データをNumPyでベクトル(配列)として扱うことを想定しています。
+
+そのため変数単位はMetPyとは異なり自分で気をつけて関数に与えなければなりません。
+また、関数の鉛直層数および時間のサイズは適当に与えています。利用される際にデータに合わせて引数を関数に渡してください。
+さらに、WRFの計算結果を入力する場合は`wrfon`のオプションを1にする必要があります。
+(`wrfon`オプションは使い勝手が悪いため、今後廃止される予定です。現在はそのための方策を考えているところです。)
+
+NakaMetPyは少なくとも2023年1月あたりまでは開発が継続される予定です。
+皆さんのContributionもお待ちしています。
+
+## Abstract
+`nakametpy` is a rewrited package of `MetPy` based on `NumPy`.
+I appreciate your contribution.
+
+## Documentation
+ドキュメンテーションは[こちら](https://muchojp.github.io/NakaMetPy/ "Docs")のページにあります。
+Documentation is [HERE](https://muchojp.github.io/NakaMetPy/).
+
+## How to Install
+### via Anaconda
+
+```
+conda install -c muchiwo nakametpy
+```
+
+### via PyPI
+
+```
+pip install nakametpy
+```
+
+## Licence
+`BSD-3-Clause`
+
+## Citation
+```
+Nakamura, Y. (2021). NakaMety (Version xxxx.x.x) [Software]. Fukuoka, Japan. https://github.com/muchojp/NakaMetPy
+```
+Note: The version number xxxx.x.x should be set to the version of NakaMetPy that you are using.
+
+## Update plans
+Next(`2022.4.0b0` or `2022.5.0` later):
+ - Refine reading GrADS binary function
+
+To Do:
+ - `wrfon`オプションの廃止
+ - MetPyの関数の移植 \[Further addition of MetPy function\]
+ - NCLに実装されている関数の移植 \[adding the NCL's function\]
+ - 方位角平均を取る関数の作成 \[Add function of Azimuthal Mean\]
+
+ - ~GPU(cupy)対応 \[GPU(cupy) compatible\]~
+ -> 軽い負荷の作業では GPU を利用するとかえって CPU only より遅くなることが多いため、ひとまず保留する。
+
+
+
+
+
+
+%prep
+%autosetup -n nakametpy-2023.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nakametpy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 2023.3.1-1
+- Package Spec generated