summaryrefslogtreecommitdiff
path: root/python-ndicapi.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ndicapi.spec')
-rw-r--r--python-ndicapi.spec143
1 files changed, 143 insertions, 0 deletions
diff --git a/python-ndicapi.spec b/python-ndicapi.spec
new file mode 100644
index 0000000..b526187
--- /dev/null
+++ b/python-ndicapi.spec
@@ -0,0 +1,143 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ndicapi
+Version: 3.2.10
+Release: 1
+Summary: This package allows interfacing with NDI tracking devices
+License: MIT
+URL: https://github.com/SciKit-Surgery/ndicapi
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/b8/b2/d2222f5a264f14942a695d2368491a26a56c3c36bcd2c3311d6d09c8567c/ndicapi-3.2.10.tar.gz
+
+
+%description
+# History
+* Program: NDI Combined API C Interface Library
+* Creator: David Gobbi
+* Language: English
+* Authors:
+ * David Gobbi
+ * Andras Lasso <lassoan@queensu.ca>
+ * Adam Rankin <arankin@robarts.ca>
+ * Stephen Thompson <s.thompson@ucl.ac.uk>
+
+# Overview
+These are binary python wheels of the PlusToolKits's ndicapi library (https://github.com/PlusToolkit/ndicapi).
+The CI scripts where developed on and hosted by (https://github.com/scikit-surgery/ndicapi).
+
+This package provides provides a straightforward Python interface to AURORA, POLARIS, and VEGA systems manufactured by Northern Digital Inc. This library is provided by the Plus library, and is not supported by Northern Digital Inc.
+
+## Acknowledgments
+
+The implementation of continuous integration and deployment was Supported by the [Wellcome Trust](https://wellcome.ac.uk/) and the [EPSRC](https://www.epsrc.ac.uk/) as part of the [Wellcome Centre for Interventional and Surgical Sciences](http://www.ucl.ac.uk/weiss).
+
+
+
+
+
+
+%package -n python3-ndicapi
+Summary: This package allows interfacing with NDI tracking devices
+Provides: python-ndicapi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-ndicapi
+# History
+* Program: NDI Combined API C Interface Library
+* Creator: David Gobbi
+* Language: English
+* Authors:
+ * David Gobbi
+ * Andras Lasso <lassoan@queensu.ca>
+ * Adam Rankin <arankin@robarts.ca>
+ * Stephen Thompson <s.thompson@ucl.ac.uk>
+
+# Overview
+These are binary python wheels of the PlusToolKits's ndicapi library (https://github.com/PlusToolkit/ndicapi).
+The CI scripts where developed on and hosted by (https://github.com/scikit-surgery/ndicapi).
+
+This package provides provides a straightforward Python interface to AURORA, POLARIS, and VEGA systems manufactured by Northern Digital Inc. This library is provided by the Plus library, and is not supported by Northern Digital Inc.
+
+## Acknowledgments
+
+The implementation of continuous integration and deployment was Supported by the [Wellcome Trust](https://wellcome.ac.uk/) and the [EPSRC](https://www.epsrc.ac.uk/) as part of the [Wellcome Centre for Interventional and Surgical Sciences](http://www.ucl.ac.uk/weiss).
+
+
+
+
+
+
+%package help
+Summary: Development documents and examples for ndicapi
+Provides: python3-ndicapi-doc
+%description help
+# History
+* Program: NDI Combined API C Interface Library
+* Creator: David Gobbi
+* Language: English
+* Authors:
+ * David Gobbi
+ * Andras Lasso <lassoan@queensu.ca>
+ * Adam Rankin <arankin@robarts.ca>
+ * Stephen Thompson <s.thompson@ucl.ac.uk>
+
+# Overview
+These are binary python wheels of the PlusToolKits's ndicapi library (https://github.com/PlusToolkit/ndicapi).
+The CI scripts where developed on and hosted by (https://github.com/scikit-surgery/ndicapi).
+
+This package provides provides a straightforward Python interface to AURORA, POLARIS, and VEGA systems manufactured by Northern Digital Inc. This library is provided by the Plus library, and is not supported by Northern Digital Inc.
+
+## Acknowledgments
+
+The implementation of continuous integration and deployment was Supported by the [Wellcome Trust](https://wellcome.ac.uk/) and the [EPSRC](https://www.epsrc.ac.uk/) as part of the [Wellcome Centre for Interventional and Surgical Sciences](http://www.ucl.ac.uk/weiss).
+
+
+
+
+
+
+%prep
+%autosetup -n ndicapi-3.2.10
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ndicapi -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.10-1
+- Package Spec generated