summaryrefslogtreecommitdiff
path: root/python-neo4jrestclient.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-neo4jrestclient.spec')
-rw-r--r--python-neo4jrestclient.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-neo4jrestclient.spec b/python-neo4jrestclient.spec
new file mode 100644
index 0000000..fcdfac3
--- /dev/null
+++ b/python-neo4jrestclient.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-neo4jrestclient
+Version: 2.1.1
+Release: 1
+Summary: Object-oriented Python library to interact with Neo4j standalone REST server
+License: GPL 3
+URL: https://github.com/versae/neo4j-rest-client
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/95/4c/df54ba57f5838fd1ae162462f81d589b8352c6aa17d5b2a7a42e8abba048/neo4jrestclient-2.1.1.tar.gz
+BuildArch: noarch
+
+
+%description
+The first objective of Neo4j Python REST Client is to make transparent for
+Python programmers the use of a local database through python-embedded_ or a
+remote database thanks to Neo4j REST Server. So, the syntax of this API is
+fully compatible with python-embedded. However, a new syntax is introduced in
+order to reach a more pythonic style.
+
+%package -n python3-neo4jrestclient
+Summary: Object-oriented Python library to interact with Neo4j standalone REST server
+Provides: python-neo4jrestclient
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-neo4jrestclient
+The first objective of Neo4j Python REST Client is to make transparent for
+Python programmers the use of a local database through python-embedded_ or a
+remote database thanks to Neo4j REST Server. So, the syntax of this API is
+fully compatible with python-embedded. However, a new syntax is introduced in
+order to reach a more pythonic style.
+
+%package help
+Summary: Development documents and examples for neo4jrestclient
+Provides: python3-neo4jrestclient-doc
+%description help
+The first objective of Neo4j Python REST Client is to make transparent for
+Python programmers the use of a local database through python-embedded_ or a
+remote database thanks to Neo4j REST Server. So, the syntax of this API is
+fully compatible with python-embedded. However, a new syntax is introduced in
+order to reach a more pythonic style.
+
+%prep
+%autosetup -n neo4jrestclient-2.1.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-neo4jrestclient -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 2.1.1-1
+- Package Spec generated