summaryrefslogtreecommitdiff
path: root/python-newrelic-api.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-newrelic-api.spec')
-rw-r--r--python-newrelic-api.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-newrelic-api.spec b/python-newrelic-api.spec
new file mode 100644
index 0000000..e3d3f82
--- /dev/null
+++ b/python-newrelic-api.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-newrelic-api
+Version: 1.0.6
+Release: 1
+Summary: A python interface to the New Relic API v2
+License: MIT
+URL: https://github.com/ambitioninc/newrelic-api
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2c/13/c090f1c0b5845190b4079745ca04b08417fc295fb10b4423c5aa44f5dcae/newrelic-api-1.0.6.tar.gz
+BuildArch: noarch
+
+
+%description
+newrelic-api is a package for easily interacting with New Relic's API in a
+concise, pythonic way. For full documentation on each endpoint, please see
+`New Relic's API explorer`_. This is based off of the v2 API.
+
+%package -n python3-newrelic-api
+Summary: A python interface to the New Relic API v2
+Provides: python-newrelic-api
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-newrelic-api
+newrelic-api is a package for easily interacting with New Relic's API in a
+concise, pythonic way. For full documentation on each endpoint, please see
+`New Relic's API explorer`_. This is based off of the v2 API.
+
+%package help
+Summary: Development documents and examples for newrelic-api
+Provides: python3-newrelic-api-doc
+%description help
+newrelic-api is a package for easily interacting with New Relic's API in a
+concise, pythonic way. For full documentation on each endpoint, please see
+`New Relic's API explorer`_. This is based off of the v2 API.
+
+%prep
+%autosetup -n newrelic-api-1.0.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-newrelic-api -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.6-1
+- Package Spec generated