summaryrefslogtreecommitdiff
path: root/python-nimare.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-nimare.spec')
-rw-r--r--python-nimare.spec141
1 files changed, 141 insertions, 0 deletions
diff --git a/python-nimare.spec b/python-nimare.spec
new file mode 100644
index 0000000..0cd2d53
--- /dev/null
+++ b/python-nimare.spec
@@ -0,0 +1,141 @@
+%global _empty_manifest_terminate_build 0
+Name: python-NiMARE
+Version: 0.0.14
+Release: 1
+Summary: NiMARE: Neuroimaging Meta-Analysis Research Environment
+License: MIT
+URL: https://github.com/neurostuff/NiMARE
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/02/67/0fe846b15c4071d0e1710c4985ef34f4e646efb4ec4a783b118c3b7bfcc7/NiMARE-0.0.14.tar.gz
+BuildArch: noarch
+
+Requires: python3-cognitiveatlas
+Requires: python3-fuzzywuzzy
+Requires: python3-indexed-gzip
+Requires: python3-joblib
+Requires: python3-matplotlib
+Requires: python3-nibabel
+Requires: python3-nilearn
+Requires: python3-numba
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-pymare
+Requires: python3-requests
+Requires: python3-scikit-learn
+Requires: python3-scipy
+Requires: python3-sparse
+Requires: python3-statsmodels
+Requires: python3-tqdm
+Requires: python3-m2r
+Requires: python3-matplotlib
+Requires: python3-mistune
+Requires: python3-pillow
+Requires: python3-recommonmark
+Requires: python3-seaborn
+Requires: python3-sphinx
+Requires: python3-sphinx-argparse
+Requires: python3-sphinx-copybutton
+Requires: python3-sphinx-gallery
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinxcontrib-bibtex
+Requires: python3-codecov
+Requires: python3-coverage
+Requires: python3-coveralls
+Requires: python3-flake8-black
+Requires: python3-flake8-docstrings
+Requires: python3-flake8-isort
+Requires: python3-pytest
+Requires: python3-pytest-cov
+Requires: python3-m2r
+Requires: python3-matplotlib
+Requires: python3-mistune
+Requires: python3-pillow
+Requires: python3-recommonmark
+Requires: python3-seaborn
+Requires: python3-sphinx
+Requires: python3-sphinx-argparse
+Requires: python3-sphinx-copybutton
+Requires: python3-sphinx-gallery
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinxcontrib-bibtex
+Requires: python3-indexed-gzip
+Requires: python3-matplotlib
+Requires: python3-nibabel
+Requires: python3-nilearn
+Requires: python3-numpy
+Requires: python3-pandas
+Requires: python3-pymare
+Requires: python3-scikit-learn
+Requires: python3-scipy
+Requires: python3-codecov
+Requires: python3-coverage
+Requires: python3-coveralls
+Requires: python3-flake8-black
+Requires: python3-flake8-docstrings
+Requires: python3-flake8-isort
+Requires: python3-pytest
+Requires: python3-pytest-cov
+
+%description
+NiMARE (Neuroimaging Meta-Analysis Research Environment) is a Python package
+for coordinate-based and image-based meta-analysis of neuroimaging data.
+
+%package -n python3-NiMARE
+Summary: NiMARE: Neuroimaging Meta-Analysis Research Environment
+Provides: python-NiMARE
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-NiMARE
+NiMARE (Neuroimaging Meta-Analysis Research Environment) is a Python package
+for coordinate-based and image-based meta-analysis of neuroimaging data.
+
+%package help
+Summary: Development documents and examples for NiMARE
+Provides: python3-NiMARE-doc
+%description help
+NiMARE (Neuroimaging Meta-Analysis Research Environment) is a Python package
+for coordinate-based and image-based meta-analysis of neuroimaging data.
+
+%prep
+%autosetup -n NiMARE-0.0.14
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-NiMARE -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.0.14-1
+- Package Spec generated