summaryrefslogtreecommitdiff
path: root/python-nrfutil.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-nrfutil.spec')
-rw-r--r--python-nrfutil.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-nrfutil.spec b/python-nrfutil.spec
new file mode 100644
index 0000000..2c83ba3
--- /dev/null
+++ b/python-nrfutil.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-nrfutil
+Version: 6.1.7
+Release: 1
+Summary: Nordic Semiconductor nrfutil utility and Python library
+License: Other/Proprietary License
+URL: https://github.com/NordicSemiconductor/pc-nrfutil
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/8b/76/bd2f7a5d27c232c61f6449b72db7826fa6aa486b1201def2dc2bc67282dc/nrfutil-6.1.7.tar.gz
+BuildArch: noarch
+
+
+%description
+A Python package that includes the nrfutil utility and the nordicsemi library
+
+
+
+%package -n python3-nrfutil
+Summary: Nordic Semiconductor nrfutil utility and Python library
+Provides: python-nrfutil
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-nrfutil
+A Python package that includes the nrfutil utility and the nordicsemi library
+
+
+
+%package help
+Summary: Development documents and examples for nrfutil
+Provides: python3-nrfutil-doc
+%description help
+A Python package that includes the nrfutil utility and the nordicsemi library
+
+
+
+%prep
+%autosetup -n nrfutil-6.1.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-nrfutil -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 6.1.7-1
+- Package Spec generated