summaryrefslogtreecommitdiff
path: root/python-numpy-api-bench.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 11:02:10 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 11:02:10 +0000
commitd0009709ddf02f36b0ef040f4c79442552c25520 (patch)
tree245fb01282a31bd9a2b5f122579fbbc745ea9eba /python-numpy-api-bench.spec
parent948c50a67ac1ff9052aa96c9cb334c7bdfaaed4a (diff)
automatic import of python-numpy-api-bench
Diffstat (limited to 'python-numpy-api-bench.spec')
-rw-r--r--python-numpy-api-bench.spec106
1 files changed, 106 insertions, 0 deletions
diff --git a/python-numpy-api-bench.spec b/python-numpy-api-bench.spec
new file mode 100644
index 0000000..cbb437c
--- /dev/null
+++ b/python-numpy-api-bench.spec
@@ -0,0 +1,106 @@
+%global _empty_manifest_terminate_build 0
+Name: python-numpy-api-bench
+Version: 0.1.0
+Release: 1
+Summary: A small Python package showcasing speed differences between NumPy's Python and C APIs.
+License: MIT
+URL: https://github.com/phetdam/numpy-api-bench
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/df/65/184391a08412f42c9132d886dd812150dba96e99db149534ef4a3e51ec60/numpy-api-bench-0.1.0.tar.gz
+
+Requires: python3-numpy
+Requires: python3-pytest
+
+%description
+ numpy-api-bench/build?logo=github
+*We should forget about small efficiencies, say about 97% of the time:
+premature optimization is the root of all evil* [#]_.
+**numpy-api-bench** is a small Python package comparing speed differences
+between NumPy's Python and C APIs that also serves as an example project for
+writing C extension modules that make use of the `NumPy C API`__ [#]_.
+ mine called ``c-npy-demo`` with more concise and efficient code as well as a
+ new name. ``c-npy-demo`` was written at a time when I was still struggling
+ with the Python and NumPy C APIs and had no idea how to test them, but now
+ that I am much more practiced with both APIs, I felt it right to use my new
+ knowledge to rework my old code.
+
+%package -n python3-numpy-api-bench
+Summary: A small Python package showcasing speed differences between NumPy's Python and C APIs.
+Provides: python-numpy-api-bench
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-numpy-api-bench
+ numpy-api-bench/build?logo=github
+*We should forget about small efficiencies, say about 97% of the time:
+premature optimization is the root of all evil* [#]_.
+**numpy-api-bench** is a small Python package comparing speed differences
+between NumPy's Python and C APIs that also serves as an example project for
+writing C extension modules that make use of the `NumPy C API`__ [#]_.
+ mine called ``c-npy-demo`` with more concise and efficient code as well as a
+ new name. ``c-npy-demo`` was written at a time when I was still struggling
+ with the Python and NumPy C APIs and had no idea how to test them, but now
+ that I am much more practiced with both APIs, I felt it right to use my new
+ knowledge to rework my old code.
+
+%package help
+Summary: Development documents and examples for numpy-api-bench
+Provides: python3-numpy-api-bench-doc
+%description help
+ numpy-api-bench/build?logo=github
+*We should forget about small efficiencies, say about 97% of the time:
+premature optimization is the root of all evil* [#]_.
+**numpy-api-bench** is a small Python package comparing speed differences
+between NumPy's Python and C APIs that also serves as an example project for
+writing C extension modules that make use of the `NumPy C API`__ [#]_.
+ mine called ``c-npy-demo`` with more concise and efficient code as well as a
+ new name. ``c-npy-demo`` was written at a time when I was still struggling
+ with the Python and NumPy C APIs and had no idea how to test them, but now
+ that I am much more practiced with both APIs, I felt it right to use my new
+ knowledge to rework my old code.
+
+%prep
+%autosetup -n numpy-api-bench-0.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-numpy-api-bench -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.0-1
+- Package Spec generated