summaryrefslogtreecommitdiff
path: root/python-numpy-stl.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 14:26:19 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 14:26:19 +0000
commitaff6965f7b63b9614d7fca87f2e0f80383c8ea9b (patch)
treee4020f85d16fa82cb77249114d83f261752b1b5f /python-numpy-stl.spec
parent275eda6d196485c2f7a6c91036ae5c992b4cb767 (diff)
automatic import of python-numpy-stl
Diffstat (limited to 'python-numpy-stl.spec')
-rw-r--r--python-numpy-stl.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-numpy-stl.spec b/python-numpy-stl.spec
new file mode 100644
index 0000000..5b3997f
--- /dev/null
+++ b/python-numpy-stl.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-numpy-stl
+Version: 3.0.0
+Release: 1
+Summary: Library to make reading, writing and modifying both binary and ascii STL files easy.
+License: BSD
+URL: https://github.com/WoLpH/numpy-stl/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/29/79/3b75898b8c3b926f5c1c26722b3211cbad0be2e309952c8a6ce3410fdac0/numpy-stl-3.0.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-utils
+
+%description
+Simple library to make working with STL files (and 3D objects in general) fast
+and easy.
+Due to all operations heavily relying on `numpy` this is one of the fastest
+STL editing libraries for Python available.
+
+%package -n python3-numpy-stl
+Summary: Library to make reading, writing and modifying both binary and ascii STL files easy.
+Provides: python-numpy-stl
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-numpy-stl
+Simple library to make working with STL files (and 3D objects in general) fast
+and easy.
+Due to all operations heavily relying on `numpy` this is one of the fastest
+STL editing libraries for Python available.
+
+%package help
+Summary: Development documents and examples for numpy-stl
+Provides: python3-numpy-stl-doc
+%description help
+Simple library to make working with STL files (and 3D objects in general) fast
+and easy.
+Due to all operations heavily relying on `numpy` this is one of the fastest
+STL editing libraries for Python available.
+
+%prep
+%autosetup -n numpy-stl-3.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-numpy-stl -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 3.0.0-1
+- Package Spec generated