summaryrefslogtreecommitdiff
path: root/python-olefile.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 11:19:06 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 11:19:06 +0000
commit1ac315d8b41198f9dd78faf9860d016fa841ef3f (patch)
treecb2d9d84ce1d4df3640108f80e9029782a4595c9 /python-olefile.spec
parentf4c228e6028b0c6afbbf18f08755cc25d3a74425 (diff)
automatic import of python-olefile
Diffstat (limited to 'python-olefile.spec')
-rw-r--r--python-olefile.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-olefile.spec b/python-olefile.spec
new file mode 100644
index 0000000..743acc7
--- /dev/null
+++ b/python-olefile.spec
@@ -0,0 +1,120 @@
+%global _empty_manifest_terminate_build 0
+Name: python-olefile
+Version: 0.46
+Release: 1
+Summary: Python package to parse, read and write Microsoft OLE2 files (Structured Storage or Compound Document, Microsoft Office)
+License: BSD
+URL: https://www.decalage.info/python/olefileio
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/34/81/e1ac43c6b45b4c5f8d9352396a14144bba52c8fec72a80f425f6a4d653ad/olefile-0.46.zip
+BuildArch: noarch
+
+
+%description
+|Build Status TravisCI| |Build Status AppVeyor| |Coverage Status|
+|Documentation Status| |PyPI| |Can I Use Python 3?| |Say Thanks!|
+`olefile <https://www.decalage.info/olefile>`__ is a Python package to
+parse, read and write `Microsoft OLE2
+files <http://en.wikipedia.org/wiki/Compound_File_Binary_Format>`__
+(also called Structured Storage, Compound File Binary Format or Compound
+Document File Format), such as Microsoft Office 97-2003 documents,
+vbaProject.bin in MS Office 2007+ files, Image Composer and FlashPix
+files, Outlook messages, StickyNotes, several Microscopy file formats,
+McAfee antivirus quarantine files, etc.
+**Quick links:** `Home page <https://www.decalage.info/olefile>`__ -
+`Download/Install <http://olefile.readthedocs.io/en/latest/Install.html>`__
+- `Documentation <http://olefile.readthedocs.io/en/latest>`__ - `Report
+Issues/Suggestions/Questions <https://github.com/decalage2/olefile/issues>`__
+- `Contact the author <https://www.decalage.info/contact>`__ -
+`Repository <https://github.com/decalage2/olefile>`__ - `Updates on
+Twitter <https://twitter.com/decalage2>`__
+
+%package -n python3-olefile
+Summary: Python package to parse, read and write Microsoft OLE2 files (Structured Storage or Compound Document, Microsoft Office)
+Provides: python-olefile
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-olefile
+|Build Status TravisCI| |Build Status AppVeyor| |Coverage Status|
+|Documentation Status| |PyPI| |Can I Use Python 3?| |Say Thanks!|
+`olefile <https://www.decalage.info/olefile>`__ is a Python package to
+parse, read and write `Microsoft OLE2
+files <http://en.wikipedia.org/wiki/Compound_File_Binary_Format>`__
+(also called Structured Storage, Compound File Binary Format or Compound
+Document File Format), such as Microsoft Office 97-2003 documents,
+vbaProject.bin in MS Office 2007+ files, Image Composer and FlashPix
+files, Outlook messages, StickyNotes, several Microscopy file formats,
+McAfee antivirus quarantine files, etc.
+**Quick links:** `Home page <https://www.decalage.info/olefile>`__ -
+`Download/Install <http://olefile.readthedocs.io/en/latest/Install.html>`__
+- `Documentation <http://olefile.readthedocs.io/en/latest>`__ - `Report
+Issues/Suggestions/Questions <https://github.com/decalage2/olefile/issues>`__
+- `Contact the author <https://www.decalage.info/contact>`__ -
+`Repository <https://github.com/decalage2/olefile>`__ - `Updates on
+Twitter <https://twitter.com/decalage2>`__
+
+%package help
+Summary: Development documents and examples for olefile
+Provides: python3-olefile-doc
+%description help
+|Build Status TravisCI| |Build Status AppVeyor| |Coverage Status|
+|Documentation Status| |PyPI| |Can I Use Python 3?| |Say Thanks!|
+`olefile <https://www.decalage.info/olefile>`__ is a Python package to
+parse, read and write `Microsoft OLE2
+files <http://en.wikipedia.org/wiki/Compound_File_Binary_Format>`__
+(also called Structured Storage, Compound File Binary Format or Compound
+Document File Format), such as Microsoft Office 97-2003 documents,
+vbaProject.bin in MS Office 2007+ files, Image Composer and FlashPix
+files, Outlook messages, StickyNotes, several Microscopy file formats,
+McAfee antivirus quarantine files, etc.
+**Quick links:** `Home page <https://www.decalage.info/olefile>`__ -
+`Download/Install <http://olefile.readthedocs.io/en/latest/Install.html>`__
+- `Documentation <http://olefile.readthedocs.io/en/latest>`__ - `Report
+Issues/Suggestions/Questions <https://github.com/decalage2/olefile/issues>`__
+- `Contact the author <https://www.decalage.info/contact>`__ -
+`Repository <https://github.com/decalage2/olefile>`__ - `Updates on
+Twitter <https://twitter.com/decalage2>`__
+
+%prep
+%autosetup -n olefile-0.46
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-olefile -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.46-1
+- Package Spec generated