summaryrefslogtreecommitdiff
path: root/python-omicidx.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-06-20 09:49:27 +0000
committerCoprDistGit <infra@openeuler.org>2023-06-20 09:49:27 +0000
commitf38d484e1e17c9aff21706caf989a9d08bb1ed85 (patch)
tree2b6267d3e7af312bc5d1a1e852c367ceb22c9437 /python-omicidx.spec
parentfc043c177a1d7305e53875de57eeba58bbf5575a (diff)
automatic import of python-omicidxopeneuler20.03
Diffstat (limited to 'python-omicidx.spec')
-rw-r--r--python-omicidx.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-omicidx.spec b/python-omicidx.spec
new file mode 100644
index 0000000..4df0341
--- /dev/null
+++ b/python-omicidx.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-omicidx
+Version: 1.6.5
+Release: 1
+Summary: The OmicIDX project collects, reprocesses, and then republishes metadata from multiple public genomics repositories. Included are the NCBI SRA, Biosample, and GEO databases. Publication is via the cloud data warehouse platform Bigquery, a set of performant search and retrieval APIs, and a set of json-format files for easy incorporation into other projects.
+License: MIT
+URL: https://github.com/omicidx/omicidx-parsers
+Source0: https://mirrors.aliyun.com/pypi/web/packages/04/33/72d236d6613be8c2570e2d0406ade4dfba520b448b85b13b7afe4c8d7a5a/omicidx-1.6.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-pydantic
+Requires: python3-requests
+Requires: python3-Click
+Requires: python3-sd_cloud_utils
+Requires: python3-aiohttp
+Requires: python3-tenacity
+Requires: python3-pendulum
+Requires: python3-httpx
+Requires: python3-trio
+
+%description
+
+
+%package -n python3-omicidx
+Summary: The OmicIDX project collects, reprocesses, and then republishes metadata from multiple public genomics repositories. Included are the NCBI SRA, Biosample, and GEO databases. Publication is via the cloud data warehouse platform Bigquery, a set of performant search and retrieval APIs, and a set of json-format files for easy incorporation into other projects.
+Provides: python-omicidx
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-omicidx
+
+
+%package help
+Summary: Development documents and examples for omicidx
+Provides: python3-omicidx-doc
+%description help
+
+
+%prep
+%autosetup -n omicidx-1.6.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-omicidx -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.5-1
+- Package Spec generated