summaryrefslogtreecommitdiff
path: root/python-opening-hours-py.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-opening-hours-py.spec')
-rw-r--r--python-opening-hours-py.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-opening-hours-py.spec b/python-opening-hours-py.spec
new file mode 100644
index 0000000..e86462c
--- /dev/null
+++ b/python-opening-hours-py.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opening-hours-py
+Version: 0.6.4
+Release: 1
+Summary: A parser and toolkit for the opening_hours in OpenStreetMap written in Rust.
+License: MIT OR Apache-2.0
+URL: https://github.com/remi-dupre/opening-hours-rs/tree/master/python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a5/0f/c5a75b0298aca6247a583bf03acc104e39a16f2e7265efdf86b436ab37db/opening_hours_py-0.6.4.tar.gz
+BuildArch: noarch
+
+
+%description
+[![PyPI](https://img.shields.io/pypi/v/opening-hours-py)](https://pypi.org/project/opening-hours-py/)
+[![Doc](https://img.shields.io/badge/doc-pdoc-blue)](https://remi-dupre.github.io/opening-hours-rs/opening_hours.html)
+
+%package -n python3-opening-hours-py
+Summary: A parser and toolkit for the opening_hours in OpenStreetMap written in Rust.
+Provides: python-opening-hours-py
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opening-hours-py
+[![PyPI](https://img.shields.io/pypi/v/opening-hours-py)](https://pypi.org/project/opening-hours-py/)
+[![Doc](https://img.shields.io/badge/doc-pdoc-blue)](https://remi-dupre.github.io/opening-hours-rs/opening_hours.html)
+
+%package help
+Summary: Development documents and examples for opening-hours-py
+Provides: python3-opening-hours-py-doc
+%description help
+[![PyPI](https://img.shields.io/pypi/v/opening-hours-py)](https://pypi.org/project/opening-hours-py/)
+[![Doc](https://img.shields.io/badge/doc-pdoc-blue)](https://remi-dupre.github.io/opening-hours-rs/opening_hours.html)
+
+%prep
+%autosetup -n opening-hours-py-0.6.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opening-hours-py -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.4-1
+- Package Spec generated