summaryrefslogtreecommitdiff
path: root/python-openquake-engine.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-openquake-engine.spec')
-rw-r--r--python-openquake-engine.spec631
1 files changed, 631 insertions, 0 deletions
diff --git a/python-openquake-engine.spec b/python-openquake-engine.spec
new file mode 100644
index 0000000..95af29a
--- /dev/null
+++ b/python-openquake-engine.spec
@@ -0,0 +1,631 @@
+%global _empty_manifest_terminate_build 0
+Name: python-openquake.engine
+Version: 3.16.3
+Release: 1
+Summary: Computes earthquake hazard and risk.
+License: AGPL3
+URL: https://github.com/gem/oq-engine
+Source0: https://mirrors.aliyun.com/pypi/web/packages/0a/e5/13dd906bff8c5496a226083e66feb24143ebe9dce0693dd005a8c7bcd48a/openquake.engine-3.16.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-setuptools
+Requires: python3-h5py
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-pandas
+Requires: python3-pyzmq
+Requires: python3-psutil
+Requires: python3-shapely
+Requires: python3-docutils
+Requires: python3-decorator
+Requires: python3-django
+Requires: python3-matplotlib
+Requires: python3-requests
+Requires: python3-toml
+Requires: python3-pyproj
+Requires: python3-pam
+Requires: python3-django-pam
+Requires: python3-gunicorn
+Requires: python3-setproctitle
+Requires: python3-pytest
+Requires: python3-flake8
+Requires: python3-pdbpp
+Requires: python3-ipython
+Requires: python3-silx
+Requires: python3-sphinx
+Requires: python3-sphinx-theme
+Requires: python3-pydata-sphinx-theme
+Requires: python3-GDAL
+
+%description
+# OpenQuake Engine
+
+![OpenQuake Logo](https://raw.githubusercontent.com/gem/oq-infrastructure/master/logos/oq-logo.png)
+
+The **OpenQuake Engine** is an open source application that allows users to compute **seismic hazard** and **seismic risk** of earthquakes on a global scale. DOI: [10.13117/openquake.engine](https://doi.org/10.13117/openquake.engine)
+
+<!-- GEM BEGIN: apply the following patch with the proper values for the next release
+-[![Build Status](https://travis-ci.org/gem/oq-engine.svg?branch=master)](https://travis-ci.org/gem/oq-engine)
+
+-### Current stable
++## OpenQuake Engine version 2.6 (Gutenberg)
+
+-Current stable version is the **OpenQuake Engine 2.5** 'Fourier'. The documentation is available at https://github.com/gem/oq-engine/tree/engine-2.5#openquake-engine.
+-* [What's new](https://github.com/gem/oq-engine/blob/engine-2.5/doc/whats-new.md)
+-
++Starting from OpenQuake version 2.0 we have introduced a "code name" to honour earthquake scientists.
+
++The code name for version 2.6 is **Gutenberg**, in memory of [Beno Gutenberg](https://en.wikipedia.org/wiki/Beno_Gutenberg).
++* [What's new](https://github.com/gem/oq-engine/blob/engine-2.6/doc/whats-new.md)
++
++## Documentation
+-## Documentation (master tree)
+-->
+
+[![AGPLv3](https://www.gnu.org/graphics/agplv3-88x31.png)](https://www.gnu.org/licenses/agpl.html)
+[![PyPI Version](https://img.shields.io/pypi/v/openquake.engine.svg)](https://pypi.python.org/pypi/openquake.engine)
+![PyPI - Wheel](https://img.shields.io/pypi/wheel/openquake.engine.svg)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/gem/oq-engine.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/gem/oq-engine/context:python)
+
+### Current Long Term Support (LTS) release - for users wanting stability
+
+Current LTS version is the **OpenQuake Engine 3.16** 'Angela':
+
+* [What's new](https://github.com/gem/oq-engine/blob/engine-3.16/doc/whats-new.md)
+* [Documentation 3.16](https://github.com/gem/oq-engine/tree/engine-3.16#openquake-engine)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+
+
+### Latest release - for users needing the latest features
+
+Latest stable version is the **OpenQuake Engine 3.16**.
+
+<!-- GEM END -->
+
+## General overview
+
+The OpenQuake Engine software provides calculation and assessment of seismic hazard, risk and decision-making tools via the data, methods and standards that are being developed by **[GEM](http://www.globalquakemodel.org)** (Global Earthquake Model) and its collaborators.
+
+* [Installation](https://github.com/gem/oq-engine/blob/engine-3.16/doc/installing/README.md)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+* [Advanced user manual](https://docs.openquake.org/oq-engine/advanced/master/). _Disclaimer: It includes experimental features and is only recommended for users that are already familiar with the user's manual._
+* [FAQ](https://github.com/gem/oq-engine/blob/engine-3.16/doc/faq.md)
+* [Glossary of Terms](https://github.com/gem/oq-engine/blob/engine-3.16/doc/glossary.md)
+
+
+## Running the OpenQuake Engine
+
+* Using the command line [on Windows](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/windows.md)
+* Using the command line [on macOS and Linux](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/unix.md)
+* [Using the WebUI](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/server.md)
+
+## Visualizing outputs via QGIS
+
+<img src="https://github.com/gem/oq-infrastructure/raw/master/icons/irmt_icon.png" alt="IRMT Logo" width="50" >
+
+A [QGIS plug-in](https://plugins.qgis.org/plugins/svir/) is available for users that would like to visually explore the outputs from the engine.
+Check the documentation for instructions on how to [drive the engine](https://docs.openquake.org/oq-irmt-qgis/latest/14_driving_the_oqengine.html) and [visualize outputs](https://docs.openquake.org/oq-irmt-qgis/latest/15_viewer_dock.html). [Source code](https://github.com/gem/oq-irmt-qgis) also available.
+
+## For developers and contributors
+
+* [Architecture](https://github.com/gem/oq-engine/blob/engine-3.16/doc/adv-manual/architecture.rst)
+* [Calculation Workflow](https://github.com/gem/oq-engine/blob/engine-3.16/doc/calculation-workflow.md)
+* [Continuous integration and testing](https://github.com/gem/oq-engine/blob/engine-3.16/doc/testing.md)
+
+#### For contributors
+
+* [Development Philosophy and Coding Guidelines](https://github.com/gem/oq-engine/blob/engine-3.16/doc/development-guidelines.md)
+* [Source Code/API Documentation](http://docs.openquake.org/oq-engine/)
+* [HTTP REST API](https://github.com/gem/oq-engine/blob/engine-3.16/doc/web-api.md)
+* [Implementing a new GSIM](https://github.com/gem/oq-engine/blob/engine-3.16/doc/implementing-new-gsim.md)
+
+
+#### Mirrors
+
+A mirror of this repository, hosted in Pavia (Italy), is available at [https://mirror.openquake.org/git/GEM/oq-engine.git](https://mirror.openquake.org/git/GEM/oq-engine.git).
+
+The main download server ([downloads.openquake.org](https://downloads.openquake.org/)) is hosted in Nürnberg (Germany).
+
+
+## License
+
+The OpenQuake Engine is released under the **[GNU Affero Public License 3](https://github.com/gem/oq-engine/blob/engine-3.16/LICENSE)**.
+
+## Contacts
+
+* Support forum: https://groups.google.com/forum/#!forum/openquake-users
+* Twitter: [@gem_devs](https://twitter.com/gem_devs)
+* Email: info@openquake.org
+
+
+## Thanks
+
+***
+
+The OpenQuake Engine is developed by the **[Global Earthquake Model Foundation (GEM)](http://gem.foundation)** with the support of
+
+## Public Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nerc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/dpc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/gns_science.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/aus.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nrcan.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/NTU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nset.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/swiss_1.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/tem.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/usaid.jpg)
+
+## Private Partners
+
+#### Governors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/eucentre.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/FMGlobal.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/hannoverRe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/munichRe.jpg)
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/swissRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/verisk.png)
+
+
+#### Advisors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/axa.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/descartes.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/oneconcern.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/guycarpenter.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/partnerRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/global_parametrics.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/safehub.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/wtw.png)
+
+
+## Associate Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/apdim.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/cssc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/EERI_GEM.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaee.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaspei.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/IRDRICSU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/istructe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/oecd.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/undrr.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/unesco.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/usgs.jpg)
+
+
+## Project Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/aon.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sg.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sura.png)
+
+
+## Products Distribution Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/imagecat.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/nasdaq.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/verisk.png)
+
+***
+
+
+If you would like to help support development of OpenQuake, please contact us at [partnership@globalquakemodel.org](mailto:partnership@globalquakemodel.org).
+For more info visit the GEM website at https://www.globalquakemodel.org/partners
+
+
+
+
+%package -n python3-openquake.engine
+Summary: Computes earthquake hazard and risk.
+Provides: python-openquake.engine
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-openquake.engine
+# OpenQuake Engine
+
+![OpenQuake Logo](https://raw.githubusercontent.com/gem/oq-infrastructure/master/logos/oq-logo.png)
+
+The **OpenQuake Engine** is an open source application that allows users to compute **seismic hazard** and **seismic risk** of earthquakes on a global scale. DOI: [10.13117/openquake.engine](https://doi.org/10.13117/openquake.engine)
+
+<!-- GEM BEGIN: apply the following patch with the proper values for the next release
+-[![Build Status](https://travis-ci.org/gem/oq-engine.svg?branch=master)](https://travis-ci.org/gem/oq-engine)
+
+-### Current stable
++## OpenQuake Engine version 2.6 (Gutenberg)
+
+-Current stable version is the **OpenQuake Engine 2.5** 'Fourier'. The documentation is available at https://github.com/gem/oq-engine/tree/engine-2.5#openquake-engine.
+-* [What's new](https://github.com/gem/oq-engine/blob/engine-2.5/doc/whats-new.md)
+-
++Starting from OpenQuake version 2.0 we have introduced a "code name" to honour earthquake scientists.
+
++The code name for version 2.6 is **Gutenberg**, in memory of [Beno Gutenberg](https://en.wikipedia.org/wiki/Beno_Gutenberg).
++* [What's new](https://github.com/gem/oq-engine/blob/engine-2.6/doc/whats-new.md)
++
++## Documentation
+-## Documentation (master tree)
+-->
+
+[![AGPLv3](https://www.gnu.org/graphics/agplv3-88x31.png)](https://www.gnu.org/licenses/agpl.html)
+[![PyPI Version](https://img.shields.io/pypi/v/openquake.engine.svg)](https://pypi.python.org/pypi/openquake.engine)
+![PyPI - Wheel](https://img.shields.io/pypi/wheel/openquake.engine.svg)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/gem/oq-engine.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/gem/oq-engine/context:python)
+
+### Current Long Term Support (LTS) release - for users wanting stability
+
+Current LTS version is the **OpenQuake Engine 3.16** 'Angela':
+
+* [What's new](https://github.com/gem/oq-engine/blob/engine-3.16/doc/whats-new.md)
+* [Documentation 3.16](https://github.com/gem/oq-engine/tree/engine-3.16#openquake-engine)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+
+
+### Latest release - for users needing the latest features
+
+Latest stable version is the **OpenQuake Engine 3.16**.
+
+<!-- GEM END -->
+
+## General overview
+
+The OpenQuake Engine software provides calculation and assessment of seismic hazard, risk and decision-making tools via the data, methods and standards that are being developed by **[GEM](http://www.globalquakemodel.org)** (Global Earthquake Model) and its collaborators.
+
+* [Installation](https://github.com/gem/oq-engine/blob/engine-3.16/doc/installing/README.md)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+* [Advanced user manual](https://docs.openquake.org/oq-engine/advanced/master/). _Disclaimer: It includes experimental features and is only recommended for users that are already familiar with the user's manual._
+* [FAQ](https://github.com/gem/oq-engine/blob/engine-3.16/doc/faq.md)
+* [Glossary of Terms](https://github.com/gem/oq-engine/blob/engine-3.16/doc/glossary.md)
+
+
+## Running the OpenQuake Engine
+
+* Using the command line [on Windows](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/windows.md)
+* Using the command line [on macOS and Linux](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/unix.md)
+* [Using the WebUI](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/server.md)
+
+## Visualizing outputs via QGIS
+
+<img src="https://github.com/gem/oq-infrastructure/raw/master/icons/irmt_icon.png" alt="IRMT Logo" width="50" >
+
+A [QGIS plug-in](https://plugins.qgis.org/plugins/svir/) is available for users that would like to visually explore the outputs from the engine.
+Check the documentation for instructions on how to [drive the engine](https://docs.openquake.org/oq-irmt-qgis/latest/14_driving_the_oqengine.html) and [visualize outputs](https://docs.openquake.org/oq-irmt-qgis/latest/15_viewer_dock.html). [Source code](https://github.com/gem/oq-irmt-qgis) also available.
+
+## For developers and contributors
+
+* [Architecture](https://github.com/gem/oq-engine/blob/engine-3.16/doc/adv-manual/architecture.rst)
+* [Calculation Workflow](https://github.com/gem/oq-engine/blob/engine-3.16/doc/calculation-workflow.md)
+* [Continuous integration and testing](https://github.com/gem/oq-engine/blob/engine-3.16/doc/testing.md)
+
+#### For contributors
+
+* [Development Philosophy and Coding Guidelines](https://github.com/gem/oq-engine/blob/engine-3.16/doc/development-guidelines.md)
+* [Source Code/API Documentation](http://docs.openquake.org/oq-engine/)
+* [HTTP REST API](https://github.com/gem/oq-engine/blob/engine-3.16/doc/web-api.md)
+* [Implementing a new GSIM](https://github.com/gem/oq-engine/blob/engine-3.16/doc/implementing-new-gsim.md)
+
+
+#### Mirrors
+
+A mirror of this repository, hosted in Pavia (Italy), is available at [https://mirror.openquake.org/git/GEM/oq-engine.git](https://mirror.openquake.org/git/GEM/oq-engine.git).
+
+The main download server ([downloads.openquake.org](https://downloads.openquake.org/)) is hosted in Nürnberg (Germany).
+
+
+## License
+
+The OpenQuake Engine is released under the **[GNU Affero Public License 3](https://github.com/gem/oq-engine/blob/engine-3.16/LICENSE)**.
+
+## Contacts
+
+* Support forum: https://groups.google.com/forum/#!forum/openquake-users
+* Twitter: [@gem_devs](https://twitter.com/gem_devs)
+* Email: info@openquake.org
+
+
+## Thanks
+
+***
+
+The OpenQuake Engine is developed by the **[Global Earthquake Model Foundation (GEM)](http://gem.foundation)** with the support of
+
+## Public Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nerc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/dpc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/gns_science.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/aus.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nrcan.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/NTU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nset.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/swiss_1.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/tem.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/usaid.jpg)
+
+## Private Partners
+
+#### Governors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/eucentre.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/FMGlobal.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/hannoverRe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/munichRe.jpg)
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/swissRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/verisk.png)
+
+
+#### Advisors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/axa.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/descartes.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/oneconcern.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/guycarpenter.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/partnerRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/global_parametrics.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/safehub.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/wtw.png)
+
+
+## Associate Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/apdim.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/cssc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/EERI_GEM.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaee.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaspei.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/IRDRICSU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/istructe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/oecd.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/undrr.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/unesco.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/usgs.jpg)
+
+
+## Project Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/aon.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sg.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sura.png)
+
+
+## Products Distribution Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/imagecat.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/nasdaq.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/verisk.png)
+
+***
+
+
+If you would like to help support development of OpenQuake, please contact us at [partnership@globalquakemodel.org](mailto:partnership@globalquakemodel.org).
+For more info visit the GEM website at https://www.globalquakemodel.org/partners
+
+
+
+
+%package help
+Summary: Development documents and examples for openquake.engine
+Provides: python3-openquake.engine-doc
+%description help
+# OpenQuake Engine
+
+![OpenQuake Logo](https://raw.githubusercontent.com/gem/oq-infrastructure/master/logos/oq-logo.png)
+
+The **OpenQuake Engine** is an open source application that allows users to compute **seismic hazard** and **seismic risk** of earthquakes on a global scale. DOI: [10.13117/openquake.engine](https://doi.org/10.13117/openquake.engine)
+
+<!-- GEM BEGIN: apply the following patch with the proper values for the next release
+-[![Build Status](https://travis-ci.org/gem/oq-engine.svg?branch=master)](https://travis-ci.org/gem/oq-engine)
+
+-### Current stable
++## OpenQuake Engine version 2.6 (Gutenberg)
+
+-Current stable version is the **OpenQuake Engine 2.5** 'Fourier'. The documentation is available at https://github.com/gem/oq-engine/tree/engine-2.5#openquake-engine.
+-* [What's new](https://github.com/gem/oq-engine/blob/engine-2.5/doc/whats-new.md)
+-
++Starting from OpenQuake version 2.0 we have introduced a "code name" to honour earthquake scientists.
+
++The code name for version 2.6 is **Gutenberg**, in memory of [Beno Gutenberg](https://en.wikipedia.org/wiki/Beno_Gutenberg).
++* [What's new](https://github.com/gem/oq-engine/blob/engine-2.6/doc/whats-new.md)
++
++## Documentation
+-## Documentation (master tree)
+-->
+
+[![AGPLv3](https://www.gnu.org/graphics/agplv3-88x31.png)](https://www.gnu.org/licenses/agpl.html)
+[![PyPI Version](https://img.shields.io/pypi/v/openquake.engine.svg)](https://pypi.python.org/pypi/openquake.engine)
+![PyPI - Wheel](https://img.shields.io/pypi/wheel/openquake.engine.svg)
+[![Language grade: Python](https://img.shields.io/lgtm/grade/python/g/gem/oq-engine.svg?logo=lgtm&logoWidth=18)](https://lgtm.com/projects/g/gem/oq-engine/context:python)
+
+### Current Long Term Support (LTS) release - for users wanting stability
+
+Current LTS version is the **OpenQuake Engine 3.16** 'Angela':
+
+* [What's new](https://github.com/gem/oq-engine/blob/engine-3.16/doc/whats-new.md)
+* [Documentation 3.16](https://github.com/gem/oq-engine/tree/engine-3.16#openquake-engine)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+
+
+### Latest release - for users needing the latest features
+
+Latest stable version is the **OpenQuake Engine 3.16**.
+
+<!-- GEM END -->
+
+## General overview
+
+The OpenQuake Engine software provides calculation and assessment of seismic hazard, risk and decision-making tools via the data, methods and standards that are being developed by **[GEM](http://www.globalquakemodel.org)** (Global Earthquake Model) and its collaborators.
+
+* [Installation](https://github.com/gem/oq-engine/blob/engine-3.16/doc/installing/README.md)
+* [User's manual](https://docs.openquake.org/oq-engine/manual/latest/)
+* [Advanced user manual](https://docs.openquake.org/oq-engine/advanced/master/). _Disclaimer: It includes experimental features and is only recommended for users that are already familiar with the user's manual._
+* [FAQ](https://github.com/gem/oq-engine/blob/engine-3.16/doc/faq.md)
+* [Glossary of Terms](https://github.com/gem/oq-engine/blob/engine-3.16/doc/glossary.md)
+
+
+## Running the OpenQuake Engine
+
+* Using the command line [on Windows](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/windows.md)
+* Using the command line [on macOS and Linux](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/unix.md)
+* [Using the WebUI](https://github.com/gem/oq-engine/blob/engine-3.16/doc/running/server.md)
+
+## Visualizing outputs via QGIS
+
+<img src="https://github.com/gem/oq-infrastructure/raw/master/icons/irmt_icon.png" alt="IRMT Logo" width="50" >
+
+A [QGIS plug-in](https://plugins.qgis.org/plugins/svir/) is available for users that would like to visually explore the outputs from the engine.
+Check the documentation for instructions on how to [drive the engine](https://docs.openquake.org/oq-irmt-qgis/latest/14_driving_the_oqengine.html) and [visualize outputs](https://docs.openquake.org/oq-irmt-qgis/latest/15_viewer_dock.html). [Source code](https://github.com/gem/oq-irmt-qgis) also available.
+
+## For developers and contributors
+
+* [Architecture](https://github.com/gem/oq-engine/blob/engine-3.16/doc/adv-manual/architecture.rst)
+* [Calculation Workflow](https://github.com/gem/oq-engine/blob/engine-3.16/doc/calculation-workflow.md)
+* [Continuous integration and testing](https://github.com/gem/oq-engine/blob/engine-3.16/doc/testing.md)
+
+#### For contributors
+
+* [Development Philosophy and Coding Guidelines](https://github.com/gem/oq-engine/blob/engine-3.16/doc/development-guidelines.md)
+* [Source Code/API Documentation](http://docs.openquake.org/oq-engine/)
+* [HTTP REST API](https://github.com/gem/oq-engine/blob/engine-3.16/doc/web-api.md)
+* [Implementing a new GSIM](https://github.com/gem/oq-engine/blob/engine-3.16/doc/implementing-new-gsim.md)
+
+
+#### Mirrors
+
+A mirror of this repository, hosted in Pavia (Italy), is available at [https://mirror.openquake.org/git/GEM/oq-engine.git](https://mirror.openquake.org/git/GEM/oq-engine.git).
+
+The main download server ([downloads.openquake.org](https://downloads.openquake.org/)) is hosted in Nürnberg (Germany).
+
+
+## License
+
+The OpenQuake Engine is released under the **[GNU Affero Public License 3](https://github.com/gem/oq-engine/blob/engine-3.16/LICENSE)**.
+
+## Contacts
+
+* Support forum: https://groups.google.com/forum/#!forum/openquake-users
+* Twitter: [@gem_devs](https://twitter.com/gem_devs)
+* Email: info@openquake.org
+
+
+## Thanks
+
+***
+
+The OpenQuake Engine is developed by the **[Global Earthquake Model Foundation (GEM)](http://gem.foundation)** with the support of
+
+## Public Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nerc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/dpc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/gns_science.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/aus.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nrcan.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/NTU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/nset.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/swiss_1.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/tem.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/public/usaid.jpg)
+
+## Private Partners
+
+#### Governors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/eucentre.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/FMGlobal.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/hannoverRe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/munichRe.jpg)
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/swissRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/governors/verisk.png)
+
+
+#### Advisors
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/axa.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/descartes.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/oneconcern.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/guycarpenter.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/partnerRe.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/global_parametrics.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/safehub.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/private/advisors/wtw.png)
+
+
+## Associate Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/apdim.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/cssc.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/EERI_GEM.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaee.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/iaspei.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/IRDRICSU.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/istructe.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/oecd.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/undrr.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/unesco.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/associate/usgs.jpg)
+
+
+## Project Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/aon.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sg.jpg)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/project/sura.png)
+
+
+## Products Distribution Partners
+
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/imagecat.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/nasdaq.png)
+![](https://github.com/gem/oq-infrastructure/raw/master/logos/prod_distr/verisk.png)
+
+***
+
+
+If you would like to help support development of OpenQuake, please contact us at [partnership@globalquakemodel.org](mailto:partnership@globalquakemodel.org).
+For more info visit the GEM website at https://www.globalquakemodel.org/partners
+
+
+
+
+%prep
+%autosetup -n openquake.engine-3.16.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-openquake.engine -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Jun 08 2023 Python_Bot <Python_Bot@openeuler.org> - 3.16.3-1
+- Package Spec generated