summaryrefslogtreecommitdiff
path: root/python-openrgb-python.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-18 04:41:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-18 04:41:25 +0000
commitdf56481d202603f2f91d11397622be643cd9dd74 (patch)
tree859e796107139543d58eed42a3fa875c7835486d /python-openrgb-python.spec
parent6497345428730831b4a6fce15fc3b3e17b40b15e (diff)
automatic import of python-openrgb-python
Diffstat (limited to 'python-openrgb-python.spec')
-rw-r--r--python-openrgb-python.spec291
1 files changed, 291 insertions, 0 deletions
diff --git a/python-openrgb-python.spec b/python-openrgb-python.spec
new file mode 100644
index 0000000..2dfd56a
--- /dev/null
+++ b/python-openrgb-python.spec
@@ -0,0 +1,291 @@
+%global _empty_manifest_terminate_build 0
+Name: python-openrgb-python
+Version: 0.2.15
+Release: 1
+Summary: A python client for the OpenRGB SDK
+License: GNU General Public License v3 (GPLv3)
+URL: https://github.com/jath03/openrgb-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f7/b5/92e121fb61e1f5c8c2275ec026da549fd722acbceb5e262bfcdcf23cdb69/openrgb-python-0.2.15.tar.gz
+BuildArch: noarch
+
+
+%description
+# OpenRGB-Python
+
+
+[![Documentation Status](https://readthedocs.org/projects/openrgb-python/badge/?version=latest)](https://openrgb-python.readthedocs.io/en/latest/?badge=latest)
+
+OpenRGB-Python is a client for the [OpenRGB SDK](https://gitlab.com/CalcProgrammer1/OpenRGB#openrgb-sdk),
+a manufacturer-independent, cross-platform way to control your RGB devices.
+OpenRGB-Python can be used to interface with other programs, create custom
+effects, or anything else you can think of!
+
+I started this project because I wanted to be able to control the color of my lights based on temps. I tried to implement the features in the best (easiest to use) way possible.
+
+SDK Feature Support:
+ - [x] Setting client name
+ - [x] Getting device info
+ - [x] Setting color by device
+ - [x] Setting color by zone
+ - [x] Setting color by led
+ - [x] Setting mode
+ - [x] Setting custom mode
+ - [x] Resizing zones
+
+Additional Features (Not part of the OpenRGB SDK):
+ - [x] Loading profiles
+ - [x] Saving profiles
+
+# Installation
+
+requires python >= 3.7
+
+Use this method for the newest, but possibly buggy, package:
+
+`pip3 install git+https://github.com/jath03/openrgb-python#egg=openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb-git`
+
+For a more stable package:
+
+`pip3 install openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb`
+
+Thanks to @GabMus for the AUR packages
+
+# Usage
+
+```python
+from openrgb import OpenRGBClient
+from openrgb.utils import RGBColor, DeviceType
+
+client = OpenRGBClient()
+
+client.clear() # Turns everything off
+
+motherboard = client.get_devices_by_type(DeviceType.MOTHERBOARD)[0]
+
+motherboard.set_color(RGBColor(0, 255, 0))
+motherboard.zones[0].set_color(RGBColor(255, 0, 0))
+motherboard.zones[1].leds[0].set_color(RGBColor.fromHSV(0, 100, 100))
+motherboard.set_mode("breathing")
+client.save_profile("profile1")
+```
+
+# Documentation
+
+https://openrgb-python.readthedocs.io/en/latest/
+
+
+For an alternative python implementation, check out [B Horn](https://github.com/bahorn)'s [OpenRGB-PyClient](https://github.com/bahorn/OpenRGB-PyClient)
+
+
+
+
+%package -n python3-openrgb-python
+Summary: A python client for the OpenRGB SDK
+Provides: python-openrgb-python
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-openrgb-python
+# OpenRGB-Python
+
+
+[![Documentation Status](https://readthedocs.org/projects/openrgb-python/badge/?version=latest)](https://openrgb-python.readthedocs.io/en/latest/?badge=latest)
+
+OpenRGB-Python is a client for the [OpenRGB SDK](https://gitlab.com/CalcProgrammer1/OpenRGB#openrgb-sdk),
+a manufacturer-independent, cross-platform way to control your RGB devices.
+OpenRGB-Python can be used to interface with other programs, create custom
+effects, or anything else you can think of!
+
+I started this project because I wanted to be able to control the color of my lights based on temps. I tried to implement the features in the best (easiest to use) way possible.
+
+SDK Feature Support:
+ - [x] Setting client name
+ - [x] Getting device info
+ - [x] Setting color by device
+ - [x] Setting color by zone
+ - [x] Setting color by led
+ - [x] Setting mode
+ - [x] Setting custom mode
+ - [x] Resizing zones
+
+Additional Features (Not part of the OpenRGB SDK):
+ - [x] Loading profiles
+ - [x] Saving profiles
+
+# Installation
+
+requires python >= 3.7
+
+Use this method for the newest, but possibly buggy, package:
+
+`pip3 install git+https://github.com/jath03/openrgb-python#egg=openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb-git`
+
+For a more stable package:
+
+`pip3 install openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb`
+
+Thanks to @GabMus for the AUR packages
+
+# Usage
+
+```python
+from openrgb import OpenRGBClient
+from openrgb.utils import RGBColor, DeviceType
+
+client = OpenRGBClient()
+
+client.clear() # Turns everything off
+
+motherboard = client.get_devices_by_type(DeviceType.MOTHERBOARD)[0]
+
+motherboard.set_color(RGBColor(0, 255, 0))
+motherboard.zones[0].set_color(RGBColor(255, 0, 0))
+motherboard.zones[1].leds[0].set_color(RGBColor.fromHSV(0, 100, 100))
+motherboard.set_mode("breathing")
+client.save_profile("profile1")
+```
+
+# Documentation
+
+https://openrgb-python.readthedocs.io/en/latest/
+
+
+For an alternative python implementation, check out [B Horn](https://github.com/bahorn)'s [OpenRGB-PyClient](https://github.com/bahorn/OpenRGB-PyClient)
+
+
+
+
+%package help
+Summary: Development documents and examples for openrgb-python
+Provides: python3-openrgb-python-doc
+%description help
+# OpenRGB-Python
+
+
+[![Documentation Status](https://readthedocs.org/projects/openrgb-python/badge/?version=latest)](https://openrgb-python.readthedocs.io/en/latest/?badge=latest)
+
+OpenRGB-Python is a client for the [OpenRGB SDK](https://gitlab.com/CalcProgrammer1/OpenRGB#openrgb-sdk),
+a manufacturer-independent, cross-platform way to control your RGB devices.
+OpenRGB-Python can be used to interface with other programs, create custom
+effects, or anything else you can think of!
+
+I started this project because I wanted to be able to control the color of my lights based on temps. I tried to implement the features in the best (easiest to use) way possible.
+
+SDK Feature Support:
+ - [x] Setting client name
+ - [x] Getting device info
+ - [x] Setting color by device
+ - [x] Setting color by zone
+ - [x] Setting color by led
+ - [x] Setting mode
+ - [x] Setting custom mode
+ - [x] Resizing zones
+
+Additional Features (Not part of the OpenRGB SDK):
+ - [x] Loading profiles
+ - [x] Saving profiles
+
+# Installation
+
+requires python >= 3.7
+
+Use this method for the newest, but possibly buggy, package:
+
+`pip3 install git+https://github.com/jath03/openrgb-python#egg=openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb-git`
+
+For a more stable package:
+
+`pip3 install openrgb-python`
+
+Arch Linux:
+`yay -S python-openrgb`
+
+Thanks to @GabMus for the AUR packages
+
+# Usage
+
+```python
+from openrgb import OpenRGBClient
+from openrgb.utils import RGBColor, DeviceType
+
+client = OpenRGBClient()
+
+client.clear() # Turns everything off
+
+motherboard = client.get_devices_by_type(DeviceType.MOTHERBOARD)[0]
+
+motherboard.set_color(RGBColor(0, 255, 0))
+motherboard.zones[0].set_color(RGBColor(255, 0, 0))
+motherboard.zones[1].leds[0].set_color(RGBColor.fromHSV(0, 100, 100))
+motherboard.set_mode("breathing")
+client.save_profile("profile1")
+```
+
+# Documentation
+
+https://openrgb-python.readthedocs.io/en/latest/
+
+
+For an alternative python implementation, check out [B Horn](https://github.com/bahorn)'s [OpenRGB-PyClient](https://github.com/bahorn/OpenRGB-PyClient)
+
+
+
+
+%prep
+%autosetup -n openrgb-python-0.2.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-openrgb-python -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.2.15-1
+- Package Spec generated