summaryrefslogtreecommitdiff
path: root/python-opentelemetry-exporter-prometheus.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 23:39:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 23:39:57 +0000
commit0c9b31cd5487c213f6d58073734a13894d4cbff6 (patch)
treefcc714fb6c7fadd2642d662382a667ed33363afa /python-opentelemetry-exporter-prometheus.spec
parentc2db0b6c73d88183c1850e2bba34ae36cf9a0729 (diff)
automatic import of python-opentelemetry-exporter-prometheus
Diffstat (limited to 'python-opentelemetry-exporter-prometheus.spec')
-rw-r--r--python-opentelemetry-exporter-prometheus.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-opentelemetry-exporter-prometheus.spec b/python-opentelemetry-exporter-prometheus.spec
new file mode 100644
index 0000000..8eef331
--- /dev/null
+++ b/python-opentelemetry-exporter-prometheus.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opentelemetry-exporter-prometheus
+Version: 1.12.0rc1
+Release: 1
+Summary: Prometheus Metric Exporter for OpenTelemetry
+License: Apache-2.0
+URL: https://github.com/open-telemetry/opentelemetry-python/tree/main/exporter/opentelemetry-exporter-prometheus
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/87/fe/e94cf40c01f2ba78dc4854c8ea61be2f6d418387c2f0f739232dba716419/opentelemetry-exporter-prometheus-1.12.0rc1.tar.gz
+BuildArch: noarch
+
+Requires: python3-prometheus-client
+Requires: python3-opentelemetry-api
+Requires: python3-opentelemetry-sdk
+
+%description
+|pypi|
+This library allows to export metrics data to `Prometheus <https://prometheus.io/>`_.
+
+%package -n python3-opentelemetry-exporter-prometheus
+Summary: Prometheus Metric Exporter for OpenTelemetry
+Provides: python-opentelemetry-exporter-prometheus
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opentelemetry-exporter-prometheus
+|pypi|
+This library allows to export metrics data to `Prometheus <https://prometheus.io/>`_.
+
+%package help
+Summary: Development documents and examples for opentelemetry-exporter-prometheus
+Provides: python3-opentelemetry-exporter-prometheus-doc
+%description help
+|pypi|
+This library allows to export metrics data to `Prometheus <https://prometheus.io/>`_.
+
+%prep
+%autosetup -n opentelemetry-exporter-prometheus-1.12.0rc1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opentelemetry-exporter-prometheus -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.12.0rc1-1
+- Package Spec generated