summaryrefslogtreecommitdiff
path: root/python-opentracing.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 09:45:07 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 09:45:07 +0000
commit5b68c13387bb7d896fec58cebde99b87e8f64361 (patch)
tree16240fd8d29ad177fe46ff0547ec5d8a633843d4 /python-opentracing.spec
parent44679c2bb494beea4cc20047478b7fc1e732be66 (diff)
automatic import of python-opentracing
Diffstat (limited to 'python-opentracing.spec')
-rw-r--r--python-opentracing.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-opentracing.spec b/python-opentracing.spec
new file mode 100644
index 0000000..e89392e
--- /dev/null
+++ b/python-opentracing.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opentracing
+Version: 2.4.0
+Release: 1
+Summary: OpenTracing API for Python. See documentation at http://opentracing.io
+License: Apache License 2.0
+URL: https://github.com/opentracing/opentracing-python
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/51/28/2dba4e3efb64cc59d4311081a5ddad1dde20a19b69cd0f677cdb2f2c29a6/opentracing-2.4.0.tar.gz
+BuildArch: noarch
+
+
+%description
+|GitterChat| |BuildStatus| |PyPI| |ReadTheDocs|
+This library is a Python platform API for OpenTracing.
+
+%package -n python3-opentracing
+Summary: OpenTracing API for Python. See documentation at http://opentracing.io
+Provides: python-opentracing
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opentracing
+|GitterChat| |BuildStatus| |PyPI| |ReadTheDocs|
+This library is a Python platform API for OpenTracing.
+
+%package help
+Summary: Development documents and examples for opentracing
+Provides: python3-opentracing-doc
+%description help
+|GitterChat| |BuildStatus| |PyPI| |ReadTheDocs|
+This library is a Python platform API for OpenTracing.
+
+%prep
+%autosetup -n opentracing-2.4.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opentracing -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.0-1
+- Package Spec generated